php-oauth_2.0.2+1.2.3-1build2_i386.deb


Advertisement

Description

php-oauth - OAuth 1.0 consumer and provider extension

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename php-oauth_2.0.2+1.2.3-1build2_i386.deb
Package name php-oauth
Package version 2.0.2+1.2.3
Package release 1build2
Package architecture i386
Package type deb
Category universe/php
Homepage http://pecl.php.net/package/oauth
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 35.89 KB
Installed size 109.00 KB
OAuth is an authorization protocol built on top of HTTP which allows
applications to securely access data without having to store
usernames and passwords.
This package provides an API for fetching and serving OAuth
protected resources.

Alternatives

Package Version Architecture Repository
php-oauth_2.0.2+1.2.3-1build2_amd64.deb 2.0.2+1.2.3 amd64 Ubuntu Universe
php-oauth - - -

Requires

Name Value
libc6 >= 2.4
php-common >= 1:7.0+33~
phpapi-20170718 -

Provides

Name Value
php7.2-oauth -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package php-oauth_2.0.2+1.2.3-1build2_i386.deb
Source Package php-oauth

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install php-oauth deb package:
    # sudo apt-get install php-oauth

Files

Path
/etc/php/7.2/mods-available/oauth.ini
/usr/lib/php/20170718/oauth.so
/usr/share/doc/php-oauth/changelog.Debian.gz
/usr/share/doc/php-oauth/copyright

Changelog

2018-02-02 - Nishanth Aravamudan <nish.aravamudan@canonical.com>
php-oauth (2.0.2+1.2.3-1build2) bionic; urgency=medium
* No-change rebuild for PHP7.2
2017-05-01 - Nishanth Aravamudan <nish.aravamudan@canonical.com>
php-oauth (2.0.2+1.2.3-1build1) artful; urgency=medium
* No-change rebuild for PHP7.1. 
2016-11-07 - Ondřej Surý <ondrej@debian.org>
php-oauth (2.0.2+1.2.3-1) unstable; urgency=medium
* Imported Upstream version 2.0.2+1.2.3
2016-04-29 - Ondřej Surý <ondrej@debian.org>
php-oauth (2.0.1+1.2.3+-2) unstable; urgency=medium
* Move the default makefile snippet to dh-php and use a simple d/rules
with dh-php >= 0.12~
2016-04-28 - Ondřej Surý <ondrej@debian.org>
php-oauth (2.0.1+1.2.3+-1) unstable; urgency=medium
* Imported Upstream version 2.0.1+1.2.3+
* Improve d/rules so it can be used with both single or multiple PECL
upstream versions, controlled by looking for package-MAJOR.MINOR.xml,
package-MAJOR.xml and package.xml in this order
2016-03-28 - Ondřej Surý <ondrej@debian.org>
php-oauth (2.0.1+1.2.3-1) unstable; urgency=medium
[ Prach Pongpanich ]
* Fix debian/watch to correct package name
* Bump standards version to 3.9.5
[ Ondřej Surý ]
* Update gbp.conf for new branches
* Bump standards version to 3.9.7
* Imported Upstream version 2.0.1+1.2.3
* Update packaging for dual-versions for PHP 5.6 and PHP 7.0
2013-10-21 - Ondřej Surý <ondrej@debian.org>
php-oauth (1.2.3-1) unstable; urgency=low
[ Prach Pongpanich ]
* Initial release. (Closes: #668315)
* Update a gbp.conf file
[ Ondřej Surý ]
* Use dh_php5 for generating Depends
* Update debian/copyright to match the package
* Use pristine-tar
* Update debian/watch to match to package
* Add myself to uploaders
* The main package should be php5-oauth and not php-oauth

See Also

Package Description
php-parser_3.1.4-1_all.deb convert PHP code into abstract syntax tree
php-patchwork-utf8_1.3.1-1_all.deb UTF-8 strings handling for PHP
php-pclzip_2.8.2-4_all.deb ZIP archive manager class for PHP
php-pecl-http-dev_3.1.0+2.6.0-4build8_all.deb pecl_http module for PHP Extended HTTP Support [dummy]
php-pecl-http_3.1.0+2.6.0-4build8_all.deb pecl_http module for PHP Extended HTTP Support [dummy]
php-phar-io-manifest_1.0.1-2_all.deb reading phar.io manifest information from a PHP Archive (Phar)
php-phar-io-version_1.0.1-1_all.deb handling version information and constraint
php-php-gettext_1.0.12-0.1_all.deb read gettext MO files directly, without requiring anything other than PHP
php-phpdbg_7.2+60ubuntu1_all.deb server-side, HTML-embedded scripting language (PHPDBG binary) (default)
php-phpdocumentor-reflection-common_1.0.1-1_all.deb Common reflection classes - phpDocumentor component
php-phpdocumentor-reflection-docblock_4.2.0-2_all.deb DocBlock parser - phpDocumentor component
php-phpdocumentor-type-resolver_0.4.0-2_all.deb TypeResolver and FqsenResolver - phpDocumentor component
php-phpseclib_2.0.9-1_all.deb implementations of an arbitrary-precision integer arithmetic library
php-phpspec-prophecy_1.7.3-1_all.deb object mocking framework - phpspec component
php-pimple_3.0.2-2ubuntu1_all.deb simple dependency injection container -- class
Advertisement
Advertisement