php-horde-db_2.4.0-1ubuntu2_all.deb


Advertisement

Description

php-horde-db - Horde Database Libraries

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename php-horde-db_2.4.0-1ubuntu2_all.deb
Package name php-horde-db
Package version 2.4.0
Package release 1ubuntu2
Package architecture all
Package type deb
Category universe/php
Homepage http://www.horde.org/
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 67.92 KB
Installed size 541.00 KB
Horde database/SQL abstraction layer
This package is part of Horde, a web application Framework written in PHP with
modules like IMP (webmail), Turba (contacts), Kronolith (calendar), Nag (task
list), Gollem (file manager), etc.

Alternatives

Package Version Architecture Repository
php-horde-db_2.4.0-1ubuntu2_all.deb 2.4.0 all Ubuntu Universe
php-horde-db - - -

Requires

Name Value
php-cli -
php-common -
php-horde-date << 3.0.0~alpha1
php-horde-date >= 2.0.0
php-horde-exception << 3.0.0~alpha1
php-horde-exception >= 2.0.0
php-horde-support >= 2.0.0
php-horde-support << 3.0.0~alpha1
php-horde-util << 3.0.0~alpha1
php-horde-util >= 2.0.0

Download

Type URL
Mirror archive.ubuntu.com
Binary Package php-horde-db_2.4.0-1ubuntu2_all.deb
Source Package php-horde-db

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install php-horde-db deb package:
    # sudo apt-get install php-horde-db

Files

Path
/usr/bin/horde-db-migrate-component
/usr/share/doc/php-horde-db/README
/usr/share/doc/php-horde-db/README_TESTING
/usr/share/doc/php-horde-db/TODO
/usr/share/doc/php-horde-db/UPGRADING
/usr/share/doc/php-horde-db/changelog.Debian.gz
/usr/share/doc/php-horde-db/copyright
/usr/share/doc/php-horde-db/horde.yml
/usr/share/doc/php-horde-db/package.xml.gz
/usr/share/php/.registry/.channel.pear.horde.org/horde_db.reg
/usr/share/php/Horde/Db.php
/usr/share/php/Horde/Db/Adapter.php
/usr/share/php/Horde/Db/Exception.php
/usr/share/php/Horde/Db/SearchParser.php
/usr/share/php/Horde/Db/StatementParser.php
/usr/share/php/Horde/Db/Value.php
/usr/share/php/Horde/Db/Adapter/Base.php
/usr/share/php/Horde/Db/Adapter/Mysql.php
/usr/share/php/Horde/Db/Adapter/Mysqli.php
/usr/share/php/Horde/Db/Adapter/Oci8.php
/usr/share/php/Horde/Db/Adapter/SplitRead.php
/usr/share/php/Horde/Db/Adapter/Base/Column.php
/usr/share/php/Horde/Db/Adapter/Base/ColumnDefinition.php
/usr/share/php/Horde/Db/Adapter/Base/Index.php
/usr/share/php/Horde/Db/Adapter/Base/Result.php
/usr/share/php/Horde/Db/Adapter/Base/Schema.php
/usr/share/php/Horde/Db/Adapter/Base/Table.php
/usr/share/php/Horde/Db/Adapter/Base/TableDefinition.php
/usr/share/php/Horde/Db/Adapter/Mysql/Column.php
/usr/share/php/Horde/Db/Adapter/Mysql/Result.php
/usr/share/php/Horde/Db/Adapter/Mysql/Schema.php
/usr/share/php/Horde/Db/Adapter/Mysqli/Result.php
/usr/share/php/Horde/Db/Adapter/Oracle/Column.php
/usr/share/php/Horde/Db/Adapter/Oracle/Result.php
/usr/share/php/Horde/Db/Adapter/Oracle/Schema.php
/usr/share/php/Horde/Db/Adapter/Oracle/TableDefinition.php
/usr/share/php/Horde/Db/Adapter/Pdo/Base.php
/usr/share/php/Horde/Db/Adapter/Pdo/Mysql.php
/usr/share/php/Horde/Db/Adapter/Pdo/Pgsql.php
/usr/share/php/Horde/Db/Adapter/Pdo/Result.php
/usr/share/php/Horde/Db/Adapter/Pdo/Sqlite.php
/usr/share/php/Horde/Db/Adapter/Postgresql/Column.php
/usr/share/php/Horde/Db/Adapter/Postgresql/Schema.php
/usr/share/php/Horde/Db/Adapter/Sqlite/Column.php
/usr/share/php/Horde/Db/Adapter/Sqlite/Schema.php
/usr/share/php/Horde/Db/Migration/Base.php
/usr/share/php/Horde/Db/Migration/Exception.php
/usr/share/php/Horde/Db/Migration/Migrator.php
/usr/share/php/Horde/Db/Value/Binary.php
/usr/share/php/Horde/Db/Value/Lob.php
/usr/share/php/Horde/Db/Value/Text.php

Changelog

2018-02-16 - Nishanth Aravamudan <nish.aravamudan@canonical.com>
php-horde-db (2.4.0-1ubuntu2) bionic; urgency=medium
* debian/patches/phpunit6_compat.patch: PHPUnit 6 has namespaced
classes.
2017-11-20 - Dimitri John Ledkov <xnox@ubuntu.com>
php-horde-db (2.4.0-1ubuntu1) bionic; urgency=medium
* Cherrypick upstream pull-request with pgsql10 support.
2017-06-30 - Mathieu Parent <sathieu@debian.org>
php-horde-db (2.4.0-1) unstable; urgency=medium
* New upstream version 2.4.0
2016-12-17 - Mathieu Parent <sathieu@debian.org>
php-horde-db (2.3.4-1) unstable; urgency=medium
* New upstream version 2.3.4
2016-09-09 - Mathieu Parent <sathieu@debian.org>
php-horde-db (2.3.3-1) unstable; urgency=medium
* New upstream version 2.3.3
2016-07-07 - Mathieu Parent <sathieu@debian.org>
php-horde-db (2.3.2-1) unstable; urgency=medium
* New upstream version 2.3.2
2016-06-22 - Mathieu Parent <sathieu@debian.org>
php-horde-db (2.3.1-6) unstable; urgency=medium
* MySQL: Use a non-blank password, fixed (Closes: #827491)
2016-06-18 - Mathieu Parent <sathieu@debian.org>
php-horde-db (2.3.1-5) unstable; urgency=medium
* Update test compatibility with MySQL 5.7 (Closes: #827491, LP #1568015), by
setting the password.
* MySQL: Use a non-blank password.
2016-06-07 - Mathieu Parent <sathieu@debian.org>
php-horde-db (2.3.1-4) unstable; urgency=medium
* Update Standards-Version to 3.9.8, no change
* Updated d/watch to use https
2016-03-19 - Mathieu Parent <sathieu@debian.org>
php-horde-db (2.3.1-3) unstable; urgency=medium
* Fix debian/tests/control: php-sqlite -> php-sqlite3

See Also

Package Description
php-horde-editor_2.0.4+debian0-8_all.deb Horde Editor API
php-horde-elasticsearch_1.0.4-1_all.deb Horde ElasticSearch client
php-horde-exception_2.0.8-2ubuntu1_all.deb Horde Exception Handler
php-horde-feed_2.0.4-3ubuntu1_all.deb Horde Feed libraries
php-horde-form_2.0.18-1_all.deb Horde Form API
php-horde-gollem_3.0.12-1_all.deb Web-based file manager
php-horde-group_2.1.1-2_all.deb Horde User Groups System
php-horde-groupware_5.2.22-1_all.deb Horde Groupware
php-horde-hashtable_1.2.6-1_all.deb Horde Hash Table Interface
php-horde-history_2.3.6-3ubuntu1_all.deb API for tracking the history of an object
php-horde-http_2.1.7-1_all.deb Horde HTTP libraries
php-horde-icalendar_2.1.7-1_all.deb iCalendar API
php-horde-idna_1.1.1-1_all.deb IDNA backend normalization package
php-horde-image_2.5.2-1_all.deb Horde Image API
php-horde-imap-client_2.29.15-1_all.deb Horde IMAP Client
Advertisement
Advertisement