php-guestfs_1.36.13-1ubuntu3_i386.deb


Advertisement

Description

php-guestfs - guest disk image management system - PHP bindings

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename php-guestfs_1.36.13-1ubuntu3_i386.deb
Package name php-guestfs
Package version 1.36.13
Package release 1ubuntu3
Package architecture i386
Package type deb
Category universe/php
Homepage http://libguestfs.org
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 69.09 KB
Installed size 480.00 KB
The libguestfs library allows accessing and modifying guest disk
images.
This package contains the PHP bindings.

Alternatives

Package Version Architecture Repository
php-guestfs_1.36.13-1ubuntu3.3_amd64.deb 1.36.13 amd64 Ubuntu Updates Universe
php-guestfs_1.36.13-1ubuntu3.3_i386.deb 1.36.13 i386 Ubuntu Updates Universe
php-guestfs_1.36.13-1ubuntu3_amd64.deb 1.36.13 amd64 Ubuntu Universe
php-guestfs - - -

Requires

Name Value
libc6 >= 2.4
libguestfs0 >= 1:1.35.36
php-common >= 1:7.0+33~
phpapi-20170718 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package php-guestfs_1.36.13-1ubuntu3_i386.deb
Source Package libguestfs

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install php-guestfs deb package:
    # sudo apt-get install php-guestfs

Files

Path
/etc/php/7.2/mods-available/guestfs_php.ini
/usr/lib/php/20170718/guestfs_php.so
/usr/share/doc/php-guestfs/changelog.Debian.gz
/usr/share/doc/php-guestfs/copyright

Changelog

2018-03-01 - Dimitri John Ledkov <xnox@ubuntu.com>
libguestfs (1:1.36.13-1ubuntu3) bionic; urgency=high
* No change rebuild against ruby-defaults without ruby2.3 support.
2018-02-01 - Matthias Klose <doko@ubuntu.com>
libguestfs (1:1.36.13-1ubuntu2) bionic; urgency=medium
* No-change rebuild for ruby2.5 update.
2018-01-30 - Gianfranco Costamagna <locutusofborg@debian.org>
libguestfs (1:1.36.13-1ubuntu1) bionic; urgency=low
* Merge from Debian unstable.  Remaining changes:
- debian/control:
+ Add qemu build dependencies for arm64 and ppc64el.
+ Switch to Ubuntu kernel meta-package names.
+ Disable Build-Depends on grub2, only needed for the quickchecks,
which are disabled anyway.
+ Build-Depends on zfs-fuse on armhf and ppc64el as well.
+ Use qemu-s390x on s390x.
- debian/rules:
+ Disable quickchecks. Requires a readable kernel image.
+ Configure with --disable-silent-rules.
2018-01-29 - Hilko Bengen <bengen@debian.org>
libguestfs (1:1.36.13-1) unstable; urgency=medium
* New upstream version 1.36.13
* Drop QEMU locking patch; a similar patch has been integrated upstream
* Add guestfs-gobject manpage
2018-01-23 - Hilko Bengen <bengen@debian.org>
libguestfs (1:1.36.11-3) unstable; urgency=medium
* Add patch to omit passing locking parameters for non-file disks
* Bump Standards-Version
2018-01-15 - Hilko Bengen <bengen@debian.org>
libguestfs (1:1.36.11-2) unstable; urgency=medium
* e2fsprogs: Add to Build-Depends, don't filter from appliance
dependencies (Closes: Closes: #887171, #887203, #887215, #887217,
#887220, #887219, #887244, #887259, #887268, #887269, #887271,
#887279, #887288, #887289, #887291, #887296, #887280, #887302)
* Catch errors in any of the "make install" runs
* Fix install target for php extension
2017-12-12 - Gianfranco Costamagna <locutusofborg@debian.org>
libguestfs (1:1.36.11-1ubuntu1) bionic; urgency=low
* Merge from Debian unstable.  Remaining changes:
- debian/control:
+ Add qemu build dependencies for arm64 and ppc64el.
+ Switch to Ubuntu kernel meta-package names.
+ Disable Build-Depends on grub2, only needed for the quickchecks,
which are disabled anyway.
+ Build-Depends on zfs-fuse on armhf and ppc64el as well.
+ Use qemu-s390x on s390x.
- debian/rules:
+ Disable quickchecks. Requires a readable kernel image.
+ Configure with --disable-silent-rules.
2017-12-10 - Hilko Bengen <bengen@debian.org>
libguestfs (1:1.36.11-1) unstable; urgency=medium
* New upstream version 1.36.11
* Bump Standards-Version
2017-11-13 - Gianfranco Costamagna <locutusofborg@debian.org>
libguestfs (1:1.36.10-1ubuntu3) bionic; urgency=medium
* Rebuild against new OCAML ABIs.
2017-10-27 - Gianfranco Costamagna <locutusofborg@debian.org>
libguestfs (1:1.36.10-1ubuntu2) bionic; urgency=medium
* Drop gjs removal on s390x. Now it builds there.

See Also

Package Description
php-guzzlehttp-promises_1.3.1-0ubuntu1_all.deb Guzzle promises library
php-hamcrest_2.0.0-0ubuntu1_all.deb This is the PHP port of Hamcrest Matchers
php-horde-activesync_2.39.0-1ubuntu1_all.deb ActiveSync server library
php-horde-alarm_2.2.10-1ubuntu1_all.deb Horde Alarm Libraries
php-horde-ansel_3.0.8+debian0-1ubuntu1_all.deb Photo management application
php-horde-argv_2.1.0-1ubuntu1_all.deb Horde command-line argument parsing package
php-horde-auth_2.2.2-1ubuntu1_all.deb Horde Authentication API
php-horde-autoloader_2.1.2-3ubuntu1_all.deb Horde Autoloader
php-horde-browser_2.0.15-1_all.deb Horde Browser API
php-horde-cache_2.5.5-1_all.deb Horde Caching API
php-horde-cli_2.2.4-1_all.deb Horde Command Line Interface API
php-horde-compress-fast_1.1.1-3_all.deb Fast Compression Library
php-horde-compress_2.2.1-1ubuntu1_all.deb Horde Compression API
php-horde-constraint_2.0.3-3_all.deb Horde Constraint library
php-horde-content_2.0.6-1_all.deb Tagging application
Advertisement
Advertisement