php-fdomdocument_1.6.6-1_all.deb


Advertisement

Description

php-fdomdocument - extension to PHP's standard DOM

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename php-fdomdocument_1.6.6-1_all.deb
Package name php-fdomdocument
Package version 1.6.6
Package release 1
Package architecture all
Package type deb
Category universe/php
Homepage https://github.com/theseer/fDOMDocument
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 12.43 KB
Installed size 106.00 KB
An extension to PHP's standard DOM to add various convenience methods and
exceptions by default.
The classes contained within this repository extend the standard DOM to use
exceptions at all occasions of errors instead of PHP warnings or notices. They
also add various custom methods and shortcuts for convenience and to simplify
the usage of DOM.

Alternatives

Package Version Architecture Repository
php-fdomdocument_1.6.6-1_all.deb 1.6.6 all Ubuntu Universe
php-fdomdocument - - -

Requires

Name Value
libxml2 -
php-common -
php-xml -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package php-fdomdocument_1.6.6-1_all.deb
Source Package php-fdomdocument

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install php-fdomdocument deb package:
    # sudo apt-get install php-fdomdocument

Files

Path
/usr/share/doc/php-fdomdocument/README.md.gz
/usr/share/doc/php-fdomdocument/changelog.Debian.gz
/usr/share/doc/php-fdomdocument/copyright
/usr/share/php/TheSeer/fDOMDocument/XPathQuery.php
/usr/share/php/TheSeer/fDOMDocument/XPathQueryException.php
/usr/share/php/TheSeer/fDOMDocument/autoload.php
/usr/share/php/TheSeer/fDOMDocument/fDOMDocument.php
/usr/share/php/TheSeer/fDOMDocument/fDOMDocumentFragment.php
/usr/share/php/TheSeer/fDOMDocument/fDOMElement.php
/usr/share/php/TheSeer/fDOMDocument/fDOMException.php
/usr/share/php/TheSeer/fDOMDocument/fDOMNode.php
/usr/share/php/TheSeer/fDOMDocument/fDOMXPath.php
/usr/share/php/TheSeer/fDOMDocument/css/DollarEqualRule.php
/usr/share/php/TheSeer/fDOMDocument/css/NotRule.php
/usr/share/php/TheSeer/fDOMDocument/css/NthChildRule.php
/usr/share/php/TheSeer/fDOMDocument/css/RegexRule.php
/usr/share/php/TheSeer/fDOMDocument/css/RuleInterface.php
/usr/share/php/TheSeer/fDOMDocument/css/Translator.php

Changelog

2017-08-03 - David Prévot <taffit@debian.org>
php-fdomdocument (1.6.6-1) unstable; urgency=medium
* Update copyright (years)
* Convert packaging to Composer source
* Update Standards-Version to 4.0.0
2016-03-08 - David Prévot <taffit@debian.org>
php-fdomdocument (1.6.1-2) unstable; urgency=medium
* Use configuration file for CI
* Update watch for Composer source
* Update Standards-Version to 3.9.7
* Rebuild with recent pkg-php-tools for the PHP 7.0 transition
2015-05-29 - David Prévot <taffit@debian.org>
php-fdomdocument (1.6.1-1) unstable; urgency=medium
[ Arne Blankerts ]
* Workaround for HHVM Issue #5412
* Release 1.6.1
[ David Prévot ]
* Add a get-orig-source target
* Simplify test calls
* Bump standards version to 3.9.6
2014-09-16 - David Prévot <taffit@debian.org>
php-fdomdocument (1.6.0-1) unstable; urgency=medium
[ Arne Blankerts ]
* Added filename to exception messages
* Added various forwarder calls
* More tests
* Release 1.6.0
[ David Prévot ]
* No tests if DEB_BUILD_OPTIONS contains nocheck
2014-04-25 - David Prévot <taffit@debian.org>
php-fdomdocument (1.5.0-1) unstable; urgency=low
* Initial Release (Closes: #746298)

See Also

Package Description
php-fig-link-util_1.0.0-2_all.deb Common utility implementations for HTTP links
php-file-iterator_1.4.5-1_all.deb FilterIterator implementation for PHP
php-finder-facade-doc_1.2.2-2_all.deb convenience wrapper for Symfony's Finder component - documentation
php-finder-facade_1.2.2-2_all.deb convenience wrapper for Symfony's Finder component
php-font-lib_0.3.1+dfsg-3_all.deb read, parse, export and make subsets of different fonts
php-fpdf_1.8.1.dfsg-2_all.deb PHP class to generate PDF files
php-fpm_7.2+60ubuntu1_all.deb server-side, HTML-embedded scripting language (FPM-CGI binary) (default)
php-fshl_2.1.0-4_all.deb Fast Syntax HighLighter
php-fxsl_1.1.1-3_all.deb XSL wrapper and extension to XSLTProcessor
php-gearman_2.0.3+1.1.2+-1build3_i386.deb PHP wrapper to libgearman
php-geoip_1.1.1-1build2_i386.deb GeoIP module for PHP
php-geos_1.0.0-2build2_i386.deb GEOS bindings for PHP
php-geshi_1.0.8.11-2.1_all.deb Generic Syntax Highlighter
php-getid3_1.9.15+dfsg-1_all.deb scripts to extract information from multimedia files
php-gettext_1.0.12-0.1_all.deb transitional dummy package for php-php-gettext
Advertisement
Advertisement