php-enum_3.0.0-1_all.deb


Advertisement

Description

php-enum - Simple and fast implementation of enumerations with native PHP>=5.6

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename php-enum_3.0.0-1_all.deb
Package name php-enum
Package version 3.0.0
Package release 1
Package architecture all
Package type deb
Category universe/php
Homepage https://github.com/marc-mabe/php-enum
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 13.63 KB
Installed size 64.00 KB
Implementation to add enumeration support to PHP >= 5.3. It's an
abstract class that needs to be extended to use it.

Alternatives

Package Version Architecture Repository
php-enum_3.0.0-1_all.deb 3.0.0 all Ubuntu Universe
php-enum - - -

Requires

Name Value
php-common -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package php-enum_3.0.0-1_all.deb
Source Package php-enum

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install php-enum deb package:
    # sudo apt-get install php-enum

Files

Path
/usr/share/doc/php-enum/README.md.gz
/usr/share/doc/php-enum/changelog.Debian.gz
/usr/share/doc/php-enum/copyright
/usr/share/php/MabeEnum/Enum.php
/usr/share/php/MabeEnum/EnumMap.php
/usr/share/php/MabeEnum/EnumSerializableTrait.php
/usr/share/php/MabeEnum/EnumSet.php
/usr/share/php/MabeEnum/autoload.php

Changelog

2017-12-03 - David Prévot <taffit@debian.org>
php-enum (3.0.0-1) experimental; urgency=medium
* Upload to experimental since the next version of php-json-schema should
depend on version 2.3.1 for the time being
[ Marc Bennewitz ]
* v3.0 preparation
* php --define zend.assertions=1 /usr/bin/phpunit (Closes: #882928)
[ David Prévot ]
* Update copyright (years)
* Update Standards-Version to 4.1.2
* Enable zend.assertions for the tests
2017-10-24 - David Prévot <taffit@debian.org>
php-enum (2.3.1-1) unstable; urgency=low
* Initial release (New php-json-schema dependency)

See Also

Package Description
php-facedetect_1.1.0+git20170801-1build1_i386.deb Detect faces with PHP
php-fdomdocument_1.6.6-1_all.deb extension to PHP's standard DOM
php-fig-link-util_1.0.0-2_all.deb Common utility implementations for HTTP links
php-file-iterator_1.4.5-1_all.deb FilterIterator implementation for PHP
php-finder-facade-doc_1.2.2-2_all.deb convenience wrapper for Symfony's Finder component - documentation
php-finder-facade_1.2.2-2_all.deb convenience wrapper for Symfony's Finder component
php-font-lib_0.3.1+dfsg-3_all.deb read, parse, export and make subsets of different fonts
php-fpdf_1.8.1.dfsg-2_all.deb PHP class to generate PDF files
php-fpm_7.2+60ubuntu1_all.deb server-side, HTML-embedded scripting language (FPM-CGI binary) (default)
php-fshl_2.1.0-4_all.deb Fast Syntax HighLighter
php-fxsl_1.1.1-3_all.deb XSL wrapper and extension to XSLTProcessor
php-gearman_2.0.3+1.1.2+-1build3_i386.deb PHP wrapper to libgearman
php-geoip_1.1.1-1build2_i386.deb GeoIP module for PHP
php-geos_1.0.0-2build2_i386.deb GEOS bindings for PHP
php-geshi_1.0.8.11-2.1_all.deb Generic Syntax Highlighter
Advertisement
Advertisement