php-elisp_1.13.5-3_all.deb


Advertisement

Description

php-elisp - Emacs support for php files

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename php-elisp_1.13.5-3_all.deb
Package name php-elisp
Package version 1.13.5
Package release 3
Package architecture all
Package type deb
Category universe/text
Homepage https://github.com/ejmr/php-mode
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 20.84 KB
Installed size 96.00 KB
Emacs major mode for php supporting syntax highlighting, indentation
and good integration with html-statements.

Alternatives

Package Version Architecture Repository
php-elisp_1.13.5-3_all.deb 1.13.5 all Ubuntu Universe
php-elisp - - -

Requires

Name Value
emacs23 -
emacs24 -
emacsen -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package php-elisp_1.13.5-3_all.deb
Source Package php-elisp

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install php-elisp deb package:
    # sudo apt-get install php-elisp

Files

Path
/etc/emacs/site-start.d/50php-elisp.el
/usr/lib/emacsen-common/packages/install/php-elisp
/usr/lib/emacsen-common/packages/remove/php-elisp
/usr/share/doc/php-elisp/README.Debian
/usr/share/doc/php-elisp/changelog.Debian.gz
/usr/share/doc/php-elisp/copyright
/usr/share/emacs/site-lisp/php-elisp/php-mode.el

Changelog

2016-06-19 - Ola Lundqvist <opal@debian.org>
php-elisp (1.13.5-3) unstable; urgency=medium
* Merged the patch from Peter S Galbraith to make sure it is not
loaded when removed but not purged. Closes: #584785.
* Updated to standards version 3.9.6.
2015-01-25 - Ola Lundqvist <opal@debian.org>
php-elisp (1.13.5-2) unstable; urgency=low
* Dropped emacs 22 support. Closes: #775390, #775548. Thanks to Youhei
SASAKI <uwabami@gfd-dennou.org> for the patch.
2014-10-15 - Ola Lundqvist <opal@debian.org>
php-elisp (1.13.5-1) unstable; urgency=low
* New upstream release. Closes: #764033.
* New maintainer. Closes: #668201.
* Removed the texi documentation.
* Changed the upsteam page reference.
* Updated standards version.
* Debhelper 9 compatible.
* Simplified debian/rules file.
2010-08-05 - Moritz Muehlenhoff <jmm@debian.org>
php-elisp (1.5.0-1.1) unstable; urgency=low
* Non-maintainer upload.
* Prevent byte compilation on xemacs21, since it's incompatible
(Closes: #584698)
2010-05-09 - Thierry Randrianiriana <thierry@debian.org>
php-elisp (1.5.0-1) unstable; urgency=low
* New upstream release (Closes: #368061, #291207)
* New maintainer (Closes: #525947)
* debian/control:
+ bumped Standards-Version to 3.8.4
+ added ${misc:Depends} in Depends
+ updated Depends to emacs23 | emacs22 | emacsen
+ updated Suggests to php5 | php5-cli
+ updated Section to lisp
+ added in Recommends field speedbar (Closes: #500120)
+ used debhelper 7
+ added Homepage field
+ added texi2html in Build-Depends to generate manual (Closes: #476197)
* debian/rules:
+ removed emacs21 references (Closes: #269650)
+ used binary-indep instead of binary-arch target
* debian/copyright
+ added copyright notice
* Added compat, docs, watch files
* switched to dpkg-source 3.0 (quilt) format
2009-04-28 - Ola Lundqvist <opal@debian.org>
php-elisp (1.4.0-3) unstable; urgency=low
* Package officially orphaned and maintainer address set to the Debian
QA Group.
2008-04-27 - Ola Lundqvist <opal@debian.org>
php-elisp (1.4.0-2) unstable; urgency=low
* Applied patch from Neil Moore <neil@s-z.org> to correct xemacs
problem, closes: #477132.
2008-04-20 - Ola Lundqvist <opal@debian.org>
php-elisp (1.4.0-1) unstable; urgency=low
* New upstream release.
* This version have a copy of the 1.2.0 version with support for emacs21
included as well.
* Applied patch with various fixes for the 1.2.0 version, closes: #342632.
Thanks to Thue Janus Kristensen <thuejk@gmail.com> for the good patch.
Due to new upstream release two chunks had to be applied manually.
* Making Ola maintainer and Pontus co-maintainer.
* Debhelper compatibility version 4 support.
* Updated to 3.7.2 version of the debian standards version.
This include removing the old conffiles file in debian dir.
* Build depends on debhelper.
* Updated to new version of FSF address in copyright file.  
2004-04-13 - Pontus Ullgren <pontus@ullgren.com>
php-elisp (1.1.0-2) unstable; urgency=low
* Fixed newline. Patch supplied by Roland Rosenfeld, closes: #242183
2004-02-06 - Pontus Ullgren <pontus@ullgren.com>
php-elisp (1.1.0-1) unstable; urgency=low
* New upstream release closes: #233858
* Added a small README.debian file. closes: #158748
* Removed dependancy to emacs20. closes: #232779

See Also

Package Description
php-email-validator_2.1.3-1_all.deb A library for validating emails against several RFCs
php-enchant_7.2+60ubuntu1_all.deb Enchant module for PHP [default]
php-enum_3.0.0-1_all.deb Simple and fast implementation of enumerations with native PHP>=5.6
php-facedetect_1.1.0+git20170801-1build1_i386.deb Detect faces with PHP
php-fdomdocument_1.6.6-1_all.deb extension to PHP's standard DOM
php-fig-link-util_1.0.0-2_all.deb Common utility implementations for HTTP links
php-file-iterator_1.4.5-1_all.deb FilterIterator implementation for PHP
php-finder-facade-doc_1.2.2-2_all.deb convenience wrapper for Symfony's Finder component - documentation
php-finder-facade_1.2.2-2_all.deb convenience wrapper for Symfony's Finder component
php-font-lib_0.3.1+dfsg-3_all.deb read, parse, export and make subsets of different fonts
php-fpdf_1.8.1.dfsg-2_all.deb PHP class to generate PDF files
php-fpm_7.2+60ubuntu1_all.deb server-side, HTML-embedded scripting language (FPM-CGI binary) (default)
php-fshl_2.1.0-4_all.deb Fast Syntax HighLighter
php-fxsl_1.1.1-3_all.deb XSL wrapper and extension to XSLTProcessor
php-gearman_2.0.3+1.1.2+-1build3_i386.deb PHP wrapper to libgearman
Advertisement
Advertisement