medusa_2.2-5_i386.deb


Advertisement

Description

medusa - fast, parallel, modular, login brute-forcer for network services

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename medusa_2.2-5_i386.deb
Package name medusa
Package version 2.2
Package release 5
Package architecture i386
Package type deb
Category universe/admin
Homepage http://foofus.net/?page_id=51
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 151.58 KB
Installed size 690.00 KB
Medusa is intended to be a speedy, massively parallel, modular, login
brute-forcer. The goal is to support as many services which allow remote
authentication as possible. The author considers following items as some of
the key features of this application:
* Thread-based parallel testing. Brute-force testing can be
performed against multiple hosts, users or passwords
concurrently.
* Flexible user input. Target information (host/user/password) can
be specified in a variety of ways. For example, each item can be
either a single entry or a file containing multiple entries.
Additionally, a combination file format allows the user to
refine their target listing.
* Modular design. Each service module exists as an
independent .mod file. This means that no modifications are
necessary to the core application in order to extend the
supported list of services for brute-forcing.

Alternatives

Package Version Architecture Repository
medusa_2.2-5_amd64.deb 2.2 amd64 Ubuntu Universe
medusa - - -

Requires

Name Value
libc6 >= 2.15
libgcrypt20 >= 1.8.0
libgnutls30 >= 3.5.0
libpq5 -
libssh2-1 >= 1.2.5
libssl1.1 >= 1.1.0
libsvn1 >= 1.8

Download

Type URL
Mirror archive.ubuntu.com
Binary Package medusa_2.2-5_i386.deb
Source Package medusa

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install medusa deb package:
    # sudo apt-get install medusa

Files

Path
/usr/bin/medusa
/usr/lib/i386-linux-gnu/medusa/modules/cvs.mod
/usr/lib/i386-linux-gnu/medusa/modules/ftp.mod
/usr/lib/i386-linux-gnu/medusa/modules/http.mod
/usr/lib/i386-linux-gnu/medusa/modules/imap.mod
/usr/lib/i386-linux-gnu/medusa/modules/mssql.mod
/usr/lib/i386-linux-gnu/medusa/modules/mysql.mod
/usr/lib/i386-linux-gnu/medusa/modules/nntp.mod
/usr/lib/i386-linux-gnu/medusa/modules/pcanywhere.mod
/usr/lib/i386-linux-gnu/medusa/modules/pop3.mod
/usr/lib/i386-linux-gnu/medusa/modules/postgres.mod
/usr/lib/i386-linux-gnu/medusa/modules/rexec.mod
/usr/lib/i386-linux-gnu/medusa/modules/rlogin.mod
/usr/lib/i386-linux-gnu/medusa/modules/rsh.mod
/usr/lib/i386-linux-gnu/medusa/modules/smbnt.mod
/usr/lib/i386-linux-gnu/medusa/modules/smtp-vrfy.mod
/usr/lib/i386-linux-gnu/medusa/modules/smtp.mod
/usr/lib/i386-linux-gnu/medusa/modules/snmp.mod
/usr/lib/i386-linux-gnu/medusa/modules/ssh.mod
/usr/lib/i386-linux-gnu/medusa/modules/svn.mod
/usr/lib/i386-linux-gnu/medusa/modules/telnet.mod
/usr/lib/i386-linux-gnu/medusa/modules/vmauthd.mod
/usr/lib/i386-linux-gnu/medusa/modules/vnc.mod
/usr/lib/i386-linux-gnu/medusa/modules/web-form.mod
/usr/lib/i386-linux-gnu/medusa/modules/wrapper.mod
/usr/share/doc/medusa/README.Debian
/usr/share/doc/medusa/README.md
/usr/share/doc/medusa/TODO
/usr/share/doc/medusa/changelog.Debian.gz
/usr/share/doc/medusa/copyright
/usr/share/man/man1/medusa.1.gz

Changelog

2018-02-12 - Lukas Schwaighofer <lukas@schwaighofer.name>
medusa (2.2-5) unstable; urgency=medium
* Team upload.
* Update to debhelper compatibility level 11.
* Update debian/rules to use the dh sequencer.
- Medusa modules are now installed in multiarch subdir of /usr/lib.
* Enable additional hardening options.
* debian/patches:
- Remove any patches which are not applied (not part of series file).
- Add a short description to web_form.patch.
- Document the origin of openssl-1.1.patch.
* Bump Standards-Version to 4.1.3 (no change needed).
* Drop the debian/dirs file as its not needed.
* Install upstream's README.md instead of README as documentation (otherwise
README ends up as dangling symlink in the package).
* Drop preinst script. It used to print a warning regarding GNOME medusa
which is no longer relevant.
* Update copyright file.
* Remove automake from Build-Depends, the version constraint is useless now
and automake is a (transitive) dependency of debhelper >= 11.
* Point Vcs-* control fields to salsa.debian.org.
* Drop support for the remote desktop protocol (RDP) module until upstream
supports the freerdp2 library (Closes: #888322).
2016-11-05 - Luciano Bello <luciano@debian.org>
medusa (2.2-4) unstable; urgency=high
* OpenSSL 1.1 support (RC bug) closes: #828433
* debian/source/options: do not store autogenerated files.
2016-08-23 - Luciano Bello <luciano@debian.org>
medusa (2.2-3) unstable; urgency=medium
* Moving to Debian Security Tools Packaging Team (pkg-security).
* Adding module RDP (with libfreerdp-dev).
2016-06-20 - Raphaƫl Hertzog <hertzog@debian.org>
medusa (2.2-2) unstable; urgency=medium
* Team upload.
* Add fix-libssh2-configure-check.patch to properly detect libssh2 on all
architectures.
* Add gnutls-dev and dh-autoreconf to build-depends for the same reason.
2016-05-16 - Adrian Alves <aalves@gmail.com>
medusa (2.2-1) unstable; urgency=medium
[ Adrian Alves ]
* New upstream version.
* Standards-Version updated in debian/control to 3.9.8
* debian/compat updated into 9
* debian/copyright updated to format 1.0
[ Luciano Bello ]
* Homepage entry updated (closes: 806394)
* Vcs-Git and Vcs-Browser entries in debian/control added.
* Watch file pointing to github.
2015-11-20 - Luciano Bello <luciano@debian.org>
medusa (2.2~rc3-1) unstable; urgency=medium
* New upstream version.
* FTBFS: SSLv3 method removed (closes: #805114).
2014-01-24 - Luciano Bello <luciano@debian.org>
medusa (2.1.1-1) unstable; urgency=medium
* New upstream version.
* Dependency libncp-dev removed. Closes: #728863.
* dpkg-buildflags added.
2012-05-22 - Matthias Klose <doko@debian.org>
medusa (2.0-3.1) unstable; urgency=low
* Non maintainer upload.
* Fix build failure with GCC 4.7. Closes: #667273.
2011-09-16 - Luciano Bello <luciano@debian.org>
medusa (2.0-3) unstable; urgency=low
* sslv2.patch: fix FTBFS with OpenSSL 1.0.0 (closes: #621994).
* as-needed.patch: fix FTBFS with --as-needed linker option (closes: #632344)
* debian/rules patch by Ilya Barygin:
- copy config.{sub,guess} files in configure target
- patches/debian-changes-2.0-2 removed.
2010-09-10 - Luciano Bello <luciano@debian.org>
medusa (2.0-2) experimental; urgency=low
* Little patch included in order to know more info when a web application
crashes.

See Also

Package Description
meep-lam4_1.3-2build2_i386.deb software package for FDTD simulation, parallel (OpenMPI) version
meep-mpi-default_1.3-3build5_i386.deb software package for FDTD simulation, parallel (OpenMPI) version
meep-mpich2_1.3-4build3_i386.deb software package for FDTD simulation, parallel (OpenMPI) version
meep-openmpi_1.3-3build4_i386.deb software package for FDTD simulation, parallel (OpenMPI) version
meep_1.3-4build2_i386.deb software package for FDTD simulation
megaglest-data_3.13.0-2_all.deb data files for MegaGlest
megaglest_3.13.0-2_i386.deb 3D multi-player real time strategy game
megatools_1.9.98-1build2_i386.deb Command-line client for the Mega cloud storage service
meld_3.18.0-6_all.deb graphical tool to diff and merge files
melt_6.6.0-1build1_i386.deb command line media player and video editor
melting-gui_4.3.1+dfsg-3_all.deb graphical interface to compute the melting temperature of nucleic acid duplex
melting_4.3.1+dfsg-3_i386.deb compute the melting temperature of nucleic acid duplex
members_20080128-5+nmu1_i386.deb Shows the members of a group; by default, all members
memcachedb_1.2.0-12build1_i386.deb Persistent storage engine using the memcache protocol
memdump_1.01-7build1_i386.deb utility to dump memory contents to standard output
Advertisement
Advertisement