libtyxml-ocaml_3.5.0-2build1_i386.deb


Advertisement

Description

libtyxml-ocaml - typed XML in OCaml (plugins)

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package filename libtyxml-ocaml_3.5.0-2build1_i386.deb
Package name libtyxml-ocaml
Package version 3.5.0
Package release 2build1
Package architecture i386
Package type deb
Category universe/ocaml
Homepage http://ocsigen.org/tyxml
License -
Maintainer Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Download size 382.51 KB
Installed size 2.86 MB
TyXML allows one to build XML trees whose validity is ensured by the
typechecker. It's based on a translation of XML types into polymorphic
variants, originally written by Thorsten Ohl. Currently, the
transcription has been done for XHTML 1.0 and 1.1, HTML5 and SVG
(partial).
TyXML also provides a generic printer and some low-level (and
untyped) iterators over XML trees. The printer has options for
printing XHTML in more browser-friendly way when served as
"text/html" (instead of "text/xml"). HTML5 is always printed with
those options.
All modules provided by TyXML are also provided in functorial
interface, where every module is parameterised by the underlying XML
representation.
A camlp4 extension, named Pa_tyxml, allows one to write HTML pages or
HTML fragments with the usual syntax.
This package contains dynamically loadable modules for plugins.

Alternatives

Package Version Architecture Repository
libtyxml-ocaml_3.5.0-2build1_amd64.deb 3.5.0 amd64 Ubuntu Universe
libtyxml-ocaml - - -

Requires

Name Value
libc6 >= 2.1.3
libuutf-ocaml-ahkt9 -
ocaml-base-nox-4.05.0 -

Provides

Name Value
libtyxml-ocaml-9usm7 -

Download

Type URL
Mirror archive.ubuntu.com
Binary Package libtyxml-ocaml_3.5.0-2build1_i386.deb
Source Package tyxml

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libtyxml-ocaml deb package:
    # sudo apt-get install libtyxml-ocaml

Files

Path
/usr/lib/ocaml/tyxml/META
/usr/lib/ocaml/tyxml/tymlx_p.cma
/usr/lib/ocaml/tyxml/tymlx_p.cmxs
/usr/lib/ocaml/tyxml/tyxml.cma
/usr/lib/ocaml/tyxml/tyxml.cmxs
/usr/lib/ocaml/tyxml/tyxml_f.cma
/usr/lib/ocaml/tyxml/tyxml_f.cmxs
/usr/lib/ocaml/tyxml/tyxml_tools.cma
/usr/lib/ocaml/tyxml/tyxml_tools.cmxs
/usr/share/doc/libtyxml-ocaml/changelog.Debian.gz
/usr/share/doc/libtyxml-ocaml/copyright

Changelog

2017-10-28 - Gianfranco Costamagna <locutusofborg@debian.org>
tyxml (3.5.0-2build1) bionic; urgency=medium
* Rebuild against new OCAML ABIs.
2017-07-21 - Stéphane Glondu <glondu@debian.org>
tyxml (3.5.0-2) unstable; urgency=medium
* Add ocamlbuild to Build-Depends
2015-10-18 - Mehdi Dogguy <mehdi@debian.org>
tyxml (3.5.0-1) unstable; urgency=medium
* New upstream release
* Build-Depend on camlp4 instead of camlp4-extrac
* Add libuutf-ocaml-dev to Build-Depends
* Adapt d/rules to upstream's new build system
* Do not install .ml files, .mli are provided
* Install tyxml_tools.cm{a,xs} in libtyxml-ocaml
* Install *.cmt{,i} and *.annot in libtyxml-ocaml-dev
2015-10-17 - Mehdi Dogguy <mehdi@debian.org>
tyxml (3.0.0-2) unstable; urgency=medium
[ Stéphane Glondu ]
* Drop versioned dependency for camlp4-extra
2014-05-30 - Stéphane Glondu <glondu@debian.org>
tyxml (3.0.0-1) unstable; urgency=medium
* New upstream release
* Update Vcs-*
* Bump Standards-Version to 3.9.5
2013-12-04 - Stéphane Glondu <glondu@debian.org>
tyxml (2.2.0-4) unstable; urgency=low
* Upload to unstable
2013-11-10 - Stéphane Glondu <glondu@debian.org>
tyxml (2.2.0-3) experimental; urgency=low
* Fix compilation with ocamlnet >= 3.6.5 (netstring-pcre)
* Disable ocamlduce support
* Compile with OCaml >= 4.01
2013-05-09 - Stéphane Glondu <glondu@debian.org>
tyxml (2.2.0-2) unstable; urgency=low
* Bump Standards-Version to 3.9.4
* Upload to unstable
2012-12-07 - Stéphane Glondu <glondu@debian.org>
tyxml (2.2.0-1) experimental; urgency=low
* New upstream release
2012-06-08 - Stéphane Glondu <glondu@debian.org>
tyxml (2.1-1) unstable; urgency=low
* New upstream release

See Also

Package Description
libu1db-dev_13.10-6.2_i386.deb Ubuntu One structured data storage - C API development files
libu1db-qt5-3_0.1.5+15.10.20150826.1-0ubuntu1_i386.deb Qt5 binding for U1DB - shared library
libu1db-qt5-dev_0.1.5+15.10.20150826.1-0ubuntu1_i386.deb Qt5 binding and QtQuick2 plugin for U1DB - development files
libu1db-qt5-doc_0.1.5+15.10.20150826.1-0ubuntu1_all.deb Qt5 binding and QtQuick2 plugin for U1DB - offline documentation
libu1db-qt5-examples_0.1.5+15.10.20150826.1-0ubuntu1_all.deb Qt5 binding and QtQuick2 plugin for U1DB - examples
libu1db1_13.10-6.2_i386.deb Ubuntu One structured data storage - C API
libu2f-host-dev_1.1.4-1_i386.deb Development files for the U2F host C library libu2f-host
libu2f-host0_1.1.4-1_i386.deb Universal 2nd Factor (U2F) host communication C Library
libu2f-server-dev_1.1.0-1build1_i386.deb Development files for the U2F server C library libu2f-server
libu2f-server0_1.1.0-1build1_i386.deb Universal 2nd Factor (U2F) server communication C Library
libubertooth-dev_2017.03.R2-2_i386.deb Shared library for Bluetooth experimentation - development files
libubertooth1_2017.03.R2-2_i386.deb Shared library for Bluetooth experimentation
libubsan0-amd64-cross_7.3.0-16ubuntu3cross1_all.deb UBSan -- undefined behaviour sanitizer (runtime)
libubsan0-armel-cross_7.3.0-16ubuntu3cross1_all.deb UBSan -- undefined behaviour sanitizer (runtime)
libubsan0-dbg-amd64-cross_7.3.0-16ubuntu3cross1_all.deb UBSan -- undefined behaviour sanitizer (debug symbols)
Advertisement
Advertisement