librasterlite2-1_1.0.0~rc0+devel1-6_i386.deb


Advertisement

Description

librasterlite2-1 - library for huge raster coverages using a SpatiaLite DBMS

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name librasterlite2-1
Package version 1.0.0~rc0+devel1
Package release 6
Package architecture i386
Package type deb
Installed size 1.10 KB
Download size 355.44 KB
Official Mirror archive.ubuntu.com
librasterlite2 is an open source library that stores and retrieves huge
raster coverages using a SpatiaLite DBMS.
It is intended to completely replace and supersede librasterlite.
The two projects are completely unrelated: the unique similarity between
both is just in covering the same identical application area.
This package contains the shared library.

Alternatives

Package Version Architecture Repository
librasterlite2-1_1.0.0~rc0+devel1-6_amd64.deb 1.0.0~rc0+devel1 amd64 Ubuntu Universe
librasterlite2-1 - - -

Requires

Name Value
libc6 >= 2.11
libcairo2 >= 1.10.0
libcharls1 >= 1.0
libcurl3-gnutls >= 7.16.2
libgeotiff2 >= 1.3.0
libgif7 >= 5.1
libjpeg8 >= 8c
liblzma5 >= 5.1.1alpha+20120614
libopenjp2-7 >= 2.0.0
libpng16-16 >= 1.6.2-1
libsqlite3-0 >= 3.5.9
libtiff5 >= 4.0.3
libwebp6 >= 0.5.1
libxml2 >= 2.7.4
zlib1g >= 1:1.2.0

Download

Type URL
Binary Package librasterlite2-1_1.0.0~rc0+devel1-6_i386.deb
Source Package librasterlite2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install librasterlite2-1 deb package:
    # sudo apt-get install librasterlite2-1

Files

Path
/usr/lib/i386-linux-gnu/librasterlite2.so.1
/usr/lib/i386-linux-gnu/librasterlite2.so.1.0.0
/usr/share/doc/librasterlite2-1/changelog.Debian.gz
/usr/share/doc/librasterlite2-1/copyright

Changelog

2017-10-18 - Bas Couwenberg <sebastic@debian.org>
librasterlite2 (1.0.0~rc0+devel1-6) unstable; urgency=medium
* Add patch to fix FTBFS with OpenJPEG 2.3.
* Bump Standards-Version to 4.1.1, no changes.
* Add lintian override for debian-watch-uses-insecure-uri.
2017-09-26 - Bas Couwenberg <sebastic@debian.org>
librasterlite2 (1.0.0~rc0+devel1-5) unstable; urgency=medium
* Change priority from extra to optional.
* Bump Standards-Version to 4.1.0, changes: priority.
* Add patch to fix FTBFS with OpenJPEG 2.2.
(closes: #876808)
* Use pkg-info.mk variables instead of dpkg-parsechangelog output.
* Add autopkgtest to test installability.
* Use libs section for librasterlite2-1 package.
2016-09-01 - Bas Couwenberg <sebastic@debian.org>
librasterlite2 (1.0.0~rc0+devel1-4) unstable; urgency=medium
* Set custom geotiff include path used for the Debian package.
libgeotiff 1.4.2-RC4 changed to #include <geo_config.h> which breaks with
/usr/include/geotiff used by the Debian package.
(closes: #836308)
2016-04-17 - Bas Couwenberg <sebastic@debian.org>
librasterlite2 (1.0.0~rc0+devel1-3) unstable; urgency=medium
* Update Vcs-Browser URL to use HTTPS.
* Bump Standards-Version to 3.9.8, no changes.
* Enable all hardening buildflags.
* Enable parallel builds.
2015-07-17 - Bas Couwenberg <sebastic@debian.org>
librasterlite2 (1.0.0~rc0+devel1-2) unstable; urgency=medium
* Skip tests on mips, s390x, sparc, hppa & ppc64, test-driver segfaults.
2015-07-14 - Bas Couwenberg <sebastic@debian.org>
librasterlite2 (1.0.0~rc0+devel1-1) unstable; urgency=medium
* Move from experimental to unstable.
2015-07-11 - Bas Couwenberg <sebastic@debian.org>
librasterlite2 (1.0.0~rc0+devel1-1~exp2) experimental; urgency=medium
* Drop spatialite.1 man page, shouldn't be included in librasterlite2.
(closes: #792103)
2015-07-01 - Bas Couwenberg <sebastic@debian.org>
librasterlite2 (1.0.0~rc0+devel1-1~exp1) experimental; urgency=medium
* New upstream pre-release.
* Drop patches applied upstream.
* Bump minimum required libspatialite to 4.3.0.
2015-06-27 - Bas Couwenberg <sebastic@debian.org>
librasterlite2 (1.0.0~rc0+devel-1~exp1) experimental; urgency=medium
* Also support -devel pre-releases in watchfile uversionmangle.
* New upstream pre-release.
* Update copyright file, changes:
- Update copyright years
- Add license & copyright for new files
- Drop .0 from GPL license shortnames
* Add build dependencies: libcharls-dev, libfreetype6-dev & libopenjp2-7-dev.
* Drop patches applied upstream.
* Bump minimum required libspatialite to 4.3.0~rc1.
* Add gbp.conf to use pristine-tar by default.
* Add patch to fix SOVERSION, was decremented from 1 to 0.
* Add man page for rl2sniff.
* Update symbols for 1.0.0~rc0+devel pre-release.
2015-06-11 - Bas Couwenberg <sebastic@debian.org>
librasterlite2 (1.0.0~rc0-1~exp2) experimental; urgency=medium
* Add upstream metadata.
* Update my email to use @debian.org address.
* Override dh_clean to remove generated man pages.
* Set the date embedded in man pages to the build date for
reproducible builds.
* Update copyright file, add license & copyright for test code & svg files.
* Update Vcs-Browser URL to use cgit instead of gitweb.
* Rename mod_rasterlite2 package to match naming for mod_spatialite.

See Also

Package Description
librasterlite2-dev_1.0.0~rc0+devel1-6_i386.deb library for huge raster coverages using a SpatiaLite DBMS - headers
libratbag-common_0.9-4_all.deb configuration library for gaming mice - common files
libratbag-dev_0.9-4_i386.deb configuration library for gaming mice - development files
libratbag-doc_0.9-4_all.deb configuration library for gaming mice - documentation
libratbag-tools_0.9-4_i386.deb configuration tools for gaming mice
libratbag4_0.9-4_i386.deb configuration library for gaming mice
libratpoints-2.1.3_2.1.3-1build1_i386.deb library for finding rational points on hyperelliptic curves
libratpoints-dev_2.1.3-1build1_i386.deb development files for libratpoints
libraul-dev_0.8.0+dfsg0-0.1ubuntu1_i386.deb real time audio utility library -- development files
libraul-doc_0.8.0+dfsg0-0.1ubuntu1_all.deb real time audio utility library -- documentation
libraul10v5_0.8.0+dfsg0-0.1ubuntu1_i386.deb real time audio utility library
libraven0_10.4+git20171031.10.g9f71bb8-1.2ubuntu1_i386.deb Raven library for budgie-desktop
libraw-bin_0.18.8-1_i386.deb raw image decoder library (tools)
libraynes-fs-clojure_1.4.6-1_all.deb filesystem utility library for Clojure
librbl-dev_2.11.0~alpha-11build1_i386.deb Headers/development libraries for the OpenDKIM RBL library
Advertisement
Advertisement