libqwtplot3d-qt5-dev_0.2.7+svn191+gcc7-2_i386.deb


Advertisement

Description

libqwtplot3d-qt5-dev - 3D plotting library based on Qt5/OpenGL (development)

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libqwtplot3d-qt5-dev
Package version 0.2.7+svn191+gcc7
Package release 2
Package architecture i386
Package type deb
Installed size 102 B
Download size 21.70 KB
Official Mirror archive.ubuntu.com
QwtPlot3D is a feature rich Qt/OpenGL-based C++ programming
library, providing essentially a bunch of 3D-widgets for
programmers.
This package contains the QwtPlot3D development files for Qt5.

Alternatives

Package Version Architecture Repository
libqwtplot3d-qt5-dev_0.2.7+svn191+gcc7-2_amd64.deb 0.2.7+svn191+gcc7 amd64 Ubuntu Universe
libqwtplot3d-qt5-dev - - -

Requires

Name Value
libqwtplot3d-qt5-0 = 0.2.7+svn191+gcc7-2

Download

Type URL
Binary Package libqwtplot3d-qt5-dev_0.2.7+svn191+gcc7-2_i386.deb
Source Package qwtplot3d

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libqwtplot3d-qt5-dev deb package:
    # sudo apt-get install libqwtplot3d-qt5-dev

Files

Path
/usr/include/qwtplot3d/qwt3d_autoptr.h
/usr/include/qwtplot3d/qwt3d_autoscaler.h
/usr/include/qwtplot3d/qwt3d_axis.h
/usr/include/qwtplot3d/qwt3d_color.h
/usr/include/qwtplot3d/qwt3d_colorlegend.h
/usr/include/qwtplot3d/qwt3d_coordsys.h
/usr/include/qwtplot3d/qwt3d_drawable.h
/usr/include/qwtplot3d/qwt3d_enrichment.h
/usr/include/qwtplot3d/qwt3d_enrichment_std.h
/usr/include/qwtplot3d/qwt3d_function.h
/usr/include/qwtplot3d/qwt3d_global.h
/usr/include/qwtplot3d/qwt3d_graphplot.h
/usr/include/qwtplot3d/qwt3d_gridmapping.h
/usr/include/qwtplot3d/qwt3d_helper.h
/usr/include/qwtplot3d/qwt3d_io.h
/usr/include/qwtplot3d/qwt3d_io_gl2ps.h
/usr/include/qwtplot3d/qwt3d_io_reader.h
/usr/include/qwtplot3d/qwt3d_label.h
/usr/include/qwtplot3d/qwt3d_mapping.h
/usr/include/qwtplot3d/qwt3d_multiplot.h
/usr/include/qwtplot3d/qwt3d_openglhelper.h
/usr/include/qwtplot3d/qwt3d_parametricsurface.h
/usr/include/qwtplot3d/qwt3d_plot.h
/usr/include/qwtplot3d/qwt3d_portability.h
/usr/include/qwtplot3d/qwt3d_scale.h
/usr/include/qwtplot3d/qwt3d_surfaceplot.h
/usr/include/qwtplot3d/qwt3d_types.h
/usr/include/qwtplot3d/qwt3d_volumeplot.h
/usr/lib/libqwtplot3d-qt5.so
/usr/share/doc/libqwtplot3d-qt5-dev/README.Debian
/usr/share/doc/libqwtplot3d-qt5-dev/changelog.Debian.gz
/usr/share/doc/libqwtplot3d-qt5-dev/copyright

Changelog

2017-12-25 - Gudjon I. Gudjonsson <gudjon@gudjon.org>
qwtplot3d (0.2.7+svn191+gcc7-2) unstable; urgency=medium
[ Gudjon I. Gudjonsson ]
* Add symbols files
* Remove support for Qt4 (Closes: #875167)
[ Andreas Tille ]
* Moved packaging from SVN to Git
* cme fix dpkg-control; cme fix dpkg-copyright
* debhelper 10
[ Gudjon I. Gudjonsson ]
* Bump standards version to 4.1.2, no changes needed
2017-09-19 - Georges Khaznadar <georgesk@debian.org>
qwtplot3d (0.2.7+svn191+gcc7-1.0) unstable; urgency=medium
* Non-maintainer upload.
* No change in the source, but ...
* Changed the version string to prevent collisions with variants
of qwtplot3d-0.2.7+svn191, especially in backports. Reinitialized
.symbols files. Closes: #853635
* Updated debhelper version, Standards-Version.
2016-12-23 - Arto Jantunen <viiru@debian.org>
qwtplot3d (0.2.7+svn191-10.1) unstable; urgency=low
* Non-maintainer upload.
* Apply patch from Graham Inggs <ginggs@debian.org> to update symbols
for gcc 6 (Closes: #811986)
2016-03-24 - Gudjon I. Gudjonsson <gudjon@gudjon.org>
qwtplot3d (0.2.7+svn191-10) unstable; urgency=medium
* Disable qt5 library on architectures armel and armhf. 
It doesn't compile on these architectures because of opengl problems.
* Bump standards version to 3.9.7,no changes needed.
* Change VCS field to https
* Change hardening to +all
2015-09-05 - Gudjon I. Gudjonsson <gudjon@gudjon.org>
qwtplot3d (0.2.7+svn191-9) unstable; urgency=medium
* Add Qt5 library
* Add support for Qt5 to examples patch
2015-09-02 - Gudjon I. Gudjonsson <gudjon@gudjon.org>
qwtplot3d (0.2.7+svn191-8) unstable; urgency=medium
* Make svn references canonical
* Bump standards version to 3.9.6
* Change debhelper dependency to 9
* Add hardening flags
* Add symbols control file
* Update build system
* Add pkg-kde-tools to build system
* Change qt4 package name to libqwtplot3d-qt4-0v5 (Closes:  #791264)
2012-05-16 - Gudjon I. Gudjonsson <gudjon@gudjon.org>
qwtplot3d (0.2.7+svn191-7) unstable; urgency=low
* Remove -lGLU from examples/common.pro, Reverting
last change.
* Add -lGLU to qwtplot3d.pro and add dependency on
libglu1-mesa-dev | libglu-dev (Closes: #672873)
2012-05-12 - Gudjon I. Gudjonsson <gudjon@gudjon.org>
qwtplot3d (0.2.7+svn191-6) unstable; urgency=low
* Fix ftbs (Closes: #672023, #665750)
* Bump standards version to 3.9.3
* Set debhelper dependency to >=8
* Add build-arch and build-indep to rules
* Change copyright to copyright-format 1.0
* Add -lGLU to examples library dependencies
2011-03-03 - Gudjon I. Gudjonsson <gudjon@gudjon.org>
qwtplot3d (0.2.7+svn191-5) unstable; urgency=low
* Remove qt3 support (Closes: #604380)
* Bump standards version to 3.9.1
* Remove README.source
* Switch to dpkg-source 3.0 (quilt) format
* Rewrite patches in quilt format
* Add dependency on zlib1g-dev
* Upgrade copyright file to current format
* Add watch file
* Add misc Depends
* Add doc-base file
* Remove qt3 related things from patches
2009-11-21 - Gudjon I. Gudjonsson <gudjon@gudjon.org>
qwtplot3d (0.2.7+svn191-4) unstable; urgency=low
* Add conflicts and replaces on the old packages libqwtplot3d-qt{3,4}

See Also

Package Description
libqxmlrpc-dev_0.0.svn6-2_i386.deb full Qt4 based implementation of XML-RPC protocol. (headers)
libqxmlrpc-doc_0.0.svn6-2_all.deb full Qt4 based implementation of XML-RPC protocol. (headers)
libqxmlrpc1_0.0.svn6-2_i386.deb full Qt4 based implementation of XML-RPC protocol
libqxmpp-dev_0.9.3-1build3_i386.deb Development files for the QXmpp library
libqxmpp-doc_0.9.3-1build3_all.deb Documentation for the QXmpp library
libqxmpp0_0.9.3-1build3_i386.deb QXmpp library for XMPP client and server applications
libqxp-0.0-0_0.0.1-1_i386.deb library for reading and converting QuarkXPress files
libqxp-dev_0.0.1-1_i386.deb library for reading and converting QuarkXPress files -- development
libqxp-doc_0.0.1-1_all.deb library for reading and converting QuarkXPress files -- documentation
libqxp-tools_0.0.1-1_i386.deb library for reading and converting QuarkXPress files -- tools
libqxt-berkeley0_0.6.2-3_i386.deb Berkeley databases module for Qt (LibQxt)
libqxt-core0_0.6.2-3_i386.deb extensions to Qt core classes (LibQxt)
libqxt-designer0_0.6.2-3_i386.deb LibQxt extensions to Qt Designer
libqxt-dev_0.6.2-3_i386.deb LibQxt development files
libqxt-doc_0.6.2-3_all.deb LibQxt reference documentation
Advertisement
Advertisement