libqwt5-qt4_5.2.3-1_i386.deb


Advertisement

Description

libqwt5-qt4 - Qt4 widgets library for technical applications (runtime)

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libqwt5-qt4
Package version 5.2.3
Package release 1
Package architecture i386
Package type deb
Installed size 786 B
Download size 302.98 KB
Official Mirror archive.ubuntu.com
The Qwt library contains Qt GUI Components and utility classes which
are primarily useful for programs with a technical background. Most of
these widgets are used to control or display values, arrays, or ranges
of type double.
This package contains the files necessary for running applications that
use the Qwt library and Qt4.

Alternatives

Package Version Architecture Repository
libqwt5-qt4_5.2.3-1_amd64.deb 5.2.3 amd64 Ubuntu Universe
libqwt5-qt4 - - -

Requires

Name Value
libc6 >= 2.1.3
libgcc1 >= 1:4.1.1
libqt4-svg >= 4:4.8.0~
libqtcore4 >= 4:4.8.0~
libqtgui4 >= 4:4.8.0~
libstdc++6 >= 4.1.1

Download

Type URL
Binary Package libqwt5-qt4_5.2.3-1_i386.deb
Source Package qwt5

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libqwt5-qt4 deb package:
    # sudo apt-get install libqwt5-qt4

Files

Path
/usr/lib/libqwt-qt4.so.5
/usr/lib/libqwt-qt4.so.5.2
/usr/lib/libqwt-qt4.so.5.2.3
/usr/share/doc/libqwt5-qt4/changelog.Debian.gz
/usr/share/doc/libqwt5-qt4/copyright

Changelog

2013-05-10 - Gudjon I. Gudjonsson <gudjon@gudjon.org>
qwt5 (5.2.3-1) unstable; urgency=low
* New upstream release
* Removed one missing warning from patch 02_add_missing_warnings.diff 
* Bump compat version to 9
* Bump standards version to 3.9.4
* Change debhelper dependency to version 9
* Add hardening includes to rules file
* Add build dependency on dpkg-dev (>= 1.16.1~)
2012-05-15 - Gudjon I. Gudjonsson <gudjon@gudjon.org>
qwt5 (5.2.2-3) unstable; urgency=low
[ Scott Kitterman ]
* Update for multi-arch Qt
- Change install path for libqwt_designer_plugin.so in
libqwt5-qt4-dev.install
- Update build-depends version requirements for libqt4-dev and debhelper
- Add misc:Pre-Depends for libqwt5-qt4
* Bump compat to 8
[ Gudjon I. Gudjonsson ]
* New upload (Closes: #662512)
2012-04-08 - Gudjon I. Gudjonsson <gudjon@gudjon.org>
qwt5 (5.2.2-2) unstable; urgency=low
* Remove man page deprecated.3 (Closes: #648283)
* Add watch file
* Bump standards version to 3.9.3
2011-08-16 - Gudjon I. Gudjonsson <gudjon@gudjon.org>
qwt5 (5.2.2-1) unstable; urgency=low
* New upstream release.
* Change source name to qwt5
* Remove qt3 support
* Bump standards version to 3.9.2
* Switch to dpkg-source 3.0 (quilt) format
* Remove patch 03_qwt_branch_pull_r544.diff
* Rewrite patches. Removing qt3 stuff but keeping
-qt4 endings for backwards compatibility with Debian
packages depending on qwt5
* Add patch 03_manpage_spelling to fix spelling errors in manpages
* Add doc base file
2009-07-01 - Fathi Boudra <fabo@debian.org>
qwt (5.2.0-1) unstable; urgency=low
* New upstream release.
* Add branch pull patch from svn r544.
* Bump Standards-Version to 3.8.2. No changes needed.
* Update installed manpages.
* Use qwt as base name for directory (drop version).
* Add missing warnings patch.
* Rewrite debian/rules: use dh.
2009-04-12 - Fathi Boudra <fabo@debian.org>
qwt (5.1.2-1) unstable; urgency=low
* New upstream release.
* Bump compat/debhelper to 7.
* Bump Standards-Version to 3.8.1. No changes needed.
* Invert Maintainers and Uploaders field.
* Fix lintian warnings:
- dh_clean _k deprecated.
- missing dependency on libc.
2008-05-26 - Fathi Boudra <fabo@debian.org>
qwt (5.1.1-1) unstable; urgency=low
* New upstream release.
2008-05-09 - Fathi Boudra <fabo@debian.org>
qwt (5.1.0-1) unstable; urgency=low
* New upstream release.
* Refresh makefiles patch.
* Remove QwtPlotScaleItem patch.
* Bump compat/debhelper to 6.
2007-10-05 - Fathi Boudra <fboudra@free.fr>
qwt (5.0.2-2) unstable; urgency=low
* Handle nostrip build option. (Closes: #437877)
* Build libqwt5-doc package in binary-indep target. (Closes: #443110)
2007-07-29 - Fathi Boudra <fboudra@free.fr>
qwt (5.0.2-1) unstable; urgency=low
* New upstream release.
* Refresh QwtPlotScaleItem from svn revision 66.
* Switch to quilt patch system.

See Also

Package Description
libqwt6abi1_6.1.3-1_i386.deb Qt widgets library for technical applications (runtime, qt4)
libqwtmathml-dev_6.1.3-1_i386.deb Text Engine for Qwt (development, qt4)
libqwtmathml-qt5-6_6.1.3-1_i386.deb Text Engine for Qwt (runtime, qt5)
libqwtmathml-qt5-dev_6.1.3-1_i386.deb Text Engine for Qwt (development, qt5)
libqwtmathml6abi1_6.1.3-1_i386.deb Text Engine for Qwt (runtime, qt4)
libqwtplot3d-doc_0.2.7+svn191+gcc7-2_all.deb 3D plotting library based on Qt/OpenGL (documentation)
libqwtplot3d-qt5-0_0.2.7+svn191+gcc7-2_i386.deb 3D plotting library based on Qt5/OpenGL (runtime)
libqwtplot3d-qt5-dev_0.2.7+svn191+gcc7-2_i386.deb 3D plotting library based on Qt5/OpenGL (development)
libqxmlrpc-dev_0.0.svn6-2_i386.deb full Qt4 based implementation of XML-RPC protocol. (headers)
libqxmlrpc-doc_0.0.svn6-2_all.deb full Qt4 based implementation of XML-RPC protocol. (headers)
libqxmlrpc1_0.0.svn6-2_i386.deb full Qt4 based implementation of XML-RPC protocol
libqxmpp-dev_0.9.3-1build3_i386.deb Development files for the QXmpp library
libqxmpp-doc_0.9.3-1build3_all.deb Documentation for the QXmpp library
libqxmpp0_0.9.3-1build3_i386.deb QXmpp library for XMPP client and server applications
libqxp-0.0-0_0.0.1-1_i386.deb library for reading and converting QuarkXPress files
Advertisement
Advertisement