libqtcore4-perl_4.14.1-0ubuntu11_i386.deb


Advertisement

Description

libqtcore4-perl - perl bindings for the Qt Core library

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libqtcore4-perl
Package version 4.14.1
Package release 0ubuntu11
Package architecture i386
Package type deb
Installed size 872 B
Download size 176.64 KB
Official Mirror archive.ubuntu.com
This package contains perl bindings for the Qt Core library.
It enables the use of Qt applications written in perl. For more details
see the libqtcore4 package.
This Package is part of the PerlQt module.

Alternatives

Package Version Architecture Repository
libqtcore4-perl_4.14.1-0ubuntu11_amd64.deb 4.14.1 amd64 Ubuntu Universe
libqtcore4-perl - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:3.0
liblist-moreutils-perl -
libperl5.26 >= 5.26.0~rc1
libqt4-network >= 4:4.5.3
libqtcore4 >= 4:4.7.0~beta1
libqtgui4 >= 4:4.5.3
libsmokebase3v5 >= 4:4.14.3
libsmokeqtcore4-3 >= 4:4.14.3
libstdc++6 >= 5.2
perl >= 5.26.1-4build1
perlapi-5.26.1 -

Download

Type URL
Binary Package libqtcore4-perl_4.14.1-0ubuntu11_i386.deb
Source Package perlqt

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libqtcore4-perl deb package:
    # sudo apt-get install libqtcore4-perl

Files

Path
/usr/lib/i386-linux-gnu/perl5/5.26/QtCore4.pm
/usr/lib/i386-linux-gnu/perl5/5.26/QtCore4/classinfo.pm
/usr/lib/i386-linux-gnu/perl5/5.26/QtCore4/debug.pm
/usr/lib/i386-linux-gnu/perl5/5.26/QtCore4/isa.pm
/usr/lib/i386-linux-gnu/perl5/5.26/QtCore4/signals.pm
/usr/lib/i386-linux-gnu/perl5/5.26/QtCore4/slots.pm
/usr/lib/i386-linux-gnu/perl5/5.26/auto/QtCore4/QtCore4.so
/usr/share/doc/libqtcore4-perl/changelog.Debian.gz
/usr/share/doc/libqtcore4-perl/copyright

Changelog

2018-02-07 - Matthias Klose <doko@ubuntu.com>
perlqt (4:4.14.1-0ubuntu11) bionic; urgency=medium
* Stop building the packages not having smokeqt support anymore.
2018-02-07 - Matthias Klose <doko@ubuntu.com>
perlqt (4:4.14.1-0ubuntu10) bionic; urgency=medium
* No-change rebuild for qscintilla2 soname change.
2017-07-26 - Matthias Klose <doko@ubuntu.com>
perlqt (4:4.14.1-0ubuntu9) artful; urgency=medium
* No-change rebuild for perl 5.26.0.
2016-10-25 - Iain Lane <iain@orangesquash.org.uk>
perlqt (4:4.14.1-0ubuntu8) zesty; urgency=medium
* debian/patches/0001-Initialize-smokeperl_object-properly.patch:
Cherry-pick from upstream to build with GCC 6.
2015-12-28 - Colin Watson <cjwatson@ubuntu.com>
perlqt (4:4.14.1-0ubuntu7) xenial; urgency=medium
* Remove libqtwebkit4-perl binary package, since WebKit support has been
removed from smokeqt (see https://bugs.debian.org/784528).
2015-12-18 - Colin Watson <cjwatson@ubuntu.com>
perlqt (4:4.14.1-0ubuntu6) xenial; urgency=medium
* Rebuild for Perl 5.22.1.
2015-11-07 - Steve Langasek <steve.langasek@ubuntu.com>
perlqt (4:4.14.1-0ubuntu5) xenial; urgency=medium
* No-change rebuild against libsmokeqttest4-3
2015-08-31 - Matthias Klose <doko@ubuntu.com>
perlqt (4:4.14.1-0ubuntu4) wily; urgency=medium
* No-change rebuild against libsmokeqtcore4-3v5
2015-08-12 - Steve Langasek <steve.langasek@ubuntu.com>
perlqt (4:4.14.1-0ubuntu3) wily; urgency=medium
* No-change rebuild against libsmokeqtcore4-3v5
2014-10-31 - Scott Kitterman <scott@kitterman.com>
perlqt (4:4.14.1-0ubuntu2) vivid; urgency=medium
* Add debian/patches/additionalperl5.20.diff from upstream to complete
Perl 5.20 compatibility fixes

See Also

Package Description
libqtcore4_4.8.7+dfsg-7ubuntu1_i386.deb Qt 4 core module
libqtcurve-utils2_1.8.18+git20160320-3d8622c-5build4_i386.deb common library for QtCurve
libqtdbus4_4.8.7+dfsg-7ubuntu1_i386.deb Qt 4 D-Bus module library
libqtdbusmock1-common_0.7+17.04.20170316.1-0ubuntu1_all.deb Library for mocking DBus interactions using Qt
libqtdbusmock1-dev_0.7+17.04.20170316.1-0ubuntu1_i386.deb Library for mocking DBus interactions using Qt
libqtdbusmock1_0.7+17.04.20170316.1-0ubuntu1_i386.deb Library for mocking DBus interactions using Qt
libqtdbustest1-dev_0.2+17.04.20170106-0ubuntu1_i386.deb Library for testing DBus interactions using Qt
libqtdbustest1_0.2+17.04.20170106-0ubuntu1_i386.deb Library for testing DBus interactions using Qt
libqtdee-dev_0.2.4-0ubuntu1_i386.deb Qt binding and QML plugin for Dee - development files
libqtdee2_0.2.4-0ubuntu1_i386.deb Qt binding and QML plugin for Dee - shared library
libqtdee3_3.3+14.04.20140317-0ubuntu2~gcc5.1_i386.deb QtQuick1 plugin for Dee
libqtermwidget5-0-dev_0.8.0-5_i386.deb Terminal emulator widget for Qt 5 (development files)
libqtermwidget5-0_0.8.0-5_i386.deb Terminal emulator widget for Qt 5 (shared libraries)
libqtexengine-dev_0.3-3_i386.deb Development files for the QTeXEngine library
libqtexengine1_0.3-3_i386.deb Library to export graphics created using QPainter to TeX
Advertisement
Advertisement