libqt5xdg-dev_3.1.0-5build2_i386.deb


Advertisement

Description

libqt5xdg-dev - Development files for libqtxdg

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libqt5xdg-dev
Package version 3.1.0
Package release 5build2
Package architecture i386
Package type deb
Installed size 89 B
Download size 14.76 KB
Official Mirror archive.ubuntu.com
This library implements functions of the XDG Specifications in Qt. It is part
of LXQt.
This package provides development files.

Alternatives

Package Version Architecture Repository
libqt5xdg-dev_3.1.0-5build2_amd64.deb 3.1.0 amd64 Ubuntu Universe
libqt5xdg-dev - - -

Requires

Name Value
libqt5xdg3 = 3.1.0-5build2
libqt5xdgiconloader-dev = 3.1.0-5build2

Download

Type URL
Binary Package libqt5xdg-dev_3.1.0-5build2_i386.deb
Source Package libqtxdg

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libqt5xdg-dev deb package:
    # sudo apt-get install libqt5xdg-dev

Files

Path
/usr/include/qt5xdg/XdgAction
/usr/include/qt5xdg/XdgAutoStart
/usr/include/qt5xdg/XdgDesktopFile
/usr/include/qt5xdg/XdgDirs
/usr/include/qt5xdg/XdgIcon
/usr/include/qt5xdg/XdgMenu
/usr/include/qt5xdg/XdgMenuWidget
/usr/include/qt5xdg/XdgMimeType
/usr/include/qt5xdg/XmlHelper
/usr/include/qt5xdg/xdgaction.h
/usr/include/qt5xdg/xdgautostart.h
/usr/include/qt5xdg/xdgdesktopfile.h
/usr/include/qt5xdg/xdgdirs.h
/usr/include/qt5xdg/xdgicon.h
/usr/include/qt5xdg/xdgmacros.h
/usr/include/qt5xdg/xdgmenu.h
/usr/include/qt5xdg/xdgmenuwidget.h
/usr/include/qt5xdg/xdgmimetype.h
/usr/include/qt5xdg/xmlhelper.h
/usr/lib/i386-linux-gnu/libQt5Xdg.so
/usr/lib/i386-linux-gnu/pkgconfig/Qt5Xdg.pc
/usr/share/cmake/qt5xdg/qt5xdg-config-version.cmake
/usr/share/cmake/qt5xdg/qt5xdg-config.cmake
/usr/share/cmake/qt5xdg/qt5xdg-targets-relwithdebinfo.cmake
/usr/share/cmake/qt5xdg/qt5xdg-targets.cmake
/usr/share/doc/libqt5xdg-dev/changelog.Debian.gz
/usr/share/doc/libqt5xdg-dev/copyright

Changelog

2018-04-14 - Simon Quigley <tsimonq2@ubuntu.com>
libqtxdg (3.1.0-5build2) bionic; urgency=medium
* No-change rebuild against qtbase-abi-5-9-5.
2018-02-27 - Simon Quigley <tsimonq2@ubuntu.com>
libqtxdg (3.1.0-5build1) bionic; urgency=medium
* No-change rebuild against qtbase-abi-5-9-4.
2017-12-14 - Alf Gaida <agaida@siduction.org>
libqtxdg (3.1.0-5) unstable; urgency=medium
* Bumped Standards to 4.1.2, no changes needed
* Removed debian/gbp.conf
* Removed branch from VCS fields 
2017-12-04 - Alf Gaida <agaida@siduction.org>
libqtxdg (3.1.0-4) unstable; urgency=medium
* Switch to unstable
2017-11-30 - Alf Gaida <agaida@siduction.org>
libqtxdg (3.1.0-3) experimental; urgency=medium
* Removed superfluous line from symbols
* Removed trailing whitespaces from changelog
2017-10-27 - Alf Gaida <agaida@siduction.org>
libqtxdg (3.1.0-2) experimental; urgency=medium
* Pick up Qt 5.9.2
2017-10-22 - Alf Gaida <agaida@siduction.org>
libqtxdg (3.1.0-1) experimental; urgency=medium
* Cherry-picked new upstream-release 3.1.0
* Added lintian-overrides for tools package
* Added new symbols for action handling
2017-10-09 - Alf Gaida <agaida@siduction.org>
libqtxdg (3.0.0-1) experimental; urgency=medium
* Imported new upstream release: 3.0.0
* Switched to experimental
* Renamed packages to reflect the new soname
* Added dependency libqt5svg5-dev to QtXdgIconloader dev package.
* Bumped Standards to 4.1.1
* Added override_dh_missing
* Added tools package
* Fixed symbols
* Reworked copyright
2017-10-03 - Alf Gaida <agaida@siduction.org>
libqtxdg (2.0.0-8) unstable; urgency=medium
* Added dependency libqt5svg5-dev to QtXdgIconloader dev package.
(Closes: #877569)- Thanks Tim Dengel <tim.dengel.debian@gmail.com>
* Bumped Standards to 4.1.1
* added override_dh_missing to rules
2017-07-24 - Alf Gaida <agaida@siduction.org>
libqtxdg (2.0.0-7) unstable; urgency=medium
* Added qttranslations5-l10n to Recommends - without this packagage there are
no working shortcuts in localized LXQt desktops. So we want to make sure
that the package is at least recommended for qtxdg based packages.

See Also

Package Description
libqt5xdg3_3.1.0-5build2_i386.deb Implementation of the XDG Specifications for Qt (shared lib)
libqt5xdgiconloader-dev_3.1.0-5build2_i386.deb Development files for libqtxdgiconloader
libqt5xdgiconloader3_3.1.0-5build2_i386.deb Implementation of the XDG Iconloader for Qt (shared lib)
libqt5xmlpatterns5-dev_5.9.5-0ubuntu1_i386.deb Qt 5 XML patterns development files
libqt5xmlpatterns5_5.9.5-0ubuntu1_i386.deb Qt 5 XML patterns module
libqtassistantclient-dev_4.6.3-7build1_i386.deb Qt Assistant client library (development)
libqtassistantclient4_4.6.3-7build1_i386.deb Qt Assistant client library (runtime)
libqtav-dev_1.12.0+ds-4build3_i386.deb QtAV development files
libqtav-private-dev_1.12.0+ds-4build3_i386.deb QtAV private development files
libqtav1_1.12.0+ds-4build3_i386.deb QtAV library
libqtavwidgets1_1.12.0+ds-4build3_i386.deb QtAV Widgets module
libqtbamf-dev_0.2.4-0ubuntu2_i386.deb Qt binding and QML plugin for bamf - development files
libqtbamf1_0.2.4-0ubuntu2_i386.deb Qt binding and QML plugin for bamf - shared library
libqtcore4-perl_4.14.1-0ubuntu11_i386.deb perl bindings for the Qt Core library
libqtcore4_4.8.7+dfsg-7ubuntu1_i386.deb Qt 4 core module
Advertisement
Advertisement