libqt5websockets5-dev_5.9.5-0ubuntu1_i386.deb


Advertisement

Description

libqt5websockets5-dev - Qt 5 Web Sockets module - development files

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libqt5websockets5-dev
Package version 5.9.5
Package release 0ubuntu1
Package architecture i386
Package type deb
Installed size 74 B
Download size 9.69 KB
Official Mirror archive.ubuntu.com
Qt is a cross-platform C++ application framework. Qt's primary feature
is its rich set of widgets that provide standard GUI functionality.
This package contains the development files needed to build Qt applications
using Qt 5 Web Sockets library.

Alternatives

Package Version Architecture Repository
libqt5websockets5-dev_5.9.5-0ubuntu1_amd64.deb 5.9.5 amd64 Ubuntu Universe
libqt5websockets5-dev - - -

Requires

Name Value
libqt5websockets5 = 5.9.5-0ubuntu1
qtbase5-dev -

Download

Type URL
Binary Package libqt5websockets5-dev_5.9.5-0ubuntu1_i386.deb
Source Package qtwebsockets-opensource-src

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libqt5websockets5-dev deb package:
    # sudo apt-get install libqt5websockets5-dev

Files

Path
/usr/include/i386-linux-gnu/qt5/QtWebSockets/QMaskGenerator
/usr/include/i386-linux-gnu/qt5/QtWebSockets/QWebSocket
/usr/include/i386-linux-gnu/qt5/QtWebSockets/QWebSocketCorsAuthenticator
/usr/include/i386-linux-gnu/qt5/QtWebSockets/QWebSocketProtocol
/usr/include/i386-linux-gnu/qt5/QtWebSockets/QWebSocketServer
/usr/include/i386-linux-gnu/qt5/QtWebSockets/QtWebSockets
/usr/include/i386-linux-gnu/qt5/QtWebSockets/QtWebSocketsDepends
/usr/include/i386-linux-gnu/qt5/QtWebSockets/QtWebSocketsVersion
/usr/include/i386-linux-gnu/qt5/QtWebSockets/qmaskgenerator.h
/usr/include/i386-linux-gnu/qt5/QtWebSockets/qtwebsocketsversion.h
/usr/include/i386-linux-gnu/qt5/QtWebSockets/qwebsocket.h
/usr/include/i386-linux-gnu/qt5/QtWebSockets/qwebsocketcorsauthenticator.h
/usr/include/i386-linux-gnu/qt5/QtWebSockets/qwebsocketprotocol.h
/usr/include/i386-linux-gnu/qt5/QtWebSockets/qwebsockets_global.h
/usr/include/i386-linux-gnu/qt5/QtWebSockets/qwebsocketserver.h
/usr/lib/i386-linux-gnu/libQt5WebSockets.prl
/usr/lib/i386-linux-gnu/libQt5WebSockets.so
/usr/lib/i386-linux-gnu/cmake/Qt5WebSockets/Qt5WebSocketsConfig.cmake
/usr/lib/i386-linux-gnu/cmake/Qt5WebSockets/Qt5WebSocketsConfigVersion.cmake
/usr/lib/i386-linux-gnu/pkgconfig/Qt5WebSockets.pc
/usr/lib/i386-linux-gnu/qt5/mkspecs/modules/qt_lib_websockets.pri
/usr/share/doc/libqt5websockets5-dev/changelog.Debian.gz
/usr/share/doc/libqt5websockets5-dev/copyright

Changelog

2018-04-14 - Simon Quigley <tsimonq2@ubuntu.com>
qtwebsockets-opensource-src (5.9.5-0ubuntu1) bionic; urgency=medium
* New upstream release.
2018-02-24 - Simon Quigley <tsimonq2@ubuntu.com>
qtwebsockets-opensource-src (5.9.4-0ubuntu1) bionic; urgency=medium
* New upstream release.
* Bump build dependencies to Qt 5.9.4.
2017-12-13 - Simon Quigley <tsimonq2@ubuntu.com>
qtwebsockets-opensource-src (5.9.3-0ubuntu1) bionic; urgency=medium
* New upstream release.
* Bump build dependencies to Qt 5.9.3.
2017-10-28 - Dmitry Shachnev <mitya57@debian.org>
qtwebsockets-opensource-src (5.9.2-3) unstable; urgency=medium
* Make the tests results not fatal also on mips64el.
2017-10-26 - Dmitry Shachnev <mitya57@debian.org>
qtwebsockets-opensource-src (5.9.2-2) unstable; urgency=medium
* Upload to unstable.
2017-10-15 - Dmitry Shachnev <mitya57@debian.org>
qtwebsockets-opensource-src (5.9.2-1) experimental; urgency=medium
* New upstream release.
* Bump Qt build-dependencies to 5.9.2.
* Use debhelper compat level 10 and dh_missing.
* Bump Standards-Version to 4.1.1, no changes needed.
2017-08-16 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
qtwebsockets-opensource-src (5.9.1-3) unstable; urgency=medium
* Release to unstable.
2017-07-18 - Dmitry Shachnev <mitya57@debian.org>
qtwebsockets-opensource-src (5.9.1-2) experimental; urgency=medium
* Run the tests with --max-parallel=1 in hope it will reduce the
number of test failures.
* Temporarily ignore the tests results on armhf (not reproducible on
porterbox) and mips (see #868745), to make the transition possible.
2017-07-02 - Dmitry Shachnev <mitya57@debian.org>
qtwebsockets-opensource-src (5.9.1-1) experimental; urgency=medium
* New upstream patch release.
* Bump Qt build-dependencies to 5.9.1.
* Run QML tests during build, drop disable_qml_tests.patch.
* Bump Standards-Version to 4.0.0, no changes needed.
2017-06-10 - Simon Quigley <tsimonq2@ubuntu.com>
qtwebsockets-opensource-src (5.9.0-1) experimental; urgency=medium
* New upstream release.
* Build now needs private QML headers; install qtdeclarative5-private-dev
accordingly.
* Install the new QWebSocketProtocol file in the development headers.

See Also

Package Description
libqt5websockets5_5.9.5-0ubuntu1_i386.deb Qt 5 Web Sockets module
libqt5webview5-dev_5.9.5-0ubuntu1_i386.deb display web content in a QML application - Development Files
libqt5webview5_5.9.5-0ubuntu1_i386.deb display web content in a QML application - Library
libqt5x11extras5-dev_5.9.5-0ubuntu1_i386.deb Qt 5 X11 extras development files
libqt5x11extras5_5.9.5-0ubuntu1_i386.deb Qt 5 X11 extras
libqt5xdg-dev_3.1.0-5build2_i386.deb Development files for libqtxdg
libqt5xdg3_3.1.0-5build2_i386.deb Implementation of the XDG Specifications for Qt (shared lib)
libqt5xdgiconloader-dev_3.1.0-5build2_i386.deb Development files for libqtxdgiconloader
libqt5xdgiconloader3_3.1.0-5build2_i386.deb Implementation of the XDG Iconloader for Qt (shared lib)
libqt5xmlpatterns5-dev_5.9.5-0ubuntu1_i386.deb Qt 5 XML patterns development files
libqt5xmlpatterns5_5.9.5-0ubuntu1_i386.deb Qt 5 XML patterns module
libqtassistantclient-dev_4.6.3-7build1_i386.deb Qt Assistant client library (development)
libqtassistantclient4_4.6.3-7build1_i386.deb Qt Assistant client library (runtime)
libqtav-dev_1.12.0+ds-4build3_i386.deb QtAV development files
libqtav-private-dev_1.12.0+ds-4build3_i386.deb QtAV private development files
Advertisement
Advertisement