libqt5webengine5_5.9.5+dfsg-0ubuntu2_i386.deb


Advertisement

Description

libqt5webengine5 - Web content engine library for Qt

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libqt5webengine5
Package version 5.9.5+dfsg
Package release 0ubuntu2
Package architecture i386
Package type deb
Installed size 1.03 KB
Download size 170.83 KB
Official Mirror archive.ubuntu.com
QtWebEngine provides a Web browser engine that makes it easy to embed content
from the World Wide Web into your Qt application.
This package contains the QtWebEngine library.

Alternatives

Package Version Architecture Repository
libqt5webengine5_5.9.5+dfsg-0ubuntu2_amd64.deb 5.9.5+dfsg amd64 Ubuntu Universe
libqt5webengine5 - - -

Requires

Name Value
libc6 >= 2.4
libqt5core5a >= 5.9.0~beta
libqt5gui5 >= 5.3.0
libqt5qml5 >= 5.1.0
libqt5quick5 >= 5.9.0~beta
libqt5webchannel5 >= 5.6.1
libqt5webengine-data = 5.9.5+dfsg-0ubuntu2
libqt5webenginecore5 >= 5.9.5+dfsg-0ubuntu2
libstdc++6 >= 5
qtbase-abi-5-9-5 -
qtdeclarative-abi-5-9-5 -

Download

Type URL
Binary Package libqt5webengine5_5.9.5+dfsg-0ubuntu2_i386.deb
Source Package qtwebengine-opensource-src

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libqt5webengine5 deb package:
    # sudo apt-get install libqt5webengine5

Files

Path
/usr/lib/i386-linux-gnu/libQt5WebEngine.so.5
/usr/lib/i386-linux-gnu/libQt5WebEngine.so.5.9
/usr/lib/i386-linux-gnu/libQt5WebEngine.so.5.9.5
/usr/share/doc/libqt5webengine5/changelog.Debian.gz
/usr/share/doc/libqt5webengine5/copyright

Changelog

2018-04-15 - Dmitry Shachnev <mitya57@ubuntu.com>
qtwebengine-opensource-src (5.9.5+dfsg-0ubuntu2) bionic; urgency=medium
* Forcefully disable make output synchronization introduced in debhelper
11.1.5~alpha1. Ninja is a single process, and with synchronized output
the buildds do not see any activity and think that the build is hung.
2018-04-14 - Simon Quigley <tsimonq2@ubuntu.com>
qtwebengine-opensource-src (5.9.5+dfsg-0ubuntu1) bionic; urgency=medium
* New upstream release.
2018-02-26 - Simon Quigley <tsimonq2@ubuntu.com>
qtwebengine-opensource-src (5.9.4+dfsg-0ubuntu1) bionic; urgency=medium
* New upstream release.
2017-12-09 - Simon Quigley <tsimonq2@ubuntu.com>
qtwebengine-opensource-src (5.9.3+dfsg-0ubuntu1) bionic; urgency=medium
[ Dmitry Shachnev ]
* Backport upstream patch to fix build with ICU 60.
[ Simon Quigley ]
* New upstream release.
* Update symbols from build logs.
2017-10-27 - Dmitry Shachnev <mitya57@debian.org>
qtwebengine-opensource-src (5.9.2+dfsg-2) unstable; urgency=medium
* Update for Qt binaries location change in qtbase 5.9.2+dfsg-3.
- Install qwebengine_convert_dict tool into the new location.
- Provide a compatibility symlink for the old location.
- Bump qtbase5-private-dev and qttools5-dev-tools build-dependencies.
* Update libqt5webenginecore5.symbols from buildds’ logs.
* Upload to unstable.
2017-10-19 - Sandro Knauß <hefee@debian.org>
qtwebengine-opensource-src (5.9.2+dfsg-1) experimental; urgency=medium
* New upstream release.
* Remove upstream applied patch: armhf-options.patch
* Update patch hunks.
* Update copyright for 5.9.2.
* Add new Build-Dependency: qtquickcontrols2-5-dev
* Bump Qt build-dependencies to 5.9.2.
* Update symbols for libqt5webenginecore5 for 5.9.2 for amd64.
* Synchronize missing-sources for 5.9.2.
* Update lintian-overrides for source.
* Update lintian-overrides for libqt5webenginecore5
2017-09-30 - Dmitry Shachnev <mitya57@debian.org>
qtwebengine-opensource-src (5.9.1+dfsg-5) unstable; urgency=medium
* Drop add_mips_support.patch. Chromium cannot be built for big endian
anyway, because of skia.
* Limit Architecture field to architectures supported by upstream
(closes: #864323, #864324, #864325, #864326).
* Fix package name in dh_link command (closes: #876860).
* Bump Standards-Version to 4.1.1, stop using deprecated Priority: extra.
* Drop autotools-dev and dh-autoreconf build-dependencies, they are
unnecessary with debhelper 10.
2017-08-23 - Dmitry Shachnev <mitya57@debian.org>
qtwebengine-opensource-src (5.9.1+dfsg-4) unstable; urgency=medium
* Disable gold on arm64, to workaround bug #869768.
* Add the needed QML dependencies to qtwebengine5-examples package
(closes: #857859).
* Update debian/libqt5webenginecore5.symbols from buildds’ logs.
2017-08-16 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
qtwebengine-opensource-src (5.9.1+dfsg-3) unstable; urgency=medium
* Team upload.
* Release to unstable.
2017-07-21 - Dmitry Shachnev <mitya57@debian.org>
qtwebengine-opensource-src (5.9.1+dfsg-2) experimental; urgency=medium
* Make qtwebengine5-dev depend on qtpositioning5-dev, as the built CMake
files now include it as dependency.
* Add a patch to print compiler commands when bootstrapping gn. This helps
us discover wrong compiler flags, such as using -mfpu=neon on armhf.
* Add a patch to apply ARM compiler options even on host builds, to make
sure NEON is not used for gn bootstrap.
* Update symbols files from buildds’ logs.
* Add myself to Uploaders.

See Also

Package Description
libqt5webenginecore5_5.9.5+dfsg-0ubuntu2_i386.deb Web content engine library for Qt - Core
libqt5webenginewidgets5_5.9.5+dfsg-0ubuntu2_i386.deb Web content engine library for Qt - Widget
libqt5webkit5-dev_5.212.0~alpha2-7ubuntu1_i386.deb Web content engine library for Qt - development files
libqt5webkit5_5.212.0~alpha2-7ubuntu1_i386.deb Web content engine library for Qt
libqt5websockets5-dev_5.9.5-0ubuntu1_i386.deb Qt 5 Web Sockets module - development files
libqt5websockets5_5.9.5-0ubuntu1_i386.deb Qt 5 Web Sockets module
libqt5webview5-dev_5.9.5-0ubuntu1_i386.deb display web content in a QML application - Development Files
libqt5webview5_5.9.5-0ubuntu1_i386.deb display web content in a QML application - Library
libqt5x11extras5-dev_5.9.5-0ubuntu1_i386.deb Qt 5 X11 extras development files
libqt5x11extras5_5.9.5-0ubuntu1_i386.deb Qt 5 X11 extras
libqt5xdg-dev_3.1.0-5build2_i386.deb Development files for libqtxdg
libqt5xdg3_3.1.0-5build2_i386.deb Implementation of the XDG Specifications for Qt (shared lib)
libqt5xdgiconloader-dev_3.1.0-5build2_i386.deb Development files for libqtxdgiconloader
libqt5xdgiconloader3_3.1.0-5build2_i386.deb Implementation of the XDG Iconloader for Qt (shared lib)
libqt5xmlpatterns5-dev_5.9.5-0ubuntu1_i386.deb Qt 5 XML patterns development files
Advertisement
Advertisement