libqt5webchannel5_5.9.5-0ubuntu1_i386.deb


Advertisement

Description

libqt5webchannel5 - Web communication library for Qt

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libqt5webchannel5
Package version 5.9.5
Package release 0ubuntu1
Package architecture i386
Package type deb
Installed size 164 B
Download size 51.57 KB
Official Mirror archive.ubuntu.com
Qt WebChannel enables peer-to-peer communication between the host (QML/C++
application) and the client (HTML/JavaScript application). The transport
mechanism is supported out of the box by the two popular web engines, Qt
WebKit 2 and Qt WebEngine (experimental).
This package contains the QtWebChannel libraries.

Alternatives

Package Version Architecture Repository
libqt5webchannel5_5.9.5-0ubuntu1_amd64.deb 5.9.5 amd64 Ubuntu Universe
libqt5webchannel5 - - -

Requires

Name Value
libc6 >= 2.4
libqt5core5a >= 5.9.5+dfsg~
libqt5qml5 >= 5.1.0
libstdc++6 >= 5
qtbase-abi-5-9-5 -

Download

Type URL
Binary Package libqt5webchannel5_5.9.5-0ubuntu1_i386.deb
Source Package qtwebchannel-opensource-src

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libqt5webchannel5 deb package:
    # sudo apt-get install libqt5webchannel5

Files

Path
/usr/lib/i386-linux-gnu/libQt5WebChannel.so.5
/usr/lib/i386-linux-gnu/libQt5WebChannel.so.5.9
/usr/lib/i386-linux-gnu/libQt5WebChannel.so.5.9.5
/usr/share/doc/libqt5webchannel5/changelog.Debian.gz
/usr/share/doc/libqt5webchannel5/copyright

Changelog

2018-04-14 - Simon Quigley <tsimonq2@ubuntu.com>
qtwebchannel-opensource-src (5.9.5-0ubuntu1) bionic; urgency=medium
* New upstream release.
2018-02-24 - Simon Quigley <tsimonq2@ubuntu.com>
qtwebchannel-opensource-src (5.9.4-0ubuntu1) bionic; urgency=medium
* New upstream release.
2017-12-03 - Simon Quigley <tsimonq2@ubuntu.com>
qtwebchannel-opensource-src (5.9.3-0ubuntu1) bionic; urgency=medium
* New upstream release.
2017-11-27 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
qtwebchannel-opensource-src (5.9.2-3) unstable; urgency=medium
* Team upload.
[ Lisandro Damián Nicanor Pérez Meyer ]
* Make qtwebchannel5-examples recommends nodejs instead of directly
depending on it. Not all examples need nodejs.
- Add README.Debian explaining the issue.
- Expand the package description to warn the user to read README.Debian
before running the examples.
2017-10-26 - Dmitry Shachnev <mitya57@debian.org>
qtwebchannel-opensource-src (5.9.2-2) unstable; urgency=medium
* Upload to unstable.
2017-10-15 - Dmitry Shachnev <mitya57@debian.org>
qtwebchannel-opensource-src (5.9.2-1) experimental; urgency=medium
* New upstream release.
* Bump Qt build-dependencies to 5.9.2.
* Use dh_missing instead of deprecated dh_install --fail-missing.
* Bump Standards-Version to 4.1.1, no changes needed.
* Drop nodetonodejs.diff, no longer needed (see #862051).
2017-08-16 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
qtwebchannel-opensource-src (5.9.1-2) unstable; urgency=medium
* Release to unstable.
2017-07-05 - Dmitry Shachnev <mitya57@debian.org>
qtwebchannel-opensource-src (5.9.1-1) experimental; urgency=medium
* New upstream release.
* Bump Qt build-dependencies to 5.9.1.
* Bump Standards-Version to 4.0.0, no changes needed.
* Add myself to Uploaders.
2017-06-11 - Simon Quigley <tsimonq2@ubuntu.com>
qtwebchannel-opensource-src (5.9.0-1) experimental; urgency=medium
[ Simon Quigley ]
* New upstream release.
[ Dmitry Shachnev ]
* Update debian/copyright.
2017-04-04 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
qtwebchannel-opensource-src (5.7.1-2) unstable; urgency=medium
[ Lisandro Damián Nicanor Pérez Meyer ]
* Team upload.
* Do not depend upon npm (Closes: #857994). It is used just by some examples
and currently not on all archs, so while removing it is not the ideal
solution is the only one we have available right now.

See Also

Package Description
libqt5webengine-data_5.9.5+dfsg-0ubuntu2_all.deb Web content engine library for Qt - Data
libqt5webengine5_5.9.5+dfsg-0ubuntu2_i386.deb Web content engine library for Qt
libqt5webenginecore5_5.9.5+dfsg-0ubuntu2_i386.deb Web content engine library for Qt - Core
libqt5webenginewidgets5_5.9.5+dfsg-0ubuntu2_i386.deb Web content engine library for Qt - Widget
libqt5webkit5-dev_5.212.0~alpha2-7ubuntu1_i386.deb Web content engine library for Qt - development files
libqt5webkit5_5.212.0~alpha2-7ubuntu1_i386.deb Web content engine library for Qt
libqt5websockets5-dev_5.9.5-0ubuntu1_i386.deb Qt 5 Web Sockets module - development files
libqt5websockets5_5.9.5-0ubuntu1_i386.deb Qt 5 Web Sockets module
libqt5webview5-dev_5.9.5-0ubuntu1_i386.deb display web content in a QML application - Development Files
libqt5webview5_5.9.5-0ubuntu1_i386.deb display web content in a QML application - Library
libqt5x11extras5-dev_5.9.5-0ubuntu1_i386.deb Qt 5 X11 extras development files
libqt5x11extras5_5.9.5-0ubuntu1_i386.deb Qt 5 X11 extras
libqt5xdg-dev_3.1.0-5build2_i386.deb Development files for libqtxdg
libqt5xdg3_3.1.0-5build2_i386.deb Implementation of the XDG Specifications for Qt (shared lib)
libqt5xdgiconloader-dev_3.1.0-5build2_i386.deb Development files for libqtxdgiconloader
Advertisement
Advertisement