libqt5waylandcompositor5_5.9.5-0ubuntu1_i386.deb


Advertisement

Description

libqt5waylandcompositor5 - QtWayland compositor library

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libqt5waylandcompositor5
Package version 5.9.5
Package release 0ubuntu1
Package architecture i386
Package type deb
Installed size 1.21 KB
Download size 247.73 KB
Official Mirror archive.ubuntu.com
QtWayland is a Qt 5 module that wraps the functionality of Wayland.
This package contains the QtWayland compositor library.

Alternatives

Package Version Architecture Repository
libqt5waylandcompositor5_5.9.5-0ubuntu1_amd64.deb 5.9.5 amd64 Ubuntu Universe
libqt5waylandcompositor5 - - -

Requires

Name Value
libc6 >= 2.4
libgl1 -
libqt5core5a >= 5.9.5+dfsg~
libqt5gui5 >= 5.9.5+dfsg~
libqt5qml5 >= 5.0.2
libqt5quick5 >= 5.9.4
libstdc++6 >= 5
libwayland-server0 >= 1.6.0
libxkbcommon0 >= 0.5.0
qtbase-abi-5-9-5 -
qtdeclarative-abi-5-9-5 -

Download

Type URL
Binary Package libqt5waylandcompositor5_5.9.5-0ubuntu1_i386.deb
Source Package qtwayland-opensource-src

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libqt5waylandcompositor5 deb package:
    # sudo apt-get install libqt5waylandcompositor5

Files

Path
/usr/lib/i386-linux-gnu/libQt5WaylandCompositor.so.5
/usr/lib/i386-linux-gnu/libQt5WaylandCompositor.so.5.9
/usr/lib/i386-linux-gnu/libQt5WaylandCompositor.so.5.9.5
/usr/share/doc/libqt5waylandcompositor5/changelog.Debian.gz
/usr/share/doc/libqt5waylandcompositor5/copyright

Changelog

2018-04-14 - Simon Quigley <tsimonq2@ubuntu.com>
qtwayland-opensource-src (5.9.5-0ubuntu1) bionic; urgency=medium
* New upstream release.
2018-03-30 - Simon Quigley <tsimonq2@ubuntu.com>
qtwayland-opensource-src (5.9.4-0ubuntu2) bionic; urgency=medium
* Cherry-pick commit from the VCS Git repository which generates
libqt5waylandclient5-dev (LP: #1760185).
[ Lisandro Damián Nicanor Pérez Meyer ]
* Generate libqt5waylandclient5-dev. The files where previously generated
and removed before packaging because they where not stable, but now a part
of them have become stable so it's time to ship them.
Also make the package recommend qtwayland5-dev-tools which provides the
tools necessary to generate C++ interfaces form the XML definitions.
Thanks Andreas Cord-Landwehr for the bug report! (Closes: #893387).
2018-02-25 - Simon Quigley <tsimonq2@ubuntu.com>
qtwayland-opensource-src (5.9.4-0ubuntu1) bionic; urgency=medium
* New upstream release.
* Add dont-create-hidden-egl-surfaces.patch which fixes a crash in a Wayland
session when a QQuickWindow hides and then is destroyed.
2017-12-13 - Simon Quigley <tsimonq2@ubuntu.com>
qtwayland-opensource-src (5.9.3-0ubuntu1) bionic; urgency=medium
* New upstream release.
* Bump build dependencies to Qt 5.9.3.
* Update symbols from build logs.
2017-10-27 - Dmitry Shachnev <mitya57@debian.org>
qtwayland-opensource-src (5.9.2-3) unstable; urgency=medium
* Update for Qt binaries location change in qtbase 5.9.2+dfsg-3.
- Install qtwaylandscanner to the new location.
- Provide a compatibility symlink in the old location.
- Bump qtbase5-private-dev and qttools5-dev-tools build-dependencies.
* Upload to unstable.
2017-10-18 - Dmitry Shachnev <mitya57@debian.org>
qtwayland-opensource-src (5.9.2-2) experimental; urgency=medium
* Move qtwaylandscanner tool into its own qtwayland5-dev-tools package,
make that package Multi-Arch: foreign.
2017-10-16 - Dmitry Shachnev <mitya57@debian.org>
qtwayland-opensource-src (5.9.2-1) experimental; urgency=medium
* New upstream release.
* Bump Qt build-dependencies to 5.9.2.
* Use debhelper compat level 10 and dh_missing.
* Update symbols files from the current build log.
* Bump Standards-Version to 4.1.1, stop using deprecated Priority: extra.
2017-08-16 - Dmitry Shachnev <mitya57@debian.org>
qtwayland-opensource-src (5.9.1-2) unstable; urgency=medium
* Upload to unstable.
2017-07-07 - Dmitry Shachnev <mitya57@debian.org>
qtwayland-opensource-src (5.9.1-1) experimental; urgency=medium
* New upstream release.
* Bump Qt build-dependencies to 5.9.1.
* Bump Standards-Version to 4.0.0, no changes needed.
2017-06-09 - Dmitry Shachnev <mitya57@debian.org>
qtwayland-opensource-src (5.9.0-1) experimental; urgency=medium
* New upstream stable release.
* Do not install Qt5Gui_QWaylandXCompositeGlxPlatformIntegrationPlugin.cmake
on armel/armhf.
* Bump qtbase build-dependencies to 5.9.0 final.
* Add support for nodoc build profile.

See Also

Package Description
libqt5webchannel5-dev_5.9.5-0ubuntu1_i386.deb Web communication library for Qt - development files
libqt5webchannel5_5.9.5-0ubuntu1_i386.deb Web communication library for Qt
libqt5webengine-data_5.9.5+dfsg-0ubuntu2_all.deb Web content engine library for Qt - Data
libqt5webengine5_5.9.5+dfsg-0ubuntu2_i386.deb Web content engine library for Qt
libqt5webenginecore5_5.9.5+dfsg-0ubuntu2_i386.deb Web content engine library for Qt - Core
libqt5webenginewidgets5_5.9.5+dfsg-0ubuntu2_i386.deb Web content engine library for Qt - Widget
libqt5webkit5-dev_5.212.0~alpha2-7ubuntu1_i386.deb Web content engine library for Qt - development files
libqt5webkit5_5.212.0~alpha2-7ubuntu1_i386.deb Web content engine library for Qt
libqt5websockets5-dev_5.9.5-0ubuntu1_i386.deb Qt 5 Web Sockets module - development files
libqt5websockets5_5.9.5-0ubuntu1_i386.deb Qt 5 Web Sockets module
libqt5webview5-dev_5.9.5-0ubuntu1_i386.deb display web content in a QML application - Development Files
libqt5webview5_5.9.5-0ubuntu1_i386.deb display web content in a QML application - Library
libqt5x11extras5-dev_5.9.5-0ubuntu1_i386.deb Qt 5 X11 extras development files
libqt5x11extras5_5.9.5-0ubuntu1_i386.deb Qt 5 X11 extras
libqt5xdg-dev_3.1.0-5build2_i386.deb Development files for libqtxdg
Advertisement
Advertisement