libqt5keychain1_0.7.0-3_i386.deb


Advertisement

Description

libqt5keychain1 - Qt API to store passwords (QT5 version)

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libqt5keychain1
Package version 0.7.0
Package release 3
Package architecture i386
Package type deb
Installed size 158 B
Download size 43.54 KB
Official Mirror archive.ubuntu.com
It can use KWallet or GNOME Keyring, if one of them is available.
If none of them is available, qtkeychain will report an error or writes
with explicit request the password unencrypted at a file.
This is the Version built for QT5

Alternatives

Package Version Architecture Repository
libqt5keychain1_0.7.0-3_amd64.deb 0.7.0 amd64 Ubuntu Universe
libqt5keychain1 - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:3.0
libqt5core5a >= 5.6.0~beta
libqt5dbus5 >= 5.0.2
libstdc++6 >= 5

Replaces

Name Value
libqt5keychain0 -

Download

Type URL
Binary Package libqt5keychain1_0.7.0-3_i386.deb
Source Package qtkeychain

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libqt5keychain1 deb package:
    # sudo apt-get install libqt5keychain1

Files

Path
/usr/lib/i386-linux-gnu/libqt5keychain.so.0.7.0
/usr/lib/i386-linux-gnu/libqt5keychain.so.1
/usr/share/doc/libqt5keychain1/changelog.Debian.gz
/usr/share/doc/libqt5keychain1/copyright
/usr/share/qt5/translations/qtkeychain_de.qm
/usr/share/qt5/translations/qtkeychain_ro.qm

Changelog

2016-10-29 - Sandro Knauß <hefee@debian.org>
qtkeychain (0.7.0-3) unstable; urgency=medium
* Added Breaks and Replaces for Qt4 and Qt5 version.
Thanks to Alf Gaida (Closes: #842416)
2016-10-28 - Sandro Knauß <hefee@debian.org>
qtkeychain (0.7.0-2) unstable; urgency=medium
* Upload to unstable to start transition.
* Update my mail address to debian.org address
2016-10-22 - Sandro Knauß <hefee@debian.org>
qtkeychain (0.7.0-1) experimental; urgency=medium
* New upstream release
* Bump Standards-Version (no changes needed)
* Bump SONAME and packagename, because of ABI breakage.
* Securify uris to debian git.
2015-06-01 - Sandro Knauß <hefee@debian.org>
qtkeychain (0.5.0-1) unstable; urgency=medium
* New upstream release
* Updated d/watch file
* Updated d/copyright with current year
* Make buildable with GCC-5 (Closes: #778089)
* Bumped Standards-Version: No changes needed
2014-09-04 - Sandro Knauß <hefee@debian.org>
qtkeychain (0.4.0-1) unstable; urgency=medium
* New upstream release:
- Improved desktop environment detection at runtime (Closes: #755349)
* Replaced hardening-wrapper with dpkg-buildflags
* Bumped compat to 9 to have dpkg-buildflags available
* Removed private symbols from libs
2014-04-01 - Sandro Knauß <hefee@debian.org>
qtkeychain (0.3.0-2) unstable; urgency=medium
* Building lib for qt4 and qt5.
* Added packages libqt5keychain0 and qt5keychain-dev
* Added symbols for libqt5keychain0
2014-03-20 - Sandro Knauß <hefee@debian.org>
qtkeychain (0.3.0-1) unstable; urgency=medium
* New upstream release. (Closes: #735043)
* Added gnome-keyring|kwalletmanager as recommends
* Updated debian/libqtkeychain0.symbols
* Updated debian/copyright
* Bumped Standards-Version
2013-09-27 - Sandro Knauß <hefee@debian.org>
qtkeychain (0.1.0-2) unstable; urgency=low
* FTBFS on !linux: libraries left in /usr/lib (Closes: #710340)
* Added patch use_system_GNUInstallDirs.cmake
* use githubredir.debian.net for watch file
2013-05-13 - Sandro Knauß <hefee@debian.org>
qtkeychain (0.1.0-1) unstable; urgency=low
* Initial release (Closes: #699687)

See Also

Package Description
libqt5location5-plugins_5.9.5+dfsg-0ubuntu2_i386.deb Qt Location module - geolocation plugins
libqt5location5_5.9.5+dfsg-0ubuntu2_i386.deb Qt Location module
libqt5multimedia5-plugins_5.9.5-0ubuntu1_i386.deb Qt 5 Multimedia module plugins
libqt5multimedia5_5.9.5-0ubuntu1_i386.deb Qt 5 Multimedia module
libqt5multimediaquick-p5_5.9.5-0ubuntu1_i386.deb Qt 5 Multimedia Quick module
libqt5multimediawidgets5_5.9.5-0ubuntu1_i386.deb Qt 5 Multimedia Widgets module
libqt5nfc5_5.9.5-0ubuntu1_i386.deb Qt Connectivity NFC module
libqt5organizer5_5.0~git20140515~29475884-0ubuntu24~7_i386.deb Qt PIM module, Organizer library
libqt5pas-dev_2.6~beta-4_i386.deb Development files for Qt5Pas
libqt5pas1_2.6~beta-4_i386.deb Qt5 interface bindings for Pascal
libqt5positioning5-plugins_5.9.5+dfsg-0ubuntu2_i386.deb Qt Positioning module - position plugins
libqt5positioning5_5.9.5+dfsg-0ubuntu2_i386.deb Qt Positioning module
libqt5qevercloud3_3.0.3+ds-3_i386.deb Unofficial Evernote Cloud API library for Qt5
libqt5qml5_5.9.5-0ubuntu1_i386.deb Qt 5 QML module
libqt5quick5_5.9.5-0ubuntu1_i386.deb Qt 5 Quick library
Advertisement
Advertisement