libqt5designer5_5.9.5-0ubuntu1_i386.deb


Advertisement

Description

libqt5designer5 - Qt 5 designer module

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libqt5designer5
Package version 5.9.5
Package release 0ubuntu1
Package architecture i386
Package type deb
Installed size 6.04 KB
Download size 2.75 MB
Official Mirror archive.ubuntu.com
Qt is a cross-platform C++ application framework. Qt's primary feature
is its rich set of widgets that provide standard GUI functionality.
The QtDesigner module provides classes that allow you to create your own
custom widget plugins for Qt Designer, and classes that enable you to access
Qt Designer's components.

Alternatives

Package Version Architecture Repository
libqt5designer5_5.9.5-0ubuntu1_amd64.deb 5.9.5 amd64 Ubuntu Universe
libqt5designer5 - - -

Requires

Name Value
libc6 >= 2.4
libqt5core5a >= 5.9.0~beta
libqt5gui5 >= 5.7.0
libqt5widgets5 >= 5.7.0
libqt5xml5 >= 5.0.2
libstdc++6 >= 5
qtbase-abi-5-9-5 -

Download

Type URL
Binary Package libqt5designer5_5.9.5-0ubuntu1_i386.deb
Source Package qttools-opensource-src

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libqt5designer5 deb package:
    # sudo apt-get install libqt5designer5

Files

Path
/usr/lib/i386-linux-gnu/libQt5Designer.so.5
/usr/lib/i386-linux-gnu/libQt5Designer.so.5.9
/usr/lib/i386-linux-gnu/libQt5Designer.so.5.9.5
/usr/share/doc/libqt5designer5/changelog.Debian.gz
/usr/share/doc/libqt5designer5/copyright

Changelog

2018-04-14 - Dmitry Shachnev <mitya57@ubuntu.com>
qttools-opensource-src (5.9.5-0ubuntu1) bionic; urgency=medium
* New upstream release.
* Bump Qt build-dependencies to 5.9.5.
* Update Vcs fields for migration to salsa.debian.org.
2018-02-25 - Simon Quigley <tsimonq2@ubuntu.com>
qttools-opensource-src (5.9.4-0ubuntu1) bionic; urgency=medium
* New upstream release.
2018-01-19 - Dmitry Shachnev <mitya57@debian.org>
qttools-opensource-src (5.9.2-6) unstable; urgency=medium
* Update no_qwebview_archs: remove alpha and sh4, and add sparc64.
* Bump copyright years for The Qt Company in debian/copyright.
* Regenerate the internal assistant.qch during build (closes: #885484).
* Bump Standards-Version to 4.1.3, no changes needed.
2017-12-17 - Dmitry Shachnev <mitya57@debian.org>
qttools-opensource-src (5.9.2-5) unstable; urgency=medium
* Split Assistant into its own package, qt5-assistant (closes: #854123).
* Bump Standards-Version to 4.1.2, no changes needed.
* Fix Exec lines in desktop files to run the tools directly.
2017-11-30 - Simon Quigley <tsimonq2@ubuntu.com>
qttools-opensource-src (5.9.3-0ubuntu3) bionic; urgency=medium
* New upstream release.
* Update Standards-version to 4.1.2, no changes needed.
2017-12-03 - Dmitry Shachnev <mitya57@debian.org>
qttools-opensource-src (5.9.2-4) unstable; urgency=medium
[ Lisandro Damián Nicanor Pérez Meyer ]
* Do not override dh_auto_configure anymore.
Require debhelper >= 10.9.2~ (Closes: #880937).
[ Dmitry Shachnev ]
* Make qttools5-dev-tools depend on libqt5sql5-sqlite, it is needed by
qhelpgenerator and Qt Assistant.
2017-10-27 - Dmitry Shachnev <mitya57@debian.org>
qttools-opensource-src (5.9.2-3) unstable; urgency=medium
* Move Qt5LinguistTools*.cmake from qttools5-dev-tools to qttools5-dev.
* Re-enable qtwebkit support again.
* Upload to unstable.
2017-10-20 - Dmitry Shachnev <mitya57@debian.org>
qttools-opensource-src (5.9.2-2) experimental; urgency=medium
* Update for Qt binaries location change in qtbase 5.9.2+dfsg-3.
- Update .install files for qttools5-dev-tools and qdbus-qt5.
- Make these packages Multi-Arch: foreign.
- Provide compatibility symlinks for the old location.
- Bump qtbase5-dev build-dependency to 5.9.2+dfsg-3.
2017-10-18 - Dmitry Shachnev <mitya57@debian.org>
qttools-opensource-src (5.9.2-1) experimental; urgency=medium
* New upstream release.
* Temporarily disable webkit support.
* Bump Qt build-dependencies to 5.9.2.
* Update symbols files from buildds’ logs.
* Update debhelper compatibility level to 10.
* Bump Standards-Version to 4.1.1, stop using deprecated Priority: extra.
2017-08-16 - Dmitry Shachnev <mitya57@debian.org>
qttools-opensource-src (5.9.1-2) unstable; urgency=medium
* Update symbols files from the current build logs.
* Upload to unstable.
- Fixes build failure with GCC 7 (closes: #853633).

See Also

Package Description
libqt5designercomponents5_5.9.5-0ubuntu1_i386.deb Qt 5 Designer components module
libqt5glib-2.0-0_1.2.0-5_i386.deb C++ bindings library for GLib and GObject with a Qt-style API - Qt 5 build
libqt5gstreamer-1.0-0_1.2.0-5_i386.deb C++ bindings library for GStreamer with a Qt-style API - Qt 5 build
libqt5gstreamer-dev_1.2.0-5_i386.deb Development headers for QtGStreamer - Qt 5 build
libqt5gstreamerquick-1.0-0_1.2.0-5_i386.deb QtGStreamerQuick library - Qt 5 build
libqt5gstreamerui-1.0-0_1.2.0-5_i386.deb QtGStreamerUi library - Qt 5 build
libqt5gstreamerutils-1.0-0_1.2.0-5_i386.deb QtGStreamerUtils library - Qt 5 build
libqt5help5_5.9.5-0ubuntu1_i386.deb Qt 5 help module
libqt5keychain1_0.7.0-3_i386.deb Qt API to store passwords (QT5 version)
libqt5location5-plugins_5.9.5+dfsg-0ubuntu2_i386.deb Qt Location module - geolocation plugins
libqt5location5_5.9.5+dfsg-0ubuntu2_i386.deb Qt Location module
libqt5multimedia5-plugins_5.9.5-0ubuntu1_i386.deb Qt 5 Multimedia module plugins
libqt5multimedia5_5.9.5-0ubuntu1_i386.deb Qt 5 Multimedia module
libqt5multimediaquick-p5_5.9.5-0ubuntu1_i386.deb Qt 5 Multimedia Quick module
libqt5multimediawidgets5_5.9.5-0ubuntu1_i386.deb Qt 5 Multimedia Widgets module
Advertisement
Advertisement