libqt5contacts5_5.0~git20140515~29475884-0ubuntu24~7_i386.deb


Advertisement

Description

libqt5contacts5 - Qt PIM module, Contacts library

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libqt5contacts5
Package version 5.0~git20140515~29475884
Package release 0ubuntu24~7
Package architecture i386
Package type deb
Installed size 674 B
Download size 155.29 KB
Official Mirror archive.ubuntu.com
Qt is a cross-platform C++ application framework. Qt's primary feature
is its rich set of widgets that provide standard GUI functionality.
This package contains Qt PIM module's Contacts library.
WARNING: This module is not an official part of Qt 5, but instead a git
snapshot of an ongoing development. The package is very likely to
change in a binary incompatible way, and no guarantees are given.

Alternatives

Package Version Architecture Repository
libqt5contacts5_5.0~git20140515~29475884-0ubuntu24~7_amd64.deb 5.0~git20140515~29475884 amd64 Ubuntu Universe
libqt5contacts5 - - -

Requires

Name Value
libc6 >= 2.4
libqt5core5a >= 5.9.0~beta
libstdc++6 >= 5
qtbase-abi-5-9-5 -

Download

Type URL
Binary Package libqt5contacts5_5.0~git20140515~29475884-0ubuntu24~7_i386.deb
Source Package qtpim-opensource-src

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libqt5contacts5 deb package:
    # sudo apt-get install libqt5contacts5

Files

Path
/usr/lib/i386-linux-gnu/libQt5Contacts.so.5
/usr/lib/i386-linux-gnu/libQt5Contacts.so.5.0
/usr/lib/i386-linux-gnu/libQt5Contacts.so.5.0.0
/usr/lib/i386-linux-gnu/qt5/plugins/contacts/libqtcontacts_memory.so
/usr/share/doc/libqt5contacts5/changelog.Debian.gz
/usr/share/doc/libqt5contacts5/copyright

Changelog

2018-04-14 - Simon Quigley <tsimonq2@ubuntu.com>
qtpim-opensource-src (5.0~git20140515~29475884-0ubuntu24~7) bionic; urgency=medium
* No-change rebuild against qtbase-abi-5-9-5.
2018-02-27 - Simon Quigley <tsimonq2@ubuntu.com>
qtpim-opensource-src (5.0~git20140515~29475884-0ubuntu24~6) bionic; urgency=medium
* No-change rebuild against qtbase-abi-5-9-4.
2017-12-10 - Simon Quigley <tsimonq2@ubuntu.com>
qtpim-opensource-src (5.0~git20140515~29475884-0ubuntu24~5) bionic; urgency=medium
* No-change rebuild against qtdeclarative ABI bump.
2017-11-03 - Simon Quigley <tsimonq2@ubuntu.com>
qtpim-opensource-src (5.0~git20140515~29475884-0ubuntu24~4) bionic; urgency=medium
* No-change rebuild against qtbase5-private-dev.
2017-07-07 - Dmitry Shachnev <mitya57@ubuntu.com>
qtpim-opensource-src (5.0~git20140515~29475884-0ubuntu24~3) artful; urgency=medium
* Build against Qt 5.9.
* Export QT_LOGGING_RULES="default.debug=true" to unbreak the tests
(this is needed to override settings from our new qtlogging.ini file).
* Add upstream patch to fix tests failures with Qt 5.8+ (qt58_nullptr.patch).
* Add upstream patch to fix QVersitReader test (fix_versitreader_test.patch).
2016-09-14 - Timo Jyrinki <timo-jyrinki@ubuntu.com>
qtpim-opensource-src (5.0~git20140515~29475884-0ubuntu23~3) zesty; urgency=medium
* Build against Qt 5.7.
2016-04-22 - Timo Jyrinki <timo-jyrinki@ubuntu.com>
qtpim-opensource-src (5.0~git20140515~29475884-0ubuntu22~5) yakkety; urgency=medium
* Build against Qt 5.6.
* debian/patches/Install-QtOrganizer-example-applications.patch:
- Add targets to install successfully.
2016-04-04 - Timo Jyrinki <timo-jyrinki@ubuntu.com>
qtpim-opensource-src (5.0~git20140515~29475884-0ubuntu21) xenial; urgency=medium
* debian/patches/Does-not-convert-datetime-properties-to-UTC.patch:
- Avoid converting datetime values to UTC. Upstream commit at 
https://codereview.qt-project.org/#/c/154461/
2016-03-17 - Timo Jyrinki <timo-jyrinki@ubuntu.com>
qtpim-opensource-src (5.0~git20140515~29475884-0ubuntu20) xenial; urgency=medium
* debian/patches/fix_recurrence_events.patch:
- Fix issues related to repeating events (LP: #1546466) (LP: #1500192)
(LP: #1455864) (LP: #1535207) (LP: #1471588) (LP: #1364653)
(LP: #1473685) (LP: #1447930)
2015-12-07 - Timo Jyrinki <timo-jyrinki@ubuntu.com>
qtpim-opensource-src (5.0~git20140515~29475884-0ubuntu18) xenial; urgency=medium
* debian/patches/QtVersit-Fix-crash-on-access-to-static-variable-in-m.patch:
- Fix a crash in versit (LP: #1521331)

See Also

Package Description
libqt5designer5_5.9.5-0ubuntu1_i386.deb Qt 5 designer module
libqt5designercomponents5_5.9.5-0ubuntu1_i386.deb Qt 5 Designer components module
libqt5glib-2.0-0_1.2.0-5_i386.deb C++ bindings library for GLib and GObject with a Qt-style API - Qt 5 build
libqt5gstreamer-1.0-0_1.2.0-5_i386.deb C++ bindings library for GStreamer with a Qt-style API - Qt 5 build
libqt5gstreamer-dev_1.2.0-5_i386.deb Development headers for QtGStreamer - Qt 5 build
libqt5gstreamerquick-1.0-0_1.2.0-5_i386.deb QtGStreamerQuick library - Qt 5 build
libqt5gstreamerui-1.0-0_1.2.0-5_i386.deb QtGStreamerUi library - Qt 5 build
libqt5gstreamerutils-1.0-0_1.2.0-5_i386.deb QtGStreamerUtils library - Qt 5 build
libqt5help5_5.9.5-0ubuntu1_i386.deb Qt 5 help module
libqt5keychain1_0.7.0-3_i386.deb Qt API to store passwords (QT5 version)
libqt5location5-plugins_5.9.5+dfsg-0ubuntu2_i386.deb Qt Location module - geolocation plugins
libqt5location5_5.9.5+dfsg-0ubuntu2_i386.deb Qt Location module
libqt5multimedia5-plugins_5.9.5-0ubuntu1_i386.deb Qt 5 Multimedia module plugins
libqt5multimedia5_5.9.5-0ubuntu1_i386.deb Qt 5 Multimedia module
libqt5multimediaquick-p5_5.9.5-0ubuntu1_i386.deb Qt 5 Multimedia Quick module
Advertisement
Advertisement