libqt4-declarative-particles_4.8.7+dfsg-7ubuntu1_i386.deb


Advertisement

Description

libqt4-declarative-particles - Qt 4 particles QML plugin

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libqt4-declarative-particles
Package version 4.8.7+dfsg
Package release 7ubuntu1
Package architecture i386
Package type deb
Installed size 205 B
Download size 27.24 KB
Official Mirror archive.ubuntu.com
Qt is a cross-platform C++ application framework. Qt's primary feature
is its rich set of widgets that provide standard GUI functionality.
This package contains the particles QML plugin for QtDeclarative.

Alternatives

Package Version Architecture Repository
libqt4-declarative-particles_4.8.7+dfsg-7ubuntu1_amd64.deb 4.8.7+dfsg amd64 Ubuntu Universe
libqt4-declarative-particles - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:3.0
libqt4-declarative = 4:4.8.7+dfsg-7ubuntu1
libqtcore4 = 4:4.8.7+dfsg-7ubuntu1
libqtgui4 = 4:4.8.7+dfsg-7ubuntu1
libstdc++6 >= 4.1.1

Download

Type URL
Binary Package libqt4-declarative-particles_4.8.7+dfsg-7ubuntu1_i386.deb
Source Package qt4-x11

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libqt4-declarative-particles deb package:
    # sudo apt-get install libqt4-declarative-particles

Files

Path
/usr/lib/i386-linux-gnu/qt4/imports/Qt/labs/particles/libqmlparticlesplugin.so
/usr/lib/i386-linux-gnu/qt4/imports/Qt/labs/particles/qmldir
/usr/share/doc/libqt4-declarative-particles/LGPL_EXCEPTION.txt
/usr/share/doc/libqt4-declarative-particles/changelog.Debian.gz
/usr/share/doc/libqt4-declarative-particles/copyright

Changelog

2016-05-23 - Timo Jyrinki <timo-jyrinki@ubuntu.com>
qt4-x11 (4:4.8.7+dfsg-7ubuntu1) yakkety; urgency=medium
* Merge with Debian since qtchooser has versioned Breaks. (LP: #1584654)
2016-05-22 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
qt4-x11 (4:4.8.7+dfsg-7) unstable; urgency=medium
[ Dmitry Shachnev ]
* Move qtchooser configuration files (except the qt-default one) from
libqtcore4 to qtchooser itself.
* Bump all dependencies on qtchooser to 55-gc9562a1-1.
[ Pino Toscano ]
* Drop menu files, since we ship already .desktop file for assistant,
designer, linguist, and qtconfig.
[ Lisandro Damián Nicanor Pérez Meyer ]
* Apply Fedora's qt-everywhere-opensource-src-4.8.7-gcc6.patch to solve two
issues while building with GCC6.
* Apply Better-handling-of-invalid-font-tables.patch, which is a backport
from Qt 5 meant to improve the handling of invalid font tables.
* Set std=gnu++98 to workaround class std::auto_ptr deprecation in GCC6, also
hinted by Fedora's packaging.
2016-02-10 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
qt4-x11 (4:4.8.7+dfsg-6) unstable; urgency=medium
* Add Eduard Sanou's backport patch from qttools5 to make qch files
reproducible by replacing the current time by a fixed date
(Closes: #814280). Thanks Eduard!
* Update symbols files with buildds' logs.
2016-05-23 - Timo Jyrinki <timo-jyrinki@ubuntu.com>
qt4-x11 (4:4.8.7+dfsg-5ubuntu5) yakkety; urgency=medium
[ Timo Jyrinki ]
* Merge changes from Debian to fix qtchooser breakage. (LP: #1584654)
[ Dmitry Shachnev ]
* Move qtchooser configuration files (except the qt-default one) from
libqtcore4 to qtchooser itself.
* Bump all dependencies on qtchooser to 55-gc9562a1-1.
2016-04-26 - Dimitri John Ledkov <xnox@ubuntu.com>
qt4-x11 (4:4.8.7+dfsg-5ubuntu4) yakkety; urgency=medium
* Add one more macro to qt4-x11 moc to fix failing to parse BOOST_JOIN.
2016-04-23 - Matthias Klose <doko@ubuntu.com>
qt4-x11 (4:4.8.7+dfsg-5ubuntu3) yakkety; urgency=medium
* No-change rebuild for libpng soname change.
2016-04-05 - Robie Basak <robie.basak@ubuntu.com>
qt4-x11 (4:4.8.7+dfsg-5ubuntu2) xenial; urgency=medium
* Rebuild against libmysqlclient20.
2016-01-07 - Matthias Klose <doko@ubuntu.com>
qt4-x11 (4:4.8.7+dfsg-5ubuntu1) xenial; urgency=medium
* Merge with Debian; remaining changes:
- Pass list-missing to dh_install instead of fail-missing, since we don't
install the QtWebkit headers
- Make sure libqt4-opengl-dev depends on gles libs for armel and armhf
- Do not package ibase/firebird and sqlite2 package
+ remove from debian/control
+ libqt4-sql doesn't recommend libqt4-sql-ibase and libqt4-sql-sqlite2
- Also exclude webkit examples from dh_shlibdeps
- Do not build libqt4-phonon, disable in debian/control
- Add debian/Trolltech.conf and install it in libqtcore4.install
- Build with -no-neon on armel and armhf
- Build with -no-javascript-jit on arm64
- Add patches:
+ kubuntu_10_ibus_input_method.diff
+ kubuntu_12_fix_stack_protector.diff
+ kubuntu_28_xi2.1.patch
+ kubuntu_30_translucent_drag_pixmap.diff
+ kubuntu_37_cups_settings.diff
+ kubuntu_39_fix_medium_font.diff
+ kubuntu_40_disable_neon.patch
+ kubuntu_43_no_meego_helper.patch
+ kubuntu_93_disable_overlay_scrollbars.diff
+ kubuntu_94_xinput_valuators_fix.diff
+ kubuntu_95_qt_disable_bounce.diff
+ kubuntu_97_a11y_qt_and_qml_backport.diff
+ kubuntu_98_a11y_fix_crash.diff
+ kubuntu_glib-honor-ExcludeSocketNotifiers-flag.diff
+ kubuntu_qclipboard_delay.diff
+ kubuntu_qclipboard_fix_recursive.diff
- Drop powerpc_designer_gstabs.diff, it breaks powerpc
* Update symbols files.

See Also

Package Description
libqt4-declarative-shaders_4.8.7+dfsg-7ubuntu1_i386.deb Qt 4 shaders QML plugin
libqt4-declarative_4.8.7+dfsg-7ubuntu1_i386.deb Qt 4 Declarative module
libqt4-designer_4.8.7+dfsg-7ubuntu1_i386.deb Qt 4 designer module
libqt4-dev-bin_4.8.7+dfsg-7ubuntu1_i386.deb Qt 4 development programs
libqt4-dev_4.8.7+dfsg-7ubuntu1_i386.deb Qt 4 development files
libqt4-help_4.8.7+dfsg-7ubuntu1_i386.deb Qt 4 help module
libqt4-network_4.8.7+dfsg-7ubuntu1_i386.deb Qt 4 network module
libqt4-opengl-dev_4.8.7+dfsg-7ubuntu1_i386.deb Qt 4 OpenGL library development files
libqt4-opengl_4.8.7+dfsg-7ubuntu1_i386.deb Qt 4 OpenGL module
libqt4-qt3support_4.8.7+dfsg-7ubuntu1_i386.deb Qt 3 compatibility library for Qt 4
libqt4-script_4.8.7+dfsg-7ubuntu1_i386.deb Qt 4 script module
libqt4-scripttools_4.8.7+dfsg-7ubuntu1_i386.deb Qt 4 script tools module
libqt4-sql-mysql_4.8.7+dfsg-7ubuntu1_i386.deb Qt 4 MySQL database driver
libqt4-sql-odbc_4.8.7+dfsg-7ubuntu1_i386.deb Qt 4 ODBC database driver
libqt4-sql-psql_4.8.7+dfsg-7ubuntu1_i386.deb Qt 4 PostgreSQL database driver
Advertisement
Advertisement