libqscintilla2-qt5-dev_2.10.2+dfsg-4_i386.deb


Advertisement

Description

libqscintilla2-qt5-dev - Scintilla source code editing widget for Qt5, development files

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libqscintilla2-qt5-dev
Package version 2.10.2+dfsg
Package release 4
Package architecture i386
Package type deb
Installed size 500 B
Download size 57.26 KB
Official Mirror archive.ubuntu.com
QScintilla is a text editor for Qt5 with features especially useful when
writing and debugging source code. These include support for syntax
styling, error indicators, code completion, call tips and margins.
This package contains development headers needed when developing
C++ applications that use QScintilla 2 and Qt 5.

Alternatives

Package Version Architecture Repository
libqscintilla2-qt5-dev_2.10.2+dfsg-4_amd64.deb 2.10.2+dfsg amd64 Ubuntu Universe
libqscintilla2-qt5-dev - - -

Requires

Name Value
libqscintilla2-qt5-13 >= 2.10.2+dfsg
libqscintilla2-qt5-13 << 2.10.2+dfsg+1~
qtbase5-dev -

Provides

Name Value
libqt5scintilla2-dev -

Replaces

Name Value
libqt5scintilla2-12v5 << 2.9.1+dfsg-3~
lilbqt5scintilla-dev << 2.10

Download

Type URL
Binary Package libqscintilla2-qt5-dev_2.10.2+dfsg-4_i386.deb
Source Package qscintilla2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libqscintilla2-qt5-dev deb package:
    # sudo apt-get install libqscintilla2-qt5-dev

Files

Path
/usr/include/i386-linux-gnu/qt5/Qsci/qsciabstractapis.h
/usr/include/i386-linux-gnu/qt5/Qsci/qsciapis.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscicommand.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscicommandset.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscidocument.h
/usr/include/i386-linux-gnu/qt5/Qsci/qsciglobal.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexer.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexeravs.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexerbash.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexerbatch.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexercmake.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexercoffeescript.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexercpp.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexercsharp.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexercss.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexercustom.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexerd.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexerdiff.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexerfortran.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexerfortran77.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexerhtml.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexeridl.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexerjava.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexerjavascript.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexerjson.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexerlua.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexermakefile.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexermarkdown.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexermatlab.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexeroctave.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexerpascal.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexerperl.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexerpo.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexerpostscript.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexerpov.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexerproperties.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexerpython.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexerruby.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexerspice.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexersql.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexertcl.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexertex.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexerverilog.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexervhdl.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexerxml.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscilexeryaml.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscimacro.h
/usr/include/i386-linux-gnu/qt5/Qsci/qsciprinter.h
/usr/include/i386-linux-gnu/qt5/Qsci/qsciscintilla.h
/usr/include/i386-linux-gnu/qt5/Qsci/qsciscintillabase.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscistyle.h
/usr/include/i386-linux-gnu/qt5/Qsci/qscistyledtext.h
/usr/lib/libqscintilla2_qt5.so
/usr/lib/i386-linux-gnu/qt5/mkspecs/features/qscintilla2.prf
/usr/share/doc/libqscintilla2-qt5-dev/changelog.Debian.gz
/usr/share/doc/libqscintilla2-qt5-dev/copyright

Changelog

2018-01-02 - Scott Kitterman <scott@kitterman.com>
qscintilla2 (2.10.2+dfsg-4) unstable; urgency=medium
* Upload to unstable
* Bump standards-version to 4.1.3 without further change
2017-12-22 - Scott Kitterman <scott@kitterman.com>
qscintilla2 (2.10.2+dfsg-3) experimental; urgency=medium
* Update symbols files from build logs
2017-12-18 - Scott Kitterman <scott@kitterman.com>
qscintilla2 (2.10.2+dfsg-2) experimental; urgency=medium
* Mark l10n packages as Section: localization to match archive overrides
* Update symbols files from build logs
2017-12-15 - Scott Kitterman <scott@kitterman.com>
qscintilla2 (2.10.2+dfsg-1) experimental; urgency=medium
* New upstream release
- Drop patches used to provide a unique library name per Qt version,
upstream supports now
- Rename binary packages to match upstream library naming scheme
- Bump minimum python/python3-sip-dev requirement to (>= 4.19)
- Update debian/copyright
* Add 0007-Fix-sip_file-path-detection.patch to fix infinite loop in Python/
configure.py
* Add Suggests: libqscintilla2-doc to library and designer plugin packages
* Bump standards-version to 4.1.2 without further change
* Update -dbg package priorities to match archive
2017-09-18 - Dmitry Shachnev <mitya57@debian.org>
qscintilla2 (2.9.3+dfsg-5) unstable; urgency=medium
* Team upload.
[ Scott Kitterman ]
* Refresh patches after git-dpm to gbp pq conversion
[ Michael Hudson-Doyle ]
* Add python3-all to d/tests/control to ensure all supported versions of
Python 3 are actually installed. (Closes: #864696)
[ Dmitry Shachnev ]
* Update symbols files for GCC 7 and Qt 5.9. (Closes: #853628)
2016-11-14 - Scott Kitterman <scott@kitterman.com>
qscintilla2 (2.9.3+dfsg-4) unstable; urgency=medium
[ Helmut Grohne ]
* Switch libqscintilla2-dev to Architecture: any (Closes: #842590)
[ Scott Kitterman ]
* Update symbols file for Qt5 5.7.1 transition (Closes: #844225)
2016-08-12 - Scott Kitterman <scott@kitterman.com>
qscintilla2 (2.9.3+dfsg-3) unstable; urgency=medium
* Update symbols from build logs again
2016-08-12 - Scott Kitterman <scott@kitterman.com>
qscintilla2 (2.9.3+dfsg-2) unstable; urgency=medium
* Upload to unstable
* Update symbols files from build logs (Closes: #811984)
2016-08-04 - Scott Kitterman <scott@kitterman.com>
qscintilla2 (2.9.3+dfsg-1) experimental; urgency=medium
* New upstream release
* Update debian/copyright
* Update symbols from local build log for new upstream and gcc-6
transition
2016-06-30 - Scott Kitterman <scott@kitterman.com>
qscintilla2 (2.9.2+dfsg-3) unstable; urgency=medium
* Update symbols files from build logs for sparc64 (Closes: #806591)
* Clean up debian/rules to remove obsolete shell leavings

See Also

Package Description
libqscintilla2-qt5-l10n_2.10.2+dfsg-4_all.deb Scintilla source code editing widget for Qt5, translation files
libqsopt-ex-dev_2.5.10.3-1build1_i386.deb Exact linear programming solver -- development files
libqsopt-ex2_2.5.10.3-1build1_i386.deb Exact linear programming solver -- shared library
libqt4-dbus_4.8.7+dfsg-7ubuntu1_i386.deb Qt 4 D-Bus module
libqt4-declarative-folderlistmodel_4.8.7+dfsg-7ubuntu1_i386.deb Qt 4 folderlistmodel QML plugin
libqt4-declarative-gestures_4.8.7+dfsg-7ubuntu1_i386.deb Qt 4 gestures QML plugin
libqt4-declarative-particles_4.8.7+dfsg-7ubuntu1_i386.deb Qt 4 particles QML plugin
libqt4-declarative-shaders_4.8.7+dfsg-7ubuntu1_i386.deb Qt 4 shaders QML plugin
libqt4-declarative_4.8.7+dfsg-7ubuntu1_i386.deb Qt 4 Declarative module
libqt4-designer_4.8.7+dfsg-7ubuntu1_i386.deb Qt 4 designer module
libqt4-dev-bin_4.8.7+dfsg-7ubuntu1_i386.deb Qt 4 development programs
libqt4-dev_4.8.7+dfsg-7ubuntu1_i386.deb Qt 4 development files
libqt4-help_4.8.7+dfsg-7ubuntu1_i386.deb Qt 4 help module
libqt4-network_4.8.7+dfsg-7ubuntu1_i386.deb Qt 4 network module
libqt4-opengl-dev_4.8.7+dfsg-7ubuntu1_i386.deb Qt 4 OpenGL library development files
Advertisement
Advertisement