libqmi-utils_1.18.0-3ubuntu1_i386.deb


Advertisement

Description

libqmi-utils - Utilities to use the QMI protocol from the command line

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libqmi-utils
Package version 1.18.0
Package release 3ubuntu1
Package architecture i386
Package type deb
Installed size 519 B
Download size 131.96 KB
Official Mirror archive.ubuntu.com
This package contains the utilities that make it easier to use QMI
functionality from the command line.

Alternatives

Package Version Architecture Repository
libqmi-utils_1.18.0-3ubuntu1_amd64.deb 1.18.0 amd64 Ubuntu Universe
libqmi-utils - - -

Requires

Name Value
libc6 >= 2.15
libglib2.0-0 >= 2.37.3
libgudev-1.0-0 >= 147
libmbim-glib4 >= 1.10.0
libmbim-proxy -
libqmi-glib5 >= 1.18.0
libqmi-proxy -

Download

Type URL
Binary Package libqmi-utils_1.18.0-3ubuntu1_i386.deb
Source Package libqmi

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libqmi-utils deb package:
    # sudo apt-get install libqmi-utils

Files

Path
/usr/bin/qmi-firmware-update
/usr/bin/qmi-network
/usr/bin/qmicli
/usr/share/bash-completion/completions/qmicli
/usr/share/doc/libqmi-utils/changelog.Debian.gz
/usr/share/doc/libqmi-utils/copyright
/usr/share/man/man1/qmi-firmware-update.1.gz
/usr/share/man/man1/qmi-network.1.gz
/usr/share/man/man1/qmicli.1.gz

Changelog

2018-04-24 - Iain Lane <iain@orangesquash.org.uk>
libqmi (1.18.0-3ubuntu1) bionic; urgency=medium
* Pass --enable-more-warnings so we build without -Werror, which fixes the
current FTBFS and mitigates against future ones.
2017-10-21 - Michael Biebl <biebl@debian.org>
libqmi (1.18.0-3) unstable; urgency=medium
* Remove myself from Uploaders.
2017-07-06 - Michael Biebl <biebl@debian.org>
libqmi (1.18.0-2) unstable; urgency=medium
* Drop useless g_file_test() call.
Fixes FTBFS with glib2.0 >= 2.52.1 which changed the behaviour of
g_file_test(). (Closes: #865579)
* Bump Standards-Version to 4.0.0
2017-06-17 - Michael Biebl <biebl@debian.org>
libqmi (1.18.0-1) unstable; urgency=medium
* New upstream version 1.18.0
* Bump Build-Depends on libglib2.0-dev to (>= 2.36)
* Update libqmi-glib5 symbols file
* Enable new qmi-firmware-update tool
* Enable GUdev support for qmi-firmware-update
2016-11-08 - Michael Biebl <biebl@debian.org>
libqmi (1.16.2-1) unstable; urgency=medium
* New upstream release.
* Bump debhelper compat level to 10.
* Drop Build-Depends on intltool.
2016-07-08 - Michael Biebl <biebl@debian.org>
libqmi (1.16.0-1) unstable; urgency=medium
* New upstream release.
* Enable QMi-over-MBIM support, which is required by new Sierra devices to
work in MBIM mode.
* Update symbols file.
* Only install the upstream documentation files once.
2016-04-15 - Michael Biebl <biebl@debian.org>
libqmi (1.14.2-1) unstable; urgency=medium
* New upstream release.
* Bump Standards-Version to 3.9.8.
2016-03-22 - Michael Biebl <biebl@debian.org>
libqmi (1.14.0-2) unstable; urgency=medium
* Update debian/copyright.
2016-03-19 - Michael Biebl <biebl@debian.org>
libqmi (1.14.0-1) unstable; urgency=medium
* New upstream release.
* Use https:// for upstream homepage.
* Rename libqmi-glib1 → libqmi-glib5 for the upstream SONAME bump.
* Update symbols files accordingly.
* Run wrap-and-sort -at.
* Bump Standards-Version to 3.9.7.
* Drop libqmi-glib5-dbg now that we have automatic dbgsym packages.
* Ensure proper upgrade from libqmi-glib5-dbg to new dbgsym packages by
using dh_strip --dbgsym-migration. Bump Build-Depends on debhelper
accordingly.
* Drop debian/qmicli.1 since we use the upstream man page.
* Install bash-completion file for qmicli.
* Drop obsolete debian/README.source.
* Rename libqmi-glib.doc-base → libqmi-glib-doc.doc-base so the doc-base
support file is actually installed.
2015-05-07 - Michael Biebl <biebl@debian.org>
libqmi (1.12.6-1) unstable; urgency=medium
* Upload to unstable.
* New upstream release.
* Add myself to Uploaders.

See Also

Package Description
libqmobipocket-dev_17.12.3-0ubuntu1_i386.deb library for reading Mobipocket documents
libqmobipocket2_17.12.3-0ubuntu1_i386.deb library for reading Mobipocket documents
libqoauth-dev_2.0.1~1-3_i386.deb Qt5-based OAuth implementation development headers
libqoauth2_2.0.1~1-3_i386.deb Qt5-based client implementation of the OAuth authorization scheme
libqofono-dev_0.90+16.10.20160901-0ubuntu1_i386.deb Qt library for Ofono
libqofono-qt5-0_0.90+16.10.20160901-0ubuntu1_i386.deb Qt library for Ofono
libqpid-proton-cpp8-dev-doc_0.14.0-5.1ubuntu1_all.deb C++ developer documentation for Qpid Proton
libqpid-proton-cpp8-dev_0.14.0-5.1ubuntu1_i386.deb C++ Development libraries for writing messaging apps with Qpid Proton
libqpid-proton-cpp8_0.14.0-5.1ubuntu1_i386.deb C++ libraries for Qpid Proton
libqpid-proton8-dev-doc_0.14.0-5.1ubuntu1_all.deb Developer documentation for Qpid Proton
libqpid-proton8-dev-examples_0.14.0-5.1ubuntu1_all.deb Example applications for writign messaging apps with Qpid Proton
libqpid-proton8-dev_0.14.0-5.1ubuntu1_i386.deb C Development libraries for writing messaging apps with Qpid Proton
libqpid-proton8_0.14.0-5.1ubuntu1_i386.deb C libraries for Qpid Proton
libqpx-dev_0.7.2-4.1_i386.deb CD/DVD quality checker (development files)
libqpx0_0.7.2-4.1_i386.deb CD/DVD quality checker (shared libraries)
Advertisement
Advertisement