libqm-dsp-dev_1.7.1-4_i386.deb


Advertisement

Description

libqm-dsp-dev - Development files (headers) for libqm-dsp library

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libqm-dsp-dev
Package version 1.7.1
Package release 4
Package architecture i386
Package type deb
Installed size 164 B
Download size 27.39 KB
Official Mirror archive.ubuntu.com
This is a C++ library for DSP and Music Informatics purposes,
written at the Queen Mary University.
Among other things, it provides functions for audio analysis.
This package contains the headers used to build applications
that use libqm-dsp.

Alternatives

Package Version Architecture Repository
libqm-dsp-dev_1.7.1-4_amd64.deb 1.7.1 amd64 Ubuntu Universe
libqm-dsp-dev - - -

Requires

Name Value
libqm-dsp0 = 1.7.1-4

Download

Type URL
Binary Package libqm-dsp-dev_1.7.1-4_i386.deb
Source Package qm-dsp

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libqm-dsp-dev deb package:
    # sudo apt-get install libqm-dsp-dev

Files

Path
/usr/include/qm-dsp/base/KaiserWindow.h
/usr/include/qm-dsp/base/Pitch.h
/usr/include/qm-dsp/base/SincWindow.h
/usr/include/qm-dsp/base/Window.h
/usr/include/qm-dsp/dsp/chromagram/Chromagram.h
/usr/include/qm-dsp/dsp/chromagram/ConstantQ.h
/usr/include/qm-dsp/dsp/keydetection/GetKeyMode.h
/usr/include/qm-dsp/dsp/mfcc/MFCC.h
/usr/include/qm-dsp/dsp/onsets/DetectionFunction.h
/usr/include/qm-dsp/dsp/onsets/PeakPicking.h
/usr/include/qm-dsp/dsp/phasevocoder/PhaseVocoder.h
/usr/include/qm-dsp/dsp/rateconversion/Decimator.h
/usr/include/qm-dsp/dsp/rateconversion/DecimatorB.h
/usr/include/qm-dsp/dsp/rateconversion/Resampler.h
/usr/include/qm-dsp/dsp/rhythm/BeatSpectrum.h
/usr/include/qm-dsp/dsp/segmentation/ClusterMeltSegmenter.h
/usr/include/qm-dsp/dsp/segmentation/Segmenter.h
/usr/include/qm-dsp/dsp/segmentation/cluster_melt.h
/usr/include/qm-dsp/dsp/segmentation/cluster_segmenter.h
/usr/include/qm-dsp/dsp/segmentation/segment.h
/usr/include/qm-dsp/dsp/signalconditioning/DFProcess.h
/usr/include/qm-dsp/dsp/signalconditioning/FiltFilt.h
/usr/include/qm-dsp/dsp/signalconditioning/Filter.h
/usr/include/qm-dsp/dsp/signalconditioning/Framer.h
/usr/include/qm-dsp/dsp/tempotracking/DownBeat.h
/usr/include/qm-dsp/dsp/tempotracking/TempoTrack.h
/usr/include/qm-dsp/dsp/tempotracking/TempoTrackV2.h
/usr/include/qm-dsp/dsp/tonal/ChangeDetectionFunction.h
/usr/include/qm-dsp/dsp/tonal/TCSgram.h
/usr/include/qm-dsp/dsp/tonal/TonalEstimator.h
/usr/include/qm-dsp/dsp/transforms/FFT.h
/usr/include/qm-dsp/dsp/wavelet/Wavelet.h
/usr/include/qm-dsp/hmm/hmm.h
/usr/include/qm-dsp/maths/Correlation.h
/usr/include/qm-dsp/maths/CosineDistance.h
/usr/include/qm-dsp/maths/KLDivergence.h
/usr/include/qm-dsp/maths/MathAliases.h
/usr/include/qm-dsp/maths/MathUtilities.h
/usr/include/qm-dsp/maths/MedianFilter.h
/usr/include/qm-dsp/maths/Polyfit.h
/usr/include/qm-dsp/maths/nan-inf.h
/usr/include/qm-dsp/maths/pca/pca.h
/usr/include/qm-dsp/thread/AsynchronousTask.h
/usr/include/qm-dsp/thread/BlockAllocator.h
/usr/include/qm-dsp/thread/Thread.h
/usr/lib/i386-linux-gnu/libqm-dsp.so
/usr/share/doc/libqm-dsp-dev/changelog.Debian.gz
/usr/share/doc/libqm-dsp-dev/copyright

Changelog

2017-09-28 - IOhannes m zmölnig (Debian/GNU) <umlaeute@debian.org>
qm-dsp (1.7.1-4) unstable; urgency=medium
* Remove fix_includes patch (Closes: #877055)
* Build-Conflict on libblas-dev/libclapack-dev
* Modernize Vcs-Browser stanza
* Bump standards version to 4.1.0
2017-08-15 - Jaromír Mikeš <mira.mikes@seznam.cz>
qm-dsp (1.7.1-3) unstable; urgency=medium
* Introduce postclone.sh script to ignore .pc/ dir.
* Bump Standards.
* Update copyright.
* Fix dh version.
* Avoid useless linking.
* Fix FTCBFS. (Closes: #872249)
2016-12-15 - IOhannes m zmölnig (Debian/GNU) <umlaeute@debian.org>
qm-dsp (1.7.1-2) unstable; urgency=medium
* B-D on pkg-config &  libatlas-base-dev
* Link with g++
* Use shlibs:Depends for library-dependencies
2016-12-15 - IOhannes m zmölnig (Debian/GNU) <umlaeute@debian.org>
qm-dsp (1.7.1-1) unstable; urgency=medium
[ Jaromír Mikeš ]
* Initial release (Closes: #847169)

See Also

Package Description
libqm-dsp0_1.7.1-4_i386.deb C++ library for audio signals analysis
libqmi-utils_1.18.0-3ubuntu1_i386.deb Utilities to use the QMI protocol from the command line
libqmobipocket-dev_17.12.3-0ubuntu1_i386.deb library for reading Mobipocket documents
libqmobipocket2_17.12.3-0ubuntu1_i386.deb library for reading Mobipocket documents
libqoauth-dev_2.0.1~1-3_i386.deb Qt5-based OAuth implementation development headers
libqoauth2_2.0.1~1-3_i386.deb Qt5-based client implementation of the OAuth authorization scheme
libqofono-dev_0.90+16.10.20160901-0ubuntu1_i386.deb Qt library for Ofono
libqofono-qt5-0_0.90+16.10.20160901-0ubuntu1_i386.deb Qt library for Ofono
libqpid-proton-cpp8-dev-doc_0.14.0-5.1ubuntu1_all.deb C++ developer documentation for Qpid Proton
libqpid-proton-cpp8-dev_0.14.0-5.1ubuntu1_i386.deb C++ Development libraries for writing messaging apps with Qpid Proton
libqpid-proton-cpp8_0.14.0-5.1ubuntu1_i386.deb C++ libraries for Qpid Proton
libqpid-proton8-dev-doc_0.14.0-5.1ubuntu1_all.deb Developer documentation for Qpid Proton
libqpid-proton8-dev-examples_0.14.0-5.1ubuntu1_all.deb Example applications for writign messaging apps with Qpid Proton
libqpid-proton8-dev_0.14.0-5.1ubuntu1_i386.deb C Development libraries for writing messaging apps with Qpid Proton
libqpid-proton8_0.14.0-5.1ubuntu1_i386.deb C libraries for Qpid Proton
Advertisement
Advertisement