libqjson-dev_0.8.1-3_i386.deb


Advertisement

Description

libqjson-dev - Qt-based library that maps JSON data to QVariant objects - development files

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libqjson-dev
Package version 0.8.1
Package release 3
Package architecture i386
Package type deb
Installed size 79 B
Download size 8.01 KB
Official Mirror archive.ubuntu.com
JSON (JavaScript Object Notation) is a lightweight data-interchange format.
It can represent integers, real numbers, strings, an ordered sequence of
values, and a collection of name/value pairs.
QJson is a Qt-based library that maps JSON data to QVariant objects: JSON
arrays will be mapped to QVariantList instances, while JSON objects will be
mapped to QVariantMap.
These are the development files.

Alternatives

Package Version Architecture Repository
libqjson-dev_0.8.1-3_amd64.deb 0.8.1 amd64 Ubuntu Universe
libqjson-dev - - -

Requires

Name Value
libqjson0 = 0.8.1-3

Download

Type URL
Binary Package libqjson-dev_0.8.1-3_i386.deb
Source Package qjson

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libqjson-dev deb package:
    # sudo apt-get install libqjson-dev

Files

Path
/usr/include/qjson/parser.h
/usr/include/qjson/parserrunnable.h
/usr/include/qjson/qjson_export.h
/usr/include/qjson/qobjecthelper.h
/usr/include/qjson/serializer.h
/usr/include/qjson/serializerrunnable.h
/usr/lib/i386-linux-gnu/libqjson.so
/usr/lib/i386-linux-gnu/cmake/qjson/QJSONConfig.cmake
/usr/lib/i386-linux-gnu/cmake/qjson/QJSONConfigVersion.cmake
/usr/lib/i386-linux-gnu/cmake/qjson/QJSONTargets-relwithdebinfo.cmake
/usr/lib/i386-linux-gnu/cmake/qjson/QJSONTargets.cmake
/usr/lib/i386-linux-gnu/pkgconfig/QJson.pc
/usr/share/doc/libqjson-dev/changelog.Debian.gz
/usr/share/doc/libqjson-dev/copyright

Changelog

2013-09-04 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
qjson (0.8.1-3) unstable; urgency=low
* Switch priority to optional. A lot of packages with priority optional
depend on qjson, so going against the Debian policy.
Thanks Pino Toscano for pointing it out.
* Update symbols file with buildds' logs.
* Make libqjson-dbg and libqjson0-dbg Priority: extra.
2013-06-16 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
qjson (0.8.1-2) unstable; urgency=low
* Upload to unstable.
* Enable tests. Thanks Pino for the pointer :)
* Confirm symbols from other architectures.
* Fix typo in package description. Thanks Pascal De Vuyst (Closes: #712404).
* Fix missing M-A qualification of the debug package.
* Update amd64 symbols.
* Fail if we are not shipping some files.
* Be sure to build against Qt4 by exporting QT_SELECT. Not really needed,
but doesn't hurts.
2012-11-28 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
qjson (0.8.1-1) experimental; urgency=low
* New upstream release.
* Remove fix_cmake_variables.patch, not necessary anymore.
* Refresh enable_multiarch.patch.
* Fix docs installation.
* Refresh symbols file.
2012-11-08 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
qjson (0.7.1-7) unstable; urgency=low
* Add fix_cmake_variables.patch by Ralf Jung (Closes: #687537).
- Remove now obsolete install_cmake_config.patch.
- Refresh enable_multiarch.patch.
- Refresh debian/series.
- Refresh libqjson-dev.install.
* Fix versioned depends on debhelper. Last time we uploaded compat 9 was
experimental.
- Remove unused lintian override.
* Update symbols files with symbols from the buildds.
* Update Standars-Version to 3.9.4. No changes needed.
2011-11-07 - Lisandro Damián Nicanor Pérez Meyer <lisandro@debian.org>
qjson (0.7.1-6) unstable; urgency=low
[ Lisandro Damián Nicanor Pérez Meyer ]
* Change my e-mail address.
* Remove the DM-Upload-Allowed flag. It is no longer needed.
* Use DEB_CXXFLAGS_MAINT_APPEND instead of exporting CXXFLAGS. Thanks
Felix Geyer for the bug + solution (Closes: #647282).
2011-09-09 - Lisandro Damián Nicanor Pérez Meyer <perezmeyer@gmail.com>
qjson (0.7.1-5) unstable; urgency=low
* Fix typos and nouns capitalization in package's descriptions.
Thanks Filipus Klutiero for checking (Closes: #637373).
2011-07-28 - Lisandro Damián Nicanor Pérez Meyer <perezmeyer@gmail.com>
qjson (0.7.1-4) experimental; urgency=low
* Enable multiarch in the lib.
- B-D on debhelper >= 8.1.3.
- B-D on cmake >= 2.8.5. Thanks Modestas Vainius for the tip.
- Update debian/compat to 9.
- Modify debian/*.install files to support arch triplets.
- Patch CMakeLists.txt to install stuff in ${CMAKE_LIBRARY_ARCHITECTURE},
wich is the same as DEB_HOST_MULTIARCH. Also thanks Modestas.
- Add Pre-Depends: ${misc:Pre-Depends} to libqjson0.
- Add a lintian override on debian/compat being 9, wich is still
experimental.
- Mark libqjson0 Multi-Arch: same.
* Do not install FindQJSON.cmake. CMake maintainer tells me this must have
been for older versions of CMake.
2011-06-16 - Lisandro Damián Nicanor Pérez Meyer <perezmeyer@gmail.com>
qjson (0.7.1-3) unstable; urgency=low
* Fix watch file. Thanks José Manuel Santamaría Lema for the pointer.
* Remember to install CMake's config files. Thanks Felix Geyer.

See Also

Package Description
libqjson0_0.8.1-3_i386.deb Qt-based library that maps JSON data to QVariant objects
libqm-dsp-dev_1.7.1-4_i386.deb Development files (headers) for libqm-dsp library
libqm-dsp0_1.7.1-4_i386.deb C++ library for audio signals analysis
libqmi-utils_1.18.0-3ubuntu1_i386.deb Utilities to use the QMI protocol from the command line
libqmobipocket-dev_17.12.3-0ubuntu1_i386.deb library for reading Mobipocket documents
libqmobipocket2_17.12.3-0ubuntu1_i386.deb library for reading Mobipocket documents
libqoauth-dev_2.0.1~1-3_i386.deb Qt5-based OAuth implementation development headers
libqoauth2_2.0.1~1-3_i386.deb Qt5-based client implementation of the OAuth authorization scheme
libqofono-dev_0.90+16.10.20160901-0ubuntu1_i386.deb Qt library for Ofono
libqofono-qt5-0_0.90+16.10.20160901-0ubuntu1_i386.deb Qt library for Ofono
libqpid-proton-cpp8-dev-doc_0.14.0-5.1ubuntu1_all.deb C++ developer documentation for Qpid Proton
libqpid-proton-cpp8-dev_0.14.0-5.1ubuntu1_i386.deb C++ Development libraries for writing messaging apps with Qpid Proton
libqpid-proton-cpp8_0.14.0-5.1ubuntu1_i386.deb C++ libraries for Qpid Proton
libqpid-proton8-dev-doc_0.14.0-5.1ubuntu1_all.deb Developer documentation for Qpid Proton
libqpid-proton8-dev-examples_0.14.0-5.1ubuntu1_all.deb Example applications for writign messaging apps with Qpid Proton
Advertisement
Advertisement