libqimageblitz-dev_0.0.6-5_i386.deb


Advertisement

Description

libqimageblitz-dev - development files for the QImageBlitz image effects library

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libqimageblitz-dev
Package version 0.0.6
Package release 5
Package architecture i386
Package type deb
Installed size 118 B
Download size 24.62 KB
Official Mirror archive.ubuntu.com
QImageBlitz is an interim graphical effect and filter library for KDE that
contains many improvements over KDE 3.x's kdefx library, including bugfixes
and speed improvements.
This package contains development files for building software that uses the
QImageBlitz library.

Alternatives

Package Version Architecture Repository
libqimageblitz-dev_0.0.6-5_amd64.deb 0.0.6 amd64 Ubuntu Universe
libqimageblitz-dev - - -

Requires

Name Value
libc6 >= 2.4
libqimageblitz4 = 1:0.0.6-5
libqtcore4 >= 4:4.7.0~beta1
libqtgui4 >= 4:4.5.3
libstdc++6 >= 4.1.1

Download

Type URL
Binary Package libqimageblitz-dev_0.0.6-5_i386.deb
Source Package qimageblitz

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libqimageblitz-dev deb package:
    # sudo apt-get install libqimageblitz-dev

Files

Path
/usr/bin/blitztest
/usr/include/qimageblitz/blitzcpu.h
/usr/include/qimageblitz/qimageblitz.h
/usr/include/qimageblitz/qimageblitz_export.h
/usr/lib/libqimageblitz.so
/usr/lib/pkgconfig/qimageblitz.pc
/usr/share/doc/libqimageblitz-dev/changelog.Debian.gz
/usr/share/doc/libqimageblitz-dev/copyright
/usr/share/man/man1/blitztest.1.gz

Changelog

2017-06-26 - Pino Toscano <pino@debian.org>
qimageblitz (1:0.0.6-5) unstable; urgency=medium
* Team upload.
[ Maximiliano Curia ]
* Bump debhelper compat and build dep to 9.
* Bump Standards-Version to 3.9.6, no changes needed.
[ Pino Toscano ]
* Update Vcs-* fields.
* Backport upstream r1203426 to use the proper C compiler when building
assembler sources; patch r1203426.diff.
* Backport upstream r1286623 to fix build with newer/different C++
compilers; patch r1286623.diff.
* Remove libqimageblitz-dbg in favour of the -dbgsym packages.
* Bump Standards-Version to 4.0.0, no changes required.
[ Helmut Grohne ]
* Fix build/host confusion in rules. (Closes: #839283)
2011-06-23 - Modestas Vainius <modax@debian.org>
qimageblitz (1:0.0.6-4) unstable; urgency=low
* Replace $(overriden_command) with $(overridden_command) in debian/rules.
Requires pkg-kde-tools 0.12.
* Bump Standards-Version to 3.9.2: no changes needed.
2011-03-13 - Modestas Vainius <modax@debian.org>
qimageblitz (1:0.0.6-3) unstable; urgency=low
* Switch debian/rules engine to qt-kde-team/2/*.
* Update symbol file (Qt 4.7 specific changes).
2010-09-19 - Modestas Vainius <modax@debian.org>
qimageblitz (1:0.0.6-2) unstable; urgency=low
* Update libqimageblitz4.symbols for other arches, fixes FTBFSes.
2010-09-18 - Modestas Vainius <modax@debian.org>
qimageblitz (1:0.0.6-1) unstable; urgency=low
* New upstream release.
* Bump debian/compat and debhelper build dependency to v7 (to get more
sophisticated debian/tmp handling).
* Switch from internal debian/cdbs/kde.mk to pkg-kde-tools:
- build depend on pkg-kde-tools 0.4;
- remove debian/cdbs directory;
- replace debian/cdbs/kde.mk with
/usr/share/pkg-kde-tools/qt-kde-team/1/debian-qt-kde.mk in debian/rules.
* Add Vcs fields to debian/control.
* Switch to debian source format 3.0 (quilt):
- remove build dependency on quilt;
- bump pkg-kde-tools build dependency to 0.9 (needed for 3.0 (quilt)).
* Strip version numbers from KDE 4 in descriptions, remove references to
Quasar.
* Bump Standards-Version to 3.9.1: no changes needed.
* Move libqimageblitz-dbg package to the bottom of debian/control.
* Change libimageblitz-dbg section to debug.
* Remove Matthew from Uploaders, R.I.P.
* Change Sune's email address to @debian.org.
* Add myself to Uploaders.
* Update packaging copyright years in debian/copyright.
* Strip ./ from libqimageblitz-dev.install.
* Sort install files.
* Add a symbol file for libqimageblitz4 (based on 0.0.4).
* Refresh patches.
* Remove duplicate Section fields from debian/control.
* Add Copyright next to (C) in the statement about Debian packaging
copyright (fixes lintian error).
* Disable /usr/lib R(UN)PATH (patch 13_disable_usr_lib_rpath.diff).
2008-05-27 - Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
qimageblitz (1:0.0.4-4) unstable; urgency=low
* Upload to unstable.
* Move .gnu.note section for non-i386 architectures. (Closes: #479575)
2008-04-28 - Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
qimageblitz (1:0.0.4-3) experimental; urgency=low
+++ Changes by Fathi Boudra:
* Remove FindQt4.cmake local copy.
2008-03-28 - Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
qimageblitz (1:0.0.4-2) experimental; urgency=low
+++ Changes by Matthew Rosewarne:
* Forcibly enable CPU optimizations.
* Move libqimageblitz-dbg to Section: libdevel.
+++ Changes by Ana Beatriz Guerrero Lopez:
* Build against Qt4 4.4 in experimental:
- Add versioned build depend for libqt4-dev on >= 4.4.0~.

See Also

Package Description
libqimageblitz4_0.0.6-5_i386.deb QImageBlitz image effects library
libqjdns-qt4-2_2.0.3-1build1_i386.deb Simple DNS queries library - QT4 wrapper
libqjdns-qt4-dev_2.0.3-1build1_i386.deb Simple DNS queries library QT4 wrapper - development files
libqjdns-qt5-2_2.0.3-1build1_i386.deb Simple DNS queries library - Qt5 wrapper
libqjdns-qt5-dev_2.0.3-1build1_i386.deb Simple DNS queries library Qt5 wrapper - development files
libqjson-dev_0.8.1-3_i386.deb Qt-based library that maps JSON data to QVariant objects - development files
libqjson0_0.8.1-3_i386.deb Qt-based library that maps JSON data to QVariant objects
libqm-dsp-dev_1.7.1-4_i386.deb Development files (headers) for libqm-dsp library
libqm-dsp0_1.7.1-4_i386.deb C++ library for audio signals analysis
libqmi-utils_1.18.0-3ubuntu1_i386.deb Utilities to use the QMI protocol from the command line
libqmobipocket-dev_17.12.3-0ubuntu1_i386.deb library for reading Mobipocket documents
libqmobipocket2_17.12.3-0ubuntu1_i386.deb library for reading Mobipocket documents
libqoauth-dev_2.0.1~1-3_i386.deb Qt5-based OAuth implementation development headers
libqoauth2_2.0.1~1-3_i386.deb Qt5-based client implementation of the OAuth authorization scheme
libqofono-dev_0.90+16.10.20160901-0ubuntu1_i386.deb Qt library for Ofono
Advertisement
Advertisement