libqglviewer-dev-qt5_2.6.3+dfsg2-3_i386.deb


Advertisement

Description

libqglviewer-dev-qt5 - OpenGL 3D viewer library based on Qt5 - development files

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libqglviewer-dev-qt5
Package version 2.6.3+dfsg2
Package release 3
Package architecture i386
Package type deb
Installed size 20 B
Download size 3.47 KB
Official Mirror archive.ubuntu.com
libqglviewer (also known as libQGLViewer) is a free C++ library based on Qt
that enables the quick creation of OpenGL 3D viewers. It features a powerful
camera trackball and simple applications simply require an implementation of
the draw() function. It is a tool of choice for OpenGL beginners and
assignements. It provides screenshot saving, mouse manipulated frames, stereo
display, interpolated keyFrames, object selection, and much more. It is fully
customizable and easy to extend to create complex applications, with a
possible Qt GUI.
This package contains the files needed to develop and compile programs
using QGLViewer linked with Qt version 4.

Alternatives

Package Version Architecture Repository
libqglviewer-dev-qt5_2.6.3+dfsg2-3_amd64.deb 2.6.3+dfsg2 amd64 Ubuntu Universe
libqglviewer-dev-qt5 - - -

Requires

Name Value
libgl-dev -
libgl1-mesa-dev -
libqglviewer-headers -
libqglviewer2-qt5 = 2.6.3+dfsg2-3
libqt5opengl5-dev -
libx11-dev -
libxext-dev -
libxmu-dev -
qtbase5-dev -
qtbase5-dev-tools -

Download

Type URL
Binary Package libqglviewer-dev-qt5_2.6.3+dfsg2-3_i386.deb
Source Package libqglviewer

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libqglviewer-dev-qt5 deb package:
    # sudo apt-get install libqglviewer-dev-qt5

Files

Path
/usr/lib/i386-linux-gnu/libQGLViewer-qt5.prl
/usr/lib/i386-linux-gnu/libQGLViewer-qt5.so
/usr/share/doc/libqglviewer-dev-qt5/README.Debian
/usr/share/doc/libqglviewer-dev-qt5/changelog.Debian.gz
/usr/share/doc/libqglviewer-dev-qt5/copyright

Changelog

2016-09-07 - Anton Gladky <gladk@debian.org>
libqglviewer (2.6.3+dfsg2-3) unstable; urgency=medium
* [33880f7] One more fix in autopkgtest.
2016-09-06 - Anton Gladky <gladk@debian.org>
libqglviewer (2.6.3+dfsg2-2) unstable; urgency=medium
* [2ab5e87] Apply cme fix dpkg-control.
* [229e47c] Update dependency for autopkgtest.
2016-05-20 - Anton Gladky <gladk@debian.org>
libqglviewer (2.6.3+dfsg2-1) unstable; urgency=medium
* [4d7bb78] Fix Breaks/Replaces constructions. (Closes: #824755)
2016-05-09 - Anton Gladky <gladk@debian.org>
libqglviewer (2.6.3+dfsg2-1~exp1) experimental; urgency=medium
* [c78aed7] Add -qt5 prefix to qt5-libs. (Closes: #817785)
* [80044fc] Remove pregenerated js-files.
* [a31f051] Imported Upstream version 2.6.3+dfsg2
* [4fe1c2f] Apply cme fix dpkg-control.
* [617d669] Add Breaks/Replaces, drop Conflicts.
2015-06-26 - Anton Gladky <gladk@debian.org>
libqglviewer (2.6.3+dfsg1-1) unstable; urgency=medium
* [7ad92fc] Add -qt4 packages.
* [3f0191e] Apply cme fix dpkg-control.
* [dc9007d] Imported Upstream version 2.6.3+dfsg1
2015-03-03 - Anton Gladky <gladk@debian.org>
libqglviewer (2.6.1+dfsg1-1) experimental; urgency=medium
* [bf5e634] Migrate to Qt5.
* [1752dbd] Update d/copyright.
* [543dce6] Imported Upstream version 2.6.1+dfsg1
* [e6c2a3c] Update autopkgtest.
* [3267fd4] Set Standards-version: 3.9.6. No changes.
2015-01-17 - Anton Gladky <gladk@debian.org>
libqglviewer (2.5.3+dfsg-4) unstable; urgency=medium
* [2a21535] Remove unnecessary dependency on dpkg. 
It is provided by ${misc:Pre-Depends}.
2015-01-17 - Anton Gladky <gladk@debian.org>
libqglviewer (2.5.3+dfsg-3) unstable; urgency=medium
* [29d85d1] Add pre-depends for libqglviewer2 on dpkg (>= 1.17.14).
Thanks to Jonathan Wiltshire <jmw@debian.org>.
(Closes: #774866)
2015-01-15 - Sebastian Ramacher <sramacher@debian.org>
libqglviewer (2.5.3+dfsg-2.1) unstable; urgency=medium
* Non-maintainer upload.
* libqglviewer2.maintscript: Handle symlink to directory conversion.
(Closes: #774866)
2014-11-06 - Anton Gladky <gladk@debian.org>
libqglviewer (2.5.3+dfsg-2) unstable; urgency=medium
* [457d748] Add Breaks/Replaces for old binary libqglviewer-dev-common.
(Closes: #768207)

See Also

Package Description
libqglviewer-doc_2.6.3+dfsg2-3_all.deb OpenGL 3D viewer library - documentation and examples
libqglviewer-headers_2.6.3+dfsg2-3_all.deb OpenGL 3D viewer library - header files
libqglviewer2-qt4_2.6.3+dfsg2-3_i386.deb OpenGL 3D viewer library based on Qt - runtime library
libqglviewer2-qt5_2.6.3+dfsg2-3_i386.deb OpenGL 3D viewer library based on Qt - runtime library
libqgpgme1_4.14.10-1ubuntu7_i386.deb library for GpgME++ integration with Qt
libqgpsmm-dev_3.17-5_i386.deb Global Positioning System - Qt wrapper for libgps (development)
libqgpsmm23_3.17-5_i386.deb Global Positioning System - Qt wrapper for libgps
libqgsttools-p1_5.9.5-0ubuntu1_i386.deb GStreamer tools for Qt 5 Multimedia module
libqhttpengine-dev_0.1.0+dfsg1-1_i386.deb HTTP server for Qt applications - development files
libqhttpengine-doc_0.1.0+dfsg1-1_all.deb HTTP server for Qt applications - documentation
libqhttpengine-examples_0.1.0+dfsg1-1_i386.deb HTTP server for Qt applications - examples
libqhttpengine0_0.1.0+dfsg1-1_i386.deb HTTP server for Qt applications
libqhull-dev_2015.2-4_i386.deb calculate convex hulls and related structures (development files)
libqhull-doc_2015.2-4_all.deb calculate convex hulls and related structures (documentation files)
libqhull-r7_2015.2-4_i386.deb calculate convex hulls and related structures (reentrant shared library)
Advertisement
Advertisement