libqd0v5_2.3.18+dfsg-2_i386.deb


Advertisement

Description

libqd0v5 - Double-double and quad double types in C++ and F90

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libqd0v5
Package version 2.3.18+dfsg
Package release 2
Package architecture i386
Package type deb
Installed size 413 B
Download size 103.66 KB
Official Mirror archive.ubuntu.com
This package supports both a double-double datatype (approx. 32
decimal digits) and a quad-double datatype (approx. 64 decimal
digits). The computational library is written in C++. Both C++ and
Fortran-90 high-level language interfaces are provided to permit one
to convert an existing C++ or Fortran-90 program to use the library
with only minor changes to the source code.

Alternatives

Package Version Architecture Repository
libqd0v5_2.3.18+dfsg-2_amd64.deb 2.3.18+dfsg amd64 Ubuntu Universe
libqd0v5 - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:3.0
libstdc++6 >= 5.2

Conflicts

Name Value
libqd0 -
libqd2c2a -

Replaces

Name Value
libqd0 -
libqd2c2a -

Download

Type URL
Binary Package libqd0v5_2.3.18+dfsg-2_i386.deb
Source Package qd

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libqd0v5 deb package:
    # sudo apt-get install libqd0v5

Files

Path
/usr/lib/i386-linux-gnu/libqd.so.0
/usr/lib/i386-linux-gnu/libqd.so.0.0.0
/usr/lib/i386-linux-gnu/libqd_f_main.so.0
/usr/lib/i386-linux-gnu/libqd_f_main.so.0.0.0
/usr/lib/i386-linux-gnu/libqdmod.so.0
/usr/lib/i386-linux-gnu/libqdmod.so.0.0.0
/usr/share/doc/libqd0v5/changelog.Debian.gz
/usr/share/doc/libqd0v5/copyright

Changelog

2018-01-26 - Andreas Tille <tille@debian.org>
qd (2.3.18+dfsg-2) unstable; urgency=medium
* Team upload.
* Moved packaging from SVN to Git
* cme fix dpkg-control
* Do not add quilt to Build-Depends when using source/format quilt (3.0)
* Convert from cdbs to dh
* Standards-Version: 4.1.3
* hardening=+all
2018-01-22 - Alastair McKinstry <mckinstry@debian.org>
qd (2.3.18+dfsg-1) unstable; urgency=medium
* New upstream release
* missing-changelog.patch - fix build breaks without ChangeLog
* Drop dh-autoreconf, no longer needed with Debhelper 10
* Standards-Version: 4.1.3; no changes required
* Include symlinks for other libs libqdmod, libqd_f_main
2016-11-14 - Alastair McKinstry <mckinstry@debian.org>
qd (2.3.17.dfsg-1) unstable; urgency=medium
* New upstream release
- libtool patch merged upstream
- gxx43 patch no longer needed
* Remove prelibtool stage, which caused FTBFS. Closes: #818542
* Remove Christophe Prud'homme from Uploaders. Closes: #835012.
* Add myself as Uploader.
* Move to DH_COMPAT=10, with debhelper dep, >= 10
* Standards-Version: 3.9.8
* source format: quilt (3.0)
* Use xz compression
* Rename library packages for g++5 ABI transition. (Match Ubuntu name)
Closes: #819339.
* Tidy up copyright; fix machine-readble format
* Add demangle to debian/watch file (dfsg component)
2015-08-14 - Alastair McKinstry <mckinstry@debian.org>
qd (2.3.11.dfsg-2.3) unstable; urgency=medium
* Non-maintainer upload.
* Build against gcc/gfortran5 for transition. 
2013-09-18 - Colin Watson <cjwatson@debian.org>
qd (2.3.11.dfsg-2.2) unstable; urgency=low
* Convert to dh-autoreconf, which is more robust than CDBS
DEB_AUTO_UPDATE_* (closes: #713207).
* Adjust pkglibdir.patch to work with current Autotools.
* Remove sh4.patch, automatically applied by autoreconf.
2012-03-25 - gregor herrmann <gregoa@debian.org>
qd (2.3.11.dfsg-2.1) unstable; urgency=low
* Non-maintainer upload.
* Fix "FTBFS": add pkglibdir.patch to fix fortran/Makefile.am.
(Closes: #662585)
2011-03-11 - Nobuhiro Iwamatsu <iwamatsu@debian.org>
qd (2.3.11.dfsg-2) unstable; urgency=low
* Team upload.
* Fix build on sh4 (Closes: #590335).
- Add patches/sh4.patch.
2010-08-13 - Christophe Prud'homme <prudhomm@debian.org>
qd (2.3.11.dfsg-1) unstable; urgency=low
[Christophe Prud'homme]
* New upstream release
* debian/control: update Standards-Version to 3.9.1
* debian/libqd-dev.install: do not ship .la file anymore
* Bug fix: "error: Cannot link C++ and Fortran.", thanks to Nobuhiro
Iwamatsu (Closes: #590335).
2009-07-13 - Christophe Prud'homme <prudhomm@debian.org>
qd (2.3.8-1) unstable; urgency=low
[Christophe Prud'homme]
* New upstream release
2009-07-13 - Christophe Prud'homme <prudhomm@debian.org>
qd (2.3.7-2) unstable; urgency=low
[Christophe Prud'homme]
* added libqdmod.a library for fortran support
* debian/control: updated Standards-Version to 3.8.2 (no changes)
* debian/{compat,contro}: updated debhelper compatibility (>=7)

See Also

Package Description
libqdbm++-dev_1.8.78-6.1ubuntu2_i386.deb QDBM Database Libraries for C++ [development] (transitional package)
libqdbm-dev_1.8.78-6.1ubuntu2_i386.deb QDBM Database Libraries [development]
libqdbm-java_1.8.78-6.1ubuntu2_i386.deb QDBM Database Libraries for Java
libqdbm-perl_1.8.78-6.1ubuntu2_i386.deb QDBM Database Libraries for Perl
libqdbm14_1.8.78-6.1ubuntu2_i386.deb QDBM Database Libraries without GDBM wrapper[runtime]
libqdbm3++c2_1.8.78-6.1ubuntu2_i386.deb QDBM Database Libraries for C++ [runtime] (transitional package)
libqdjango-db0_0.6.2-2_i386.deb Database library for the QDjango framework
libqdjango-dev_0.6.2-2_i386.deb Development files for the QDjango framework
libqdjango-doc_0.6.2-2_all.deb Documentation for the QDjango framework
libqdjango-http0_0.6.2-2_i386.deb HTTP library for the QDjango framework
libqdox-java-doc_1.12.1-3_all.deb Documentation for qdox (javadoc)
libqdox-java_1.12.1-3_all.deb Quickly parses declarations and Javadoc from Java source
libqdox2-java-doc_2.0~M8-2_all.deb Documentation for QDox
libqdox2-java_2.0~M8-2_all.deb quickly parses declarations and Javadoc from Java source
libqdwizard-java_5.0.1-1_all.deb simple Java Wizard API
Advertisement
Advertisement