libpythonqt-qtall-qt5-python2-dev_3.2-7build2_i386.deb


Advertisement

Description

libpythonqt-qtall-qt5-python2-dev - Dynamic Python binding for the Qt framework - development

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libpythonqt-qtall-qt5-python2-dev
Package version 3.2
Package release 7build2
Package architecture i386
Package type deb
Installed size 18 B
Download size 2.97 KB
Official Mirror archive.ubuntu.com
PythonQt offers an easy way to embed the Python scripting language into a
C++ Qt applications. It makes heavy use of the QMetaObject system and
requires Qt 5.x.
The focus of PythonQt is on embedding Python into an existing C++ application,
not on writing the whole application completely in Python. If you want to write
your whole application in Python, you should use PyQt or PySide instead.
If you are looking for a simple way to embed Python objects into your C++/Qt
Application and to script parts of your application via Python, PythonQt is the
way to go!
This package contains development files needed to build applications
using and the PythonQt extension PythonQt_QtAll for Python 2.

Alternatives

Package Version Architecture Repository
libpythonqt-qtall-qt5-python2-dev_3.2-7build2_amd64.deb 3.2 amd64 Ubuntu Universe
libpythonqt-qtall-qt5-python2-dev - - -

Requires

Name Value
libpythonqt-qt5-python2-dev = 3.2-7build2
libpythonqt-qtall-qt5-common-dev = 3.2-7build2
libpythonqt-qtall-qt5-python2-3 = 3.2-7build2

Download

Type URL
Binary Package libpythonqt-qtall-qt5-python2-dev_3.2-7build2_i386.deb
Source Package pythonqt

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpythonqt-qtall-qt5-python2-dev deb package:
    # sudo apt-get install libpythonqt-qtall-qt5-python2-dev

Files

Path
/usr/lib/i386-linux-gnu/libPythonQt_QtAll-Qt5-Python2.7.so
/usr/lib/i386-linux-gnu/pkgconfig/PythonQt_QtAll-Qt5-Python2.pc
/usr/share/doc/libpythonqt-qtall-qt5-python2-dev/changelog.Debian.gz
/usr/share/doc/libpythonqt-qtall-qt5-python2-dev/copyright

Changelog

2018-04-14 - Simon Quigley <tsimonq2@ubuntu.com>
pythonqt (3.2-7build2) bionic; urgency=medium
* No-change rebuild against qtdeclarative-abi-5-9-5.
2018-02-25 - Simon Quigley <tsimonq2@ubuntu.com>
pythonqt (3.2-7build1) bionic; urgency=medium
* No-change rebuild against Qt 5.9.4.
2018-02-14 - Jonathan Carter <jcc@debian.org>
pythonqt (3.2-7) unstable; urgency=medium
* Move VCS to salsa.debian.org
* Update standards version to 4.1.3
* Fix debian/copyright
* Replace {binary:Version} with {source:Version} dependency
* Adjust arm builds to allow building for Ubuntu
2018-02-09 - Jonathan Carter <jcc@debian.org>
pythonqt (3.2-6) unstable; urgency=medium
* Upload to unstable
* Update debian/copyright
* Add lintian overrides for package naming
2017-12-01 - Erik Lundin <erik@lun.nu>
pythonqt (3.2-6~exp1) experimental; urgency=medium
* Make common dev packages architecture: all
* Don't install compiled example code
* Move example files to dev package
2017-11-21 - Jonathan Carter <jcc@debian.org>
pythonqt (3.2-5) unstable; urgency=medium
* Upload to unstable
2017-11-20 - Jonathan Carter <jcc@debian.org>
pythonqt (3.2-5~exp1) experimental; urgency=medium
* Add Erik Lundin's patch to fix builds on ppc64
(Closes: #881685)
* Add Erik Lundin's patch to fix files shipped in multiple binaries
(Closes: #881710)
2017-11-13 - Jonathan Carter <jcc@debian.org>
pythonqt (3.2-4) unstable; urgency=medium
* Upload to unstable
2017-11-09 - Erik Lundin <erik@lun.nu>
pythonqt (3.2-4~exp4) experimental; urgency=medium
* Fix generator Qt include dir for multiarch
* Remove unneeded patch fix-string-literals
* Remove unneeded and add new build depends
2017-10-27 - Erik Lundin <erik@lun.nu>
pythonqt (3.2-4~exp3) experimental; urgency=medium
* Patch for building with Qt 5.9

See Also

Package Description
libpythonqt-qtall-qt5-python3-3_3.2-7build2_i386.deb Dynamic Python binding for the Qt framework - runtime
libpythonqt-qtall-qt5-python3-dev_3.2-7build2_i386.deb Dynamic Python binding for the Qt framework - development
libpyzy-1.0-0v5_1.0.1-5_i386.deb Chinese PinYin and Bopomofo conversion library
libpyzy-dev_1.0.1-5_i386.deb Development files of libpyzy
libqaccessibilityclient-dev_0.1.1-5_i386.deb helper to make writing accessibility tools easier -- development
libqaccessibilityclient0_0.1.1-5_i386.deb helper to make writing accessibility tools easier
libqalculate-dev_0.9.10-1_i386.deb Powerful and easy to use desktop calculator - development
libqalculate-doc_0.9.10-1_all.deb Powerful and easy to use desktop calculator - documentation
libqalculate6-data_0.9.10-1_all.deb Powerful and easy to use desktop calculator - data
libqalculate6_0.9.10-1_i386.deb Powerful and easy to use desktop calculator - library
libqapt-dev_3.0.4-0ubuntu1_i386.deb Development headers for the QApt library
libqapt3-runtime_3.0.4-0ubuntu1_i386.deb Runtime components for the QApt library
libqapt3_3.0.4-0ubuntu1_i386.deb QApt library package
libqbscore1.10_1.10.1+dfsg-1_i386.deb Qbs core library
libqbsqtprofilesetup1.10_1.10.1+dfsg-1_i386.deb Qbs profile setup library
Advertisement
Advertisement