libpynac15_0.7.12-2build1_i386.deb


Advertisement

Description

libpynac15 - Engine for symbolic geometric calculus for Python

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libpynac15
Package version 0.7.12
Package release 2build1
Package architecture i386
Package type deb
Installed size 1.94 KB
Download size 568.39 KB
Official Mirror archive.ubuntu.com
Pynac (which stands for "Python is Not a CAS") is a fork of GiNaC that
replaces the dependency of GiNaC on CLN (Class Library for Numbers, C++) by
a dependency on Python.
This is the library for symbolic geometric calculus in Python,
as used in SAGE (http://www.sagemath.org)

Alternatives

Package Version Architecture Repository
libpynac15_0.7.12-2build1_amd64.deb 0.7.12 amd64 Ubuntu Universe
libpynac15 - - -

Requires

Name Value
libc6 >= 2.4
libflint-2.5.2 -
libgcc1 >= 1:3.0
libgmp10 >= 2:6.1.0
libpython2.7 >= 2.7
libsingular4 -
libstdc++6 >= 5.2

Download

Type URL
Binary Package libpynac15_0.7.12-2build1_i386.deb
Source Package pynac

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpynac15 deb package:
    # sudo apt-get install libpynac15

Files

Path
/usr/lib/i386-linux-gnu/libpynac.so.15
/usr/lib/i386-linux-gnu/libpynac.so.15.0.0
/usr/share/doc/libpynac15/README
/usr/share/doc/libpynac15/changelog.Debian.gz
/usr/share/doc/libpynac15/copyright

Changelog

2018-01-31 - Matthias Klose <doko@ubuntu.com>
pynac (0.7.12-2build1) bionic; urgency=medium
* No-change rebuild using mpfr 4.0.0.
2017-12-30 - Tobias Hansen <thansen@debian.org>
pynac (0.7.12-2) unstable; urgency=medium
* Team upload.
* Upload to unstable.
2017-10-15 - Tobias Hansen <thansen@debian.org>
pynac (0.7.12-1) experimental; urgency=medium
* Team upload.
[ Julien Puydt ]
* New upstream release.
* Bump soname version to 15.
* Bump d/watch version to 4.
* Bump std-ver to 4.1.1.
2017-08-15 - Julien Puydt <julien.puydt@laposte.net>
pynac (0.7.10-1) experimental; urgency=medium
* New upstream release.
* Drop static-python-fix.patch, which got upstreamed.
* Bump standards version to 4.0.0.
2017-08-18 - Ximin Luo <infinity0@debian.org>
pynac (0.7.8-3) unstable; urgency=medium
* Team upload.
* Upload to unstable.
2017-06-21 - Tobias Hansen <thansen@debian.org>
pynac (0.7.8-2) experimental; urgency=medium
* Team upload.
* Apply static-python-fix.patch, fixing a segfault after the docbuild
of sagemath.
2017-06-05 - Julien Puydt <julien.puydt@laposte.net>
pynac (0.7.8-1) experimental; urgency=medium
* Updated to latest upstream.
* Bumped soname version up to 13.
2017-02-16 - Julien Puydt <julien.puydt@laposte.net>
pynac (0.7.5-1) experimental; urgency=medium
[ Julien Puydt ]
* Updated to latest upstream.
* Bumped soname version up to 10.
[ Tobias Hansen ]
* Build-Depend on libsingular4-dev (>= 1:4.1.0-p2) to ensure the package
from experimental is used.
2017-01-29 - Julien Puydt <julien.puydt@laposte.net>
pynac (0.7.4-1) experimental; urgency=medium
* Updated to latest upstream.
* Added build-dep on flint.
* Bumped soname version up to 9.
* Added libsingular4-dev, libntl-dev and pkg-config as build-dep.
* Added a patch to find the singular libs.
2016-10-06 - Julien Puydt <julien.puydt@laposte.net>
pynac (0.6.91-1) unstable; urgency=medium
* Updated to latest upstream.
* Pushed dh compat to 10.
* Marked the -dev package as Multi-Arch:same as hinted in the tracker.

See Also

Package Description
libpyside-dev_1.2.2+source1-3_i386.deb Python bindings for Qt 4 (development files)
libpyside-py3-1.2_1.2.2+source1-3_i386.deb Python3 bindings for Qt 4 (base files)
libpyside1.2_1.2.2+source1-3_i386.deb Python bindings for Qt 4 (base files)
libpythia8-dev_8.1.86-1.2_i386.deb PYTHIA event generator of high energy physics - development files
libpythia8v5_8.1.86-1.2_i386.deb PYTHIA event generator of high energy physics
libpython2.7-testsuite_2.7.15~rc1-1_all.deb Testsuite for the Python standard library (v2.7)
libpython3.7-dev_3.7.0~b3-1_i386.deb Header files and a static library for Python (v3.7)
libpython3.7-minimal_3.7.0~b3-1_i386.deb Minimal subset of the Python language (version 3.7)
libpython3.7-stdlib_3.7.0~b3-1_i386.deb Interactive high-level object-oriented language (standard library, version 3.7)
libpython3.7-testsuite_3.7.0~b3-1_all.deb Testsuite for the Python standard library (v3.7)
libpython3.7_3.7.0~b3-1_i386.deb Shared Python runtime library (version 3.7)
libpythonqt-qt5-common-dev_3.2-7build2_all.deb Dynamic Python binding for the Qt framework - development
libpythonqt-qt5-python2-3_3.2-7build2_i386.deb Dynamic Python binding for the Qt framework - runtime
libpythonqt-qt5-python2-dev_3.2-7build2_i386.deb Dynamic Python binding for the Qt framework - development
libpythonqt-qt5-python3-3_3.2-7build2_i386.deb Dynamic Python binding for the Qt framework - runtime
Advertisement
Advertisement