libpwiz3_3.0.10827-4_i386.deb


Advertisement

Description

libpwiz3 - library to perform proteomics data analyses (runtime)

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libpwiz3
Package version 3.0.10827
Package release 4
Package architecture i386
Package type deb
Installed size 10.64 KB
Download size 2.90 MB
Official Mirror archive.ubuntu.com
The libpwiz library from the ProteoWizard project provides a modular
and extensible set of open-source, cross-platform tools and
libraries. The tools perform proteomics data analyses; the libraries
enable rapid tool creation by providing a robust, pluggable
development framework that simplifies and unifies data file access,
and performs standard chemistry and LCMS dataset computations.
The primary goal of ProteoWizard is to eliminate the existing
barriers to proteomic software development so that researchers can
focus on the development of new analytic approaches, rather than
having to dedicate significant resources to mundane (if important)
tasks, like reading data files.

Alternatives

Package Version Architecture Repository
libpwiz3_3.0.10827-4_amd64.deb 3.0.10827 amd64 Ubuntu Universe
libpwiz3 - - -

Requires

Name Value
libboost-chrono1.65.1 -
libboost-filesystem1.65.1 -
libboost-iostreams1.65.1 -
libboost-program-options1.65.1 -
libboost-serialization1.65.1 -
libboost-system1.65.1 -
libboost-thread1.65.1 -
libc6 >= 2.4
libgcc1 >= 1:4.0
libstdc++6 >= 5.2

Download

Type URL
Binary Package libpwiz3_3.0.10827-4_i386.deb
Source Package libpwiz

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpwiz3 deb package:
    # sudo apt-get install libpwiz3

Files

Path
/usr/lib/libpwiz.so.3
/usr/lib/libpwiz.so.3.0.0
/usr/share/doc/libpwiz3/changelog.Debian.gz
/usr/share/doc/libpwiz3/copyright
/usr/share/doc/libpwiz3/example-files/hello_analyzer.cpp
/usr/share/doc/libpwiz3/example-files/hello_analyzer_2.cpp
/usr/share/doc/libpwiz3/example-files/hello_msdata.cpp
/usr/share/doc/libpwiz3/example-files/mscat.cpp
/usr/share/doc/libpwiz3/example-files/txt2mzml.cpp
/usr/share/doc/libpwiz3/example-files/write_example_files.cpp
/usr/share/doc/libpwiz3/example-files/write_mzid_example_files.cpp
/usr/share/doc/libpwiz3/example-files/write_proteome_example_files.cpp
/usr/share/doc/libpwiz3/example-files/write_traml_example_files.cpp
/usr/share/lintian/overrides/libpwiz3
/usr/share/man/man3/libpwiz.3.gz

Changelog

2017-11-01 - Filippo Rusconi <lopippo@debian.org>
libpwiz (3.0.10827-4) unstable; urgency=medium
* debian/make-included-headers-hierarchy.sh: fix script to avoid adding
non-useful h[pp] files. Thanks to Adam Borowski <kilobyte@angband.pl>
for reporting the bug (Closes:#878616).
2017-07-05 - Filippo Rusconi <lopippo@debian.org>
libpwiz (3.0.10827-3) unstable; urgency=medium
* debian/control: Replace tabs with spaces. 
* debian/control: fix libboost-dev dependency so that
/usr/include/boost/lexical_cast.hpp is there although the library 
fine even without it, it is required by dependencies.
2017-07-01 - Filippo Rusconi <lopippo@debian.org>
libpwiz (3.0.10827-2) unstable; urgency=medium
* debian/control: add dependency to libbost-dev. 
2017-06-27 - Filippo Rusconi <lopippo@debian.org>
libpwiz (3.0.10827-1) unstable; urgency=medium
* New upstream version.
* debian/control Standards-Version: 4.0.0
* Use the trigger infrastructure to call ldconfig.
* debian/copyright: thorough rework using licensecheck  + manual checking.
2016-03-21 - Filippo Rusconi <lopippo@debian.org>
libpwiz (3.0.9393-1) unstable; urgency=medium
* New upstream version.
* debian/rules: remove the clean target from the configure target.
* debian/control Standards-Version: 3.9.7 (no changes)
2015-10-02 - Filippo Rusconi <lopippo@debian.org>
libpwiz (3.0.8789-1) unstable; urgency=medium
* New upstream version.
* debian/control:
Build-Depends: add libboost-chrono-dev
Standards-Version: 3.9.6
* libpwiz.lintian-overrides: add a bunch of overrides.
* debian/rules: add some shell code to set the BOOST_LDPATH to the
proper architecture-dependent lib path.
2015-07-10 - Filippo Rusconi <lopippo@debian.org>
libpwiz (3.0.8642-1) unstable; urgency=medium
* New upstream version.
2015-02-09 - Filippo Rusconi <lopippo@debian.org>
libpwiz (3.0.6585-3) UNRELEASED; urgency=medium
* debian/upstream/metadata: use correct bibtex syntax for authors list
(thanks Andreas Tille <tille@debian.org>.
2014-08-18 - Filippo Rusconi <lopippo@debian.org>
libpwiz (3.0.6585-2) unstable; urgency=medium
* mv upstream upstream/metadata
2014-08-13 - Filippo Rusconi <lopippo@debian.org>
libpwiz (3.0.6585-1) unstable; urgency=medium
* New upstream version.
* Patch to fix autotools-based boost-related glitches.

See Also

Package Description
libpwquality-tools_1.4.0-2_i386.deb tools for password quality checking and generation
libpxp-ocaml-dev_1.2.9-1build1_i386.deb OCaml library that implements an XML-1.0 validating parser
libpycaml-ocaml-dev_0.82-15build1_i386.deb OCaml bindings to embed Python interpreter (development files)
libpycaml-ocaml_0.82-15build1_i386.deb OCaml bindings to embed Python interpreter (runtime)
libpynac-dev_0.7.12-2build1_i386.deb Engine for symbolic geometric calculus for Python (development files)
libpynac15_0.7.12-2build1_i386.deb Engine for symbolic geometric calculus for Python
libpyside-dev_1.2.2+source1-3_i386.deb Python bindings for Qt 4 (development files)
libpyside-py3-1.2_1.2.2+source1-3_i386.deb Python3 bindings for Qt 4 (base files)
libpyside1.2_1.2.2+source1-3_i386.deb Python bindings for Qt 4 (base files)
libpythia8-dev_8.1.86-1.2_i386.deb PYTHIA event generator of high energy physics - development files
libpythia8v5_8.1.86-1.2_i386.deb PYTHIA event generator of high energy physics
libpython2.7-testsuite_2.7.15~rc1-1_all.deb Testsuite for the Python standard library (v2.7)
libpython3.7-dev_3.7.0~b3-1_i386.deb Header files and a static library for Python (v3.7)
libpython3.7-minimal_3.7.0~b3-1_i386.deb Minimal subset of the Python language (version 3.7)
libpython3.7-stdlib_3.7.0~b3-1_i386.deb Interactive high-level object-oriented language (standard library, version 3.7)
Advertisement
Advertisement