libpuzzle1_0.11-2_i386.deb


Advertisement

Description

libpuzzle1 - quick similar image finder - shared library

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libpuzzle1
Package version 0.11
Package release 2
Package architecture i386
Package type deb
Installed size 41 B
Download size 15.75 KB
Official Mirror archive.ubuntu.com
The Puzzle library is designed to quickly find visually similar images
(GIF, PNG, JPG), even if they have been resized, recompressed,
recolored or slightly modified.
This package contains the C library.

Alternatives

Package Version Architecture Repository
libpuzzle1_0.11-2_amd64.deb 0.11 amd64 Ubuntu Universe
libpuzzle1 - - -

Requires

Name Value
libc6 >= 2.4
libgd3 >= 2.1.0~alpha~

Download

Type URL
Binary Package libpuzzle1_0.11-2_i386.deb
Source Package libpuzzle

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpuzzle1 deb package:
    # sudo apt-get install libpuzzle1

Files

Path
/usr/lib/i386-linux-gnu/libpuzzle.so.1
/usr/lib/i386-linux-gnu/libpuzzle.so.1.0.0
/usr/share/doc/libpuzzle1/AUTHORS
/usr/share/doc/libpuzzle1/README.gz
/usr/share/doc/libpuzzle1/THANKS
/usr/share/doc/libpuzzle1/TODO.Debian
/usr/share/doc/libpuzzle1/changelog.Debian.gz
/usr/share/doc/libpuzzle1/copyright

Changelog

2017-11-12 - Herbert Parentes Fortes Neto <hpfn@debian.org>
libpuzzle (0.11-2) unstable; urgency=medium
* Team upload.
* debian/control:
- Build-Depends: libgd-dev instead of libgd2-noxpm-dev.
(Closes: #880774) -  Thanks Adrian Bunk
* debian/rules:
- Add DEB_CFLAGS_MAINT_APPEND = -fPIE
- Add DEB_LDFLAGS_MAINT_APPEND = -fPIE -pie
2016-09-19 - Herbert Parentes Fortes Neto <hpfn@debian.org>
libpuzzle (0.11-1) unstable; urgency=low
* Team upload.
* New upstream release.
* All references to build libpuzzle-php package were 
removed. No support to PHP7. (Closes: #821688)
* debian/control:
- Bump Standards-Version from 3.9.5 to 3.9.8.
- Homepage entry updated. github.com
- Vcs-* entries updated. And using https.
- php5-dev removed from Build-Depends.
- chrpath removed from Build-Depends.
- libpuzzle-php entry removed. No support to PHP7. No reverse depends.
* debian/copyright:
- Upstream Copyright: 2007-2009 
* debian/patches:
- 02_link_against_libm renamed to 02_link_against_libm_jump_regress_1_test
Add a reference to skip regress_1 test. As recommended by the upstream.
Please see the header.
* debian/rules:
- References to php removed. libpuzzle 0.11 does not support PHP7.
(Closes: #
- Hardening added.
- LDFLAGS maint append added.
* debian/watch:
- version 4.
- github address added. There is no release on github yet. A guess line.
2014-03-21 - Emmanuel Bouthenot <kolter@debian.org>
libpuzzle (0.9-6) unstable; urgency=medium
* Add a patch to force linking against libm (Closes: #734564)
* Use dh-autoreconf instead of autotools-dev to fix FTBFS on
ppc64el. Thanks to Logan Rosen <logan@ubuntu.com> for the patches.
* Bump Standards-Version to 3.9.5
* Tiny updates in debian/copyright
* Fix Vcs-Browser field
* Add symbols file for libpuzzle1
2012-05-06 - Emmanuel Bouthenot <kolter@debian.org>
libpuzzle (0.9-5) unstable; urgency=low
* Taking over the maintenance of libpuzzle: add myself to Uploaders
(Closes: #651426)
* Bump Standards-Version to 3.9.3
* Switch source format to '3.0 (quilt)'
* Switch build system to full debhelper 9 (bye bye CDBS)
* Add a patch to cleanly build the PHP module separately
* Add Multi-Arch support
* Fix typo in libpuzzle manpage
* Fix various pod errors in manpages pod files
* Switch debian/copyright to DEP5 format
* Update Vcs-* fields
* Use php5{en,dis}mod for conffile handling (Closes: #667769)
2010-01-28 - Cyril Brulebois <kibi@debian.org>
libpuzzle (0.9-4) unstable; urgency=high
* Fix missing dependency on phpapi-* for libpuzzle-php, thanks to
Raphael Geissert (Closes: #566289):
- Add ${php:Depends} to its Depends.
- Use $(php-config5 --phpapi) to define this variable in the
associated substvars file.
* Set urgency to “high” accordingly.
2010-01-03 - Cyril Brulebois <kibi@debian.org>
libpuzzle (0.9-3) unstable; urgency=low
* Fix comment in debian/libpuzzle.ini as requested by Thijs Kinkhorst
since the previous style generates warnings with PHP 5.3: Replace
leading “#” with “;”, which is said to work with all current PHP
versions.
* Add ${misc:Depends} to libpuzzle-dev.
2008-04-26 - Cyril Brulebois <kibi@debian.org>
libpuzzle (0.9-2) unstable; urgency=low
* Pass “LDFLAGS=""” to the PHP extension's ./configure script. Since
dpkg-buildpackage now exports LDFLAGS, an FTBFS is triggered because
of “-Wl,-z,defs” (which was previously only used for the shared
library, as intended); and since “-Wl,--as-needed” isn't sufficient to
get rid of extra linking for that extension anyway, passing an empty
LDFLAGS variable for that part of the build (Closes: #475984).
* Move the maintainership to pkg-phototools as originally planned
(thanks to to Emmanuel Bouthenot who proposed that package):
- Set Maintainer to pkg-phototools.
- Set Uploaders to myself, and update the mail address.
- Add Vcs-Browser and Vcs-Git.

See Also

Package Description
libpvm3_3.4.6-1build2_i386.deb Parallel Virtual Machine - shared libraries
libpwiz-dev_3.0.10827-4_i386.deb library to perform proteomics data analyses (devel files)
libpwiz-doc_3.0.10827-4_all.deb set of programs to perform proteomics data analyses (doc)
libpwiz-tools_3.0.10827-4_i386.deb ProteoWizard command line tools
libpwiz3_3.0.10827-4_i386.deb library to perform proteomics data analyses (runtime)
libpwquality-tools_1.4.0-2_i386.deb tools for password quality checking and generation
libpxp-ocaml-dev_1.2.9-1build1_i386.deb OCaml library that implements an XML-1.0 validating parser
libpycaml-ocaml-dev_0.82-15build1_i386.deb OCaml bindings to embed Python interpreter (development files)
libpycaml-ocaml_0.82-15build1_i386.deb OCaml bindings to embed Python interpreter (runtime)
libpynac-dev_0.7.12-2build1_i386.deb Engine for symbolic geometric calculus for Python (development files)
libpynac15_0.7.12-2build1_i386.deb Engine for symbolic geometric calculus for Python
libpyside-dev_1.2.2+source1-3_i386.deb Python bindings for Qt 4 (development files)
libpyside-py3-1.2_1.2.2+source1-3_i386.deb Python3 bindings for Qt 4 (base files)
libpyside1.2_1.2.2+source1-3_i386.deb Python bindings for Qt 4 (base files)
libpythia8-dev_8.1.86-1.2_i386.deb PYTHIA event generator of high energy physics - development files
Advertisement
Advertisement