libpurple-dev_2.12.0-1ubuntu4_i386.deb


Advertisement

Description

libpurple-dev - multi-protocol instant messaging library - development files

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libpurple-dev
Package version 2.12.0
Package release 1ubuntu4
Package architecture i386
Package type deb
Installed size 1.10 KB
Download size 146.44 KB
Official Mirror archive.ubuntu.com
This package contains the headers and other development files not included in
the main libpurple0 package. Install this if you wish to compile your own
client-agnostic plugins, or would like to compile programs that use
libpurple.

Alternatives

Package Version Architecture Repository
libpurple-dev_2.12.0-1ubuntu4_amd64.deb 2.12.0 amd64 Ubuntu Universe
libpurple-dev - - -

Requires

Name Value
libdbus-glib-1-dev -
libglib2.0-dev -
libpurple0 << 1:2.12.0+1~
libpurple0 >= 1:2.12.0
pkg-config -

Download

Type URL
Binary Package libpurple-dev_2.12.0-1ubuntu4_i386.deb
Source Package pidgin

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpurple-dev deb package:
    # sudo apt-get install libpurple-dev

Files

Path
/usr/include/libpurple/account.h
/usr/include/libpurple/accountopt.h
/usr/include/libpurple/blist.h
/usr/include/libpurple/buddyicon.h
/usr/include/libpurple/certificate.h
/usr/include/libpurple/cipher.h
/usr/include/libpurple/circbuffer.h
/usr/include/libpurple/cmds.h
/usr/include/libpurple/connection.h
/usr/include/libpurple/conversation.h
/usr/include/libpurple/core.h
/usr/include/libpurple/dbus-bindings.h
/usr/include/libpurple/dbus-define-api.h
/usr/include/libpurple/dbus-maybe.h
/usr/include/libpurple/dbus-purple.h
/usr/include/libpurple/dbus-server.h
/usr/include/libpurple/dbus-types.h
/usr/include/libpurple/dbus-useful.h
/usr/include/libpurple/debug.h
/usr/include/libpurple/desktopitem.h
/usr/include/libpurple/dnsquery.h
/usr/include/libpurple/dnssrv.h
/usr/include/libpurple/eventloop.h
/usr/include/libpurple/ft.h
/usr/include/libpurple/gaim-compat.h
/usr/include/libpurple/idle.h
/usr/include/libpurple/imgstore.h
/usr/include/libpurple/log.h
/usr/include/libpurple/marshallers.h
/usr/include/libpurple/media-gst.h
/usr/include/libpurple/media.h
/usr/include/libpurple/mediamanager.h
/usr/include/libpurple/mime.h
/usr/include/libpurple/nat-pmp.h
/usr/include/libpurple/network.h
/usr/include/libpurple/notify.h
/usr/include/libpurple/ntlm.h
/usr/include/libpurple/plugin.h
/usr/include/libpurple/pluginpref.h
/usr/include/libpurple/pounce.h
/usr/include/libpurple/prefs.h
/usr/include/libpurple/privacy.h
/usr/include/libpurple/proxy.h
/usr/include/libpurple/prpl.h
/usr/include/libpurple/purple.h
/usr/include/libpurple/request.h
/usr/include/libpurple/roomlist.h
/usr/include/libpurple/savedstatuses.h
/usr/include/libpurple/server.h
/usr/include/libpurple/signals.h
/usr/include/libpurple/smiley.h
/usr/include/libpurple/sound-theme-loader.h
/usr/include/libpurple/sound-theme.h
/usr/include/libpurple/sound.h
/usr/include/libpurple/sslconn.h
/usr/include/libpurple/status.h
/usr/include/libpurple/stringref.h
/usr/include/libpurple/stun.h
/usr/include/libpurple/theme-loader.h
/usr/include/libpurple/theme-manager.h
/usr/include/libpurple/theme.h
/usr/include/libpurple/upnp.h
/usr/include/libpurple/util.h
/usr/include/libpurple/value.h
/usr/include/libpurple/version.h
/usr/include/libpurple/whiteboard.h
/usr/include/libpurple/xmlnode.h
/usr/include/libpurple/media/backend-iface.h
/usr/include/libpurple/media/candidate.h
/usr/include/libpurple/media/codec.h
/usr/include/libpurple/media/enum-types.h
/usr/lib/i386-linux-gnu/libpurple-client.so
/usr/lib/i386-linux-gnu/libpurple.so
/usr/lib/i386-linux-gnu/pkgconfig/purple.pc
/usr/share/aclocal/purple.m4
/usr/share/doc/libpurple-dev/changelog.Debian.gz
/usr/share/doc/libpurple-dev/copyright

Changelog

See pidgin_2.12.0-1ubuntu4_i386.deb changelog.

See Also

Package Description
libpurple0_2.12.0-1ubuntu4_i386.deb multi-protocol instant messaging library
libpuzzle-bin_0.11-2_i386.deb quick similar image finder - runtime tool
libpuzzle-dev_0.11-2_i386.deb quick similar image finder - development files
libpuzzle1_0.11-2_i386.deb quick similar image finder - shared library
libpvm3_3.4.6-1build2_i386.deb Parallel Virtual Machine - shared libraries
libpwiz-dev_3.0.10827-4_i386.deb library to perform proteomics data analyses (devel files)
libpwiz-doc_3.0.10827-4_all.deb set of programs to perform proteomics data analyses (doc)
libpwiz-tools_3.0.10827-4_i386.deb ProteoWizard command line tools
libpwiz3_3.0.10827-4_i386.deb library to perform proteomics data analyses (runtime)
libpwquality-tools_1.4.0-2_i386.deb tools for password quality checking and generation
libpxp-ocaml-dev_1.2.9-1build1_i386.deb OCaml library that implements an XML-1.0 validating parser
libpycaml-ocaml-dev_0.82-15build1_i386.deb OCaml bindings to embed Python interpreter (development files)
libpycaml-ocaml_0.82-15build1_i386.deb OCaml bindings to embed Python interpreter (runtime)
libpynac-dev_0.7.12-2build1_i386.deb Engine for symbolic geometric calculus for Python (development files)
libpynac15_0.7.12-2build1_i386.deb Engine for symbolic geometric calculus for Python
Advertisement
Advertisement