libpt2.10.11_2.10.11~dfsg-2.1_i386.deb


Advertisement

Description

libpt2.10.11 - Portable Tools Library

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libpt2.10.11
Package version 2.10.11~dfsg
Package release 2.1
Package architecture i386
Package type deb
Installed size 3.84 KB
Download size 1.08 MB
Official Mirror archive.ubuntu.com
This package contains the shared version of the library PTLib, which is
a moderately large class library that has its genesis many years ago as
a method to produce applications to run on both Microsoft Windows and
Unix X-Window systems.
This package also contains all the current PTLib plugins (alsa, oss, pulse,
and v4l2).

Alternatives

Package Version Architecture Repository
libpt2.10.11_2.10.11~dfsg-2.1_amd64.deb 2.10.11~dfsg amd64 Ubuntu Universe
libpt2.10.11 - - -

Requires

Name Value
libasound2 >= 1.0.16
libc6 >= 2.15
libexpat1 >= 2.0.1
libgcc1 >= 1:4.2
libldap-2.4-2 >= 2.4.7
libodbc1 >= 2.3.1
libpulse0 >= 0.99.1
libsasl2-2 -
libsdl1.2debian >= 1.2.11
libssl1.0.0 >= 1.0.0
libstdc++6 >= 5.2
libv4l-0 >= 0.5.0

Download

Type URL
Binary Package libpt2.10.11_2.10.11~dfsg-2.1_i386.deb
Source Package ptlib

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpt2.10.11 deb package:
    # sudo apt-get install libpt2.10.11

Files

Path
/usr/lib/libpt.so.2.10.11
/usr/lib/ptlib-2.10.11/devices/sound/alsa_pwplugin.so
/usr/lib/ptlib-2.10.11/devices/sound/oss_pwplugin.so
/usr/lib/ptlib-2.10.11/devices/sound/pulse_pwplugin.so
/usr/lib/ptlib-2.10.11/devices/videoinput/v4l2_pwplugin.so
/usr/share/doc/libpt2.10.11/README.Debian
/usr/share/doc/libpt2.10.11/changelog.Debian.gz
/usr/share/doc/libpt2.10.11/copyright

Changelog

2016-11-30 - Andrey Rahmatullin <wrar@debian.org>
ptlib (2.10.11~dfsg-2.1) unstable; urgency=medium
* Non-maintainer upload.
* Fix FTBFS with GCC 6 (Closes: #811835).
* Explicitly build with OpenSSL 1.0 (Closes: #828514).
2015-11-06 - Eugen Dedu <eugen.dedu@univ-fcomte.fr>
ptlib (2.10.11~dfsg-2) unstable; urgency=low
* patches/no-sslv3: Fix FTBFS with recent libssl library without SSL v3 support
* Update debian/copyright file, thanks Scott Kitterman
2015-08-28 - Eugen Dedu <Eugen.Dedu@pu-pm.univ-fcomte.fr>
ptlib (2.10.11~dfsg-1) unstable; urgency=low
* New upstream release
2015-06-26 - Eugen Dedu <Eugen.Dedu@pu-pm.univ-fcomte.fr>
ptlib (2.10.10~dfsg-5) unstable; urgency=medium
* patches/gcc-5_support: Fix FTBS with GCC 5 (Closes: Bug#778074).
2014-10-08 - YunQiang Su <syq@debian.org>
ptlib (2.10.10~dfsg-4.1) unstable; urgency=low
* Non-mantainer upload.
* Define P_64BIT and LIB64 for arm64, mips64(el) and ppc64el (Closes: #748911).
2014-01-17 - Eugen Dedu <Eugen.Dedu@pu-pm.univ-fcomte.fr>
ptlib (2.10.10~dfsg-4) unstable; urgency=medium
* patches/bison-fix: Update patch to fix crash (Closes: Bug#735600).
2014-01-08 - Eugen Dedu <Eugen.Dedu@pu-pm.univ-fcomte.fr>
ptlib (2.10.10~dfsg-3) unstable; urgency=low
* patches/bison-fix: Fix build with bison 3.0 (Closes: Bug#733396).
* Ack NMU, thanks Samuel!
2013-11-10 - Samuel Thibault <sthibault@debian.org>
ptlib (2.10.10~dfsg-2.1) unstable; urgency=low
* NMU with agreement of maintainer.
* patches/hurd-fix: Fix hurd build (Closes: Bug#729184).
* control: Bump doxygen version to 1.8.5-1 to avoid its hang bug
(Closes: #729243).
2013-05-05 - Mark Purcell <msp@debian.org>
ptlib (2.10.10~dfsg-2) unstable; urgency=low
* Upload to Unstable
2013-02-23 - Mark Purcell <msp@debian.org>
ptlib (2.10.10~dfsg-1) experimental; urgency=low
[ Eugen Dedu ]
* New upstream release

See Also

Package Description
libpth-dev_2.0.7-20_i386.deb GNU Portable Threads (development)
libpth20_2.0.7-20_i386.deb GNU Portable Threads
libpthread-workqueue-dev_0.9.1-1_i386.deb thread pool library (development files)
libpthread-workqueue0_0.9.1-1_i386.deb thread pool library
libptscotch-6.0_6.0.4.dfsg1-8_i386.deb MPI programs and libraries for graph, mesh and hypergraph partitioning
libptscotch-dev_6.0.4.dfsg1-8_i386.deb MPI programs and libraries for graph, mesh and hypergraph partitioning
libpugixml-dev_1.8.1-7_i386.deb Light-weight C++ XML processing library (development)
libpugixml1v5_1.8.1-7_i386.deb Light-weight C++ XML processing library
libpugl-0-0_0~svn32+dfsg0-2_i386.deb portable API for OpenGL graphical interfaces
libpugl-dev_0~svn32+dfsg0-2_i386.deb portable API for OpenGL graphical interfaces (headers)
libpulse-java_2.4.7-1_all.deb PulseAudio sound driver for Java
libpulse-jni_2.4.7-1_i386.deb PulseAudio sound driver for Java (JNI libraries)
libpulse-ocaml-dev_0.1.2-1build5_i386.deb OCaml interface to the pulseaudio library
libpulse-ocaml_0.1.2-1build5_i386.deb OCaml interface to the PulseAudio sound server
libpuma-dev_2.2+git20170823-1_i386.deb C/C++/AspectC++ Scanner and Parsers
Advertisement
Advertisement