libproxy-cil-dev_0.4.15-1_all.deb


Advertisement

Description

libproxy-cil-dev - automatic proxy configuration management library (CLI devel)

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libproxy-cil-dev
Package version 0.4.15
Package release 1
Package architecture all
Package type deb
Installed size 18 B
Download size 2.44 KB
Official Mirror archive.ubuntu.com
libproxy is a lightweight library which makes it easy to develop
applications proxy-aware with a simple and stable API.
This package contains development files for the CLI bindings, and should be
used for compilation.

Alternatives

Package Version Architecture Repository
libproxy-cil-dev_0.4.15-1_all.deb 0.4.15 all Ubuntu Universe
libproxy-cil-dev - - -

Requires

Name Value
libproxy0.4-cil = 0.4.15-1

Download

Type URL
Binary Package libproxy-cil-dev_0.4.15-1_all.deb
Source Package libproxy

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libproxy-cil-dev deb package:
    # sudo apt-get install libproxy-cil-dev

Files

Path
/usr/lib/pkgconfig/libproxy-sharp-1.0.pc
/usr/share/doc/libproxy-cil-dev/changelog.Debian.gz
/usr/share/doc/libproxy-cil-dev/copyright

Changelog

2018-03-28 - Jeremy Bicha <jbicha@debian.org>
libproxy (0.4.15-1) unstable; urgency=medium
* New upstream release
* Update Vcs fields for migration to https://salsa.debian.org/
* Drop libproxy1-plugin-mozjs since it depends on an outdated version
of mozjs. Use libproxy1-plugin-webkit instead. (Closes: #863783)
* Drop fix-clean-reload-cache.patch: Applied in new release
2017-12-18 - Jeremy Bicha <jbicha@debian.org>
libproxy (0.4.14-4) unstable; urgency=medium
* Update Vcs fields for conversion to git
* Add debian/gbp.conf
* Update Maintainer
* Bump debhelper compat to 11
* Bump Standards-Version to 4.1.2
2017-05-27 - Laurent Bigonville <bigon@debian.org>
libproxy (0.4.14-3) unstable; urgency=medium
[ Alexander Volkov ]
* Don't build depend on libkf5config-bin on stage1 (Closes: #847365)
2017-02-08 - Laurent Bigonville <bigon@debian.org>
libproxy (0.4.14-2) unstable; urgency=medium
* debian/patches/fix-clean-reload-cache.patch: Make sure that the PAC/WPAD
cache is cleanup when network topology changes and prevent a segfault in
the process, patches merged upstream.
2017-01-22 - Michael Biebl <biebl@debian.org>
libproxy (0.4.14-1) unstable; urgency=medium
* New upstream release.
* Switch Build-Depends from network-manager-dev to the newer libnm-dev.
While the code has a fallback for the older header files, the new ones
provided by libnm are preferred by upstream.
* Use DEB_LDFLAGS_MAINT_APPEND to pass additional flags to the linker.
* Bump SHVER to 0.4.14.
2016-11-20 - Andrey Rahmatullin <wrar@debian.org>
libproxy (0.4.13-1.1) unstable; urgency=medium
* Non-maintainer upload.
* Fix FTBFS (Closes: #844956).
2016-11-10 - Jeremy Bicha <jbicha@linux.com>
libproxy (0.4.13-1) unstable; urgency=medium
* Team upload.
[ Michael Biebl ]
* Drop uploaders.mk from debian/rules as this breaks the clean target with
dh. Instead use the gnome dh addon which updates debian/control via
dh_gnome_clean.
[ Jeremy Bicha ]
* New upstream version
* Add python3-libproxy package
* Add debian/docs to install NEWS
* debian/control.in debian/watch: Update homepage and watch URLs
* debian/control.in:
- Build-depend on libkf5config-bin instead of QT and KDE libs
- Bump Standards-Version to 3.9.8
* debian/libproxy1-plugin-kconfig.install:
config_kde.so instead of config_kde4.so
* Dropped patches applied in new version:
- 0001-pacrunner_webkit-allow-linking-against-javascriptcor.patch
- dont_segfault_on_exit.patch
- fix-mozjs-detection.patch
[ Iain Lane ]
* debian/rules: Use pyversions -d
2016-02-16 - Iain Lane <laney@debian.org>
libproxy (0.4.11-5) unstable; urgency=medium
[ Peter Pentchev ]
* Add explicit zlib build-dependency (Closes: #758465)
* Break a couple of build dependency loops (Closes: #758466)
* Add build profile annotations to debian/control (Closes: #758467)
[ Andreas Henriksson ]
* Build-depend on dpkg-dev (>= 1.17.2) and bump debhelper to >= 9.20140227
- these versions introduced build profiles support.
* Bump Standards-Version to 3.9.5
[ Iain Lane ]
* Ack the NMUs, thanks!
* Fix the build profiles syntax to the current version.
* debian/patches/0001-pacrunner_webkit-allow-linking-against-javascriptcor.patch:
Cherry-pick - allow building against webkit2gtk. Update BDs too.
* Add Enhances: from the plugin packages to the library so that people can
find them easier. (Closes: #768435, #768437)
* Use the substvar we just added to add Depends on our shared package.
2015-08-04 - Matthias Klose <doko@debian.org>
libproxy (0.4.11-4.2) unstable; urgency=medium
* Non maintainer upload.
* libproxy1-plugin-mozjs: Fix dependency on new libproxy1v5.
2015-08-04 - Matthias Klose <doko@debian.org>
libproxy (0.4.11-4.1) unstable; urgency=medium
* Non maintainer upload.
* Rename library libproxy1 -> libproxy1v5, needed as a follow-up transition
for the libstdc++6 ABI changes (patch by Sebastien Bacher).
Addresses: #794402.

See Also

Package Description
libproxy-tools_0.4.15-1_i386.deb automatic proxy configuration management library (tools)
libproxy0.4-cil_0.4.15-1_all.deb automatic proxy configuration management library (CLI)
libproxy1-plugin-kconfig_0.4.15-1_i386.deb automatic proxy configuration management library (KConfig plugin)
libproxy1-plugin-webkit_0.4.15-1_i386.deb automatic proxy configuration management library (Webkit plugin)
libproxychains-dev_3.1-7_i386.deb proxy chains -- shared library (development)
libproxychains3_3.1-7_i386.deb proxy chains -- shared library (runtime)
libproxychains4_4.12-1_i386.deb runtime shared library for proxychains-ng
libprpc-perl_0.1005-21_all.deb Perl extensions for writing pRPC servers and clients
libpseudo_1.8.1+git20161012-2_i386.deb advanced tool for simulating superuser privileges
libpsi3-dev_3.4.0-6build2_i386.deb Quantum Chemical Program Suite (Development Libraries)
libpsm-infinipath1-dev_3.3+20.604758e7-5_i386.deb Development files for libpsm-infinipath1
libpsm-infinipath1_3.3+20.604758e7-5_i386.deb PSM Messaging library for Intel Truescale adapters
libpsocksxx-dev_1.1.0-1.2_i386.deb psocksxx is a C++ wrapper for POSIX sockets (development files)
libpsocksxx-doc_1.1.0-1.2_all.deb psocksxx is a C++ wrapper for POSIX sockets (documentation)
libpsocksxx0_1.1.0-1.2_i386.deb psocksxx is a C++ wrapper for POSIX sockets
Advertisement
Advertisement