libprojectm2v5_2.1.0+dfsg-4build1_i386.deb


Advertisement

Description

libprojectm2v5 - Advanced Milkdrop-compatible music visualization library

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libprojectm2v5
Package version 2.1.0+dfsg
Package release 4build1
Package architecture i386
Package type deb
Installed size 668 B
Download size 216.43 KB
Official Mirror archive.ubuntu.com
libprojectm is an iterative music visualization library which uses
OpenGL for hardware acceleration. It is compatible with Milkdrop
presets.
This package contains the library and essential data needed for
the visualization library to work.

Alternatives

Package Version Architecture Repository
libprojectm2v5_2.1.0+dfsg-4build1_amd64.deb 2.1.0+dfsg amd64 Ubuntu Universe
libprojectm2v5 - - -

Requires

Name Value
fonts-dejavu-core -
libc6 >= 2.4
libftgl2 >= 2.1.3~rc5
libgcc1 >= 1:3.0
libgl1 -
libgl1-mesa-glx -
libglew2.0 >= 1.12.0
libstdc++6 >= 5.2
projectm-data -

Replaces

Name Value
libprojectm-data << 2.0.1
libprojectm2 -

Download

Type URL
Binary Package libprojectm2v5_2.1.0+dfsg-4build1_i386.deb
Source Package projectm

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libprojectm2v5 deb package:
    # sudo apt-get install libprojectm2v5

Files

Path
/usr/lib/libprojectM.so.2
/usr/lib/libprojectM.so.2.1.0
/usr/share/doc/libprojectm2v5/FAQ.txt.gz
/usr/share/doc/libprojectm2v5/README.Debian
/usr/share/doc/libprojectm2v5/changelog.Debian.gz
/usr/share/doc/libprojectm2v5/copyright
/usr/share/projectM/config.inp

Changelog

2016-11-06 - Jeremy Bicha <jbicha@ubuntu.com>
projectm (2.1.0+dfsg-4build1) zesty; urgency=medium
* No-change rebuild against latest glew
2016-07-28 - Matthias Klumpp <mak@debian.org>
projectm (2.1.0+dfsg-4) unstable; urgency=medium
* Acknowledge NMU
* fix-gcc6-build.patch: Fix FTBFS with GCC 6 (Closes: #811831)
* Stop building debug package: We have automatic dbgsym packages now
* Bump standards version: No changes needed
* Use secure Vcs-* URLs
* Modernize gbp.conf
2016-04-30 - Adam Borowski <kilobyte@angband.pl>
projectm (2.1.0+dfsg-3.1) unstable; urgency=medium
* Non-maintainer upload.
* Use fonts-dejavu-core instead of ttf-dejavu-core (Closes: #733957)
2015-08-05 - Sebastian Ramacher <sramacher@debian.org>
projectm (2.1.0+dfsg-3) unstable; urgency=medium
* Team upload.
* Upload to unstable.
2015-08-02 - Sebastian Ramacher <sramacher@debian.org>
projectm (2.1.0+dfsg-2) experimental; urgency=medium
* Team upload.
[ Matthias Klumpp ]
* Fix debian/watch file
* Use my Debian mail address
* Bump standards version (no change needed)
[ Sebastian Ramacher ]
* Rename library packages for GCC 5 transition.
* debian/copyright: Fix lintian warnings.
2012-05-21 - Matthias Klumpp <matthias@tenstral.net>
projectm (2.1.0+dfsg-1) unstable; urgency=low
* New upstream release: 2.1.0
- Fixed several memory leaks (when projectM gets destroyed,
or when a preset gets destroyed)
- Resolved some parser errors and an embarrasing evaluation bug
(in particular, 2^x does not equal x^2)
- +/- keys support to edit the ratings
- libvisual / gstreamer compatibility
- Various cmake build fixes and improvements
- Patches for better Linux distribution integration
* Switch to compat-level 9
* Update dfsg-free projectM generator script
* Drop all patches: Applied upstream
* Install libvisual-plugin into multiarch dir
* Set font-settings as build-time parameters
* Make debian/copyright DEP-5 compliant
2012-01-01 - Matthias Klumpp <matthias@tenstral.net>
projectm (2.0.1+dfsg-12) unstable; urgency=low
* Make parser handle cases like "1.0-1.0-2.0"
* Fix wrong sqr and sigmoid functions
* Unbind FBO when done (might fix some OGL errors)
2011-11-20 - Matthias Klumpp <matthias@tenstral.net>
projectm (2.0.1+dfsg-11) unstable; urgency=low
[ Reinhard Tartler ]
* use Breaks: libprojectm-data instead Conflicts
[ Matthias Klumpp ]
* Fix FTBFS with recent PulseAudio versions (Closes: #646492)
* Adjust path to projectM header (Closes: #642498)
* Allow DM upload
* Fix FTBFS on multiarch Debian config (files were placed wrong)
2011-08-01 - Matthias Klumpp <matthias@tenstral.net>
projectm (2.0.1+dfsg-10) unstable; urgency=low
* Use DejaVu font instead of Bistream-Vera (Closes: #630557)
* Update my email-address
* Update projectM-Qt dev package dependencies
* Fix projectM linking (LP: #819025)
* Rebuild for libglew1.5 -> libglew1.6 transition
2011-06-09 - Matthias Klumpp <matthias@nlinux.org>
projectm (2.0.1+dfsg-9) unstable; urgency=low
* Fix incorrect token parsing in presetfactory
projectM-pulseaudio hangs whilst trying to parse
the idle preset due to incorrect token parsing in
libprojectm2 (Closes: #627616).
Thanks to Adam Guthrie for the patch!
* Adjusted VCS links

See Also

Package Description
libpromises3_3.10.2-4build1_i386.deb libpromises library for cfengine3 binaries
libproperties-cpp-dev_0.0.1+14.10.20140730-0ubuntu1_i386.deb C++11 library providing properties/signals. - dev headers
libproperties-cpp-doc_0.0.1+14.10.20140730-0ubuntu1_all.deb Documentation files for libproperties-cpp-dev
libproperties-maven-plugin-java_1.0.0-1_all.deb Maven Plugin to read and write property files from mojo.codehaus.org
libprotobuf-c-dev_1.2.1-2_i386.deb Protocol Buffers C static library and headers (protobuf-c)
libprotobuf-c1_1.2.1-2_i386.deb Protocol Buffers C shared library (protobuf-c)
libprotobuf-java-format-java_1.3-1_all.deb Library to serialize protobuf messages to XML, JSON and HTML
libprotobuf-java_3.0.0-9.1ubuntu1_all.deb Java bindings for protocol buffers
libprotocol-acme-perl_1.01-2_all.deb Perl Interface to the Let's Encrypt ACME API
libprotocol-http2-perl_1.08-1_all.deb HTTP/2 protocol implementation with client and server libraries
libprotocol-osc-perl_0.08-1_all.deb module to implement (de)coding and processing of OSC packets
libprotozero-dev_1.6.1-1_i386.deb Minimalistic protocol buffer decoder and encoder in C++
libprotozero-doc_1.6.1-1_all.deb Minimalistic protocol buffer decoder and encoder in C++ - docs
libproxool-java_0.9.1-10_all.deb Java JDBC connection pool
libproxy-cil-dev_0.4.15-1_all.deb automatic proxy configuration management library (CLI devel)
Advertisement
Advertisement