libprelude-perl_4.1.0-4_i386.deb


Advertisement

Description

libprelude-perl - Security Information and Events Management system [ Perl bindings ]

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libprelude-perl
Package version 4.1.0
Package release 4
Package architecture i386
Package type deb
Installed size 462 B
Download size 92.74 KB
Official Mirror archive.ubuntu.com
The Prelude Library is a collection of generic functions providing
communication between the Prelude SIEM suite components. It provides a
convenient interface for sending alerts to Prelude Manager with transparent
SSL, failover and replication support, asynchronous events and timer
interfaces, an abstracted configuration API (hooking at the commandline, the
configuration line, or wide configuration, available from the Manager), and a
generic plugin API. It allows you to easily turn your favorite security
program into a Prelude sensor.
This package contains the perl bindings for Prelude.

Alternatives

Package Version Architecture Repository
libprelude-perl_4.1.0-4_amd64.deb 4.1.0 amd64 Ubuntu Universe
libprelude-perl - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:3.0
libprelude23 = 4.1.0-4
libpreludecpp8 >= 4.1
perl >= 5.26.1-5
perlapi-5.26.1 -
ruby << 1:2.6~

Download

Type URL
Binary Package libprelude-perl_4.1.0-4_i386.deb
Source Package libprelude

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libprelude-perl deb package:
    # sudo apt-get install libprelude-perl

Files

Path
/usr/lib/i386-linux-gnu/perl5/5.26/Prelude.pm
/usr/lib/i386-linux-gnu/perl5/5.26/auto/Prelude/Prelude.so
/usr/share/doc/libprelude-perl/changelog.Debian.gz
/usr/share/doc/libprelude-perl/copyright

Changelog

2018-03-11 - Thomas Andrejak <thomas.andrejak@gmail.com>
libprelude (4.1.0-4) unstable; urgency=medium
* Fix FTBFS with gcc-8: symbol mismatch (Closes: #892588)
* d/control: Add multiarch fields
2018-03-07 - Thomas Andrejak <thomas.andrejak@gmail.com>
libprelude (4.1.0-3) unstable; urgency=medium
* Fix FTBFS on x32: symbols mismatch (Closes: #892171)
Thanks Mattia Rizzolo
2018-03-06 - Thomas Andrejak <thomas.andrejak@gmail.com>
libprelude (4.1.0-2) unstable; urgency=medium
* Fix migrating from stable (Closes: #892051)
* Fix symbols file for 32 bit architectures (Closes: #892104)
2018-02-28 - Thomas Andrejak <thomas.andrejak@gmail.com>
libprelude (4.1.0-1) unstable; urgency=medium
* Bump version 4.1.0 (Closes: #891800)
- New patches:
011-fix_spelling_error.patch
012-fix-server_confirm_type.patch (Closes: #689434)
- Remove unnecessary patches:
002-manpages-spelling.patch
003-disable_gnulib_test_lock.patch
009-update-gtkdoc-files.patch
- Fix license-problem-non-free-RFC for src/common.c
* Update d/control
- Bump to Standards-Version 4.1.3
- Update Vcs-* to Salsa
- Update debhelper to 11
- Split libprelude23 to libprelude23 and libprelude-utils (Closes: #855916)
This new package handle /etc/prelude dir and prelude-admin binary
- Update packages description
* Update d/compat to 11
* Add symbols files for libprelude23 and libpreludecpp8
* Update d/copyright: update dates to 2017
2017-11-03 - Thomas Andrejak <thomas.andrejak@gmail.com>
libprelude (3.1.0-1) unstable; urgency=medium
* Add patch to fix compatibility with GnutLS 3.6 when using prelude-admin
- 010-fix_compatibility_gnutls_3_6.patch
* Update d/control
- Add Thomas Andrejak as uploader
- Bump to Standards-Version 4.1.1
- Add Vcs* fields
- Change Priority from extra to optional
* Remove trailing whitespaces in d/changelog
2017-09-24 - Thomas Andrejak <thomas.andrejak@gmail.com>
libprelude (3.1.0-0.6) unstable; urgency=medium
* Non-maintainer upload.
* Update gtkdoc files to be compatible with gtkdoc-1.26 (Closes: #876591)
- Update gtk-doc.make and m4/gtk-doc.m4
- Using https://github.com/GNOME/gtk-doc
* Add libglib2.0-dev to build-dep-indep because it is required for gtk-doc
2017-08-28 - Thomas Andrejak <thomas.andrejak@gmail.com>
libprelude (3.1.0-0.5) unstable; urgency=medium
* Non-maintainer upload.
* Rebuild with GCC 7. (Closes: #871289)
- Build-depend on gcc >= 7.
- Update shlibs to ensure rdeps pull in the new version.
2017-07-17 - Thomas Andrejak <thomas.andrejak@gmail.com>
libprelude (3.1.0-0.4) unstable; urgency=medium
* Upload to unstable.
2017-06-27 - Mattia Rizzolo <mattia@debian.org>
libprelude (3.1.0-0.3) experimental; urgency=medium
* Non-maintainer upload.
* Bump Standards-Version to 4.0.0, no changes needed.
* Bump debhelper compat level to 10:
+ Drop explicit autoreconf, now part of debhelper standard sequence.
* Fix arch-dep only build, by fixing an inverted boolean check.
2017-06-22 - Thomas Andrejak <thomas.andrejak@gmail.com>
libprelude (3.1.0-0.2) experimental; urgency=medium
* Non-maintainer upload.
* Control:
- Support Build profiles nopython, noperl, nolua and noruby; also build
the documentation only when building the indep packages (Closes: #838115)
- Add Replace and Breaks for transition (Closes: #864460)
* Patches:
- 007-fix_libprelude-error_hurd.patch: patch for errno on hurd-i386
- 008-disable_test-poll_on_kfreebsd.patch: Disable test-poll test in
libmissing on kfreebsd

See Also

Package Description
libprelude23_4.1.0-4_i386.deb Security Information and Events Management system [ Base library ]
libpreludecpp8_4.1.0-4_i386.deb Security Information and Events Management system [ C++ library ]
libpreludedb-dev_4.1.0-1_i386.deb Security Information and Events Management System [ Development files ]
libpreludedb-doc_4.1.0-1_all.deb Security Information and Events Management System [ Documentation ]
libpreludedb7-mysql_4.1.0-1_i386.deb Security Information and Events Management System [ MySQL library ]
libpreludedb7-pgsql_4.1.0-1_i386.deb Security Information and Events Management System [ PGSQL library ]
libpreludedb7-sqlite_4.1.0-1_i386.deb Security Information and Events Management System [ SQLite library ]
libpreludedb7_4.1.0-1_i386.deb Security Information and Events Management System [ Base library ]
libpreludedbcpp2_4.1.0-1_i386.deb Security Information and Events Management System [ C++ library ]
libpresage-data_0.9.1-2.1ubuntu4_all.deb intelligent predictive text entry platform (data files)
libpresage-dev_0.9.1-2.1ubuntu4_i386.deb intelligent predictive text entry platform (development files)
libpresage-doc_0.9.1-2.1ubuntu4_all.deb intelligent predictive text entry platform (documentation)
libpresage1v5_0.9.1-2.1ubuntu4_i386.deb intelligent predictive text entry platform (shared library)
libpri-dev_1.6.0-1_i386.deb Primary Rate ISDN specification development files
libpri1.4_1.6.0-1_i386.deb Primary Rate ISDN specification library
Advertisement
Advertisement