libppx-visitors-ocaml-dev_20170725-2_i386.deb


Advertisement

Description

libppx-visitors-ocaml-dev - OCaml syntax extension for object-oriented visitors

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libppx-visitors-ocaml-dev
Package version 20170725
Package release 2
Package architecture i386
Package type deb
Installed size 1.18 KB
Download size 220.45 KB
Official Mirror archive.ubuntu.com
Visitors is a syntax extension for the OCaml programming language. It
allows you to annotate your type definitions, such that a visitor class
will be automatically generated. This visitor class contains methods
for the traversal of your data structure, like iter, map, fold, etc. It
is then easy to override these methods for your needs. This is very
convenient when programming with complex algebraic data structures.

Alternatives

Package Version Architecture Repository
libppx-visitors-ocaml-dev_20170725-2_amd64.deb 20170725 amd64 Ubuntu Universe
libppx-visitors-ocaml-dev - - -

Requires

Name Value
libc6 >= 2.1.3
libppx-deriving-ocaml-dev-dxg83 -
libppx-tools-ocaml-dev-cqv09 -
libresult-ocaml-dev-ciso5 -
ocaml-nox-4.05.0 -

Provides

Name Value
libppx-visitors-ocaml-dev-6svy1 -

Download

Type URL
Binary Package libppx-visitors-ocaml-dev_20170725-2_i386.deb
Source Package ocaml-visitors

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libppx-visitors-ocaml-dev deb package:
    # sudo apt-get install libppx-visitors-ocaml-dev

Files

Path
/usr/lib/ocaml/visitors/META
/usr/lib/ocaml/visitors/Makefile.preprocess
/usr/lib/ocaml/visitors/VisitorsRuntime.a
/usr/lib/ocaml/visitors/VisitorsRuntime.cma
/usr/lib/ocaml/visitors/VisitorsRuntime.cmi
/usr/lib/ocaml/visitors/VisitorsRuntime.cmo
/usr/lib/ocaml/visitors/VisitorsRuntime.cmx
/usr/lib/ocaml/visitors/VisitorsRuntime.cmxa
/usr/lib/ocaml/visitors/VisitorsRuntime.o
/usr/lib/ocaml/visitors/ppx_deriving_visitors.a
/usr/lib/ocaml/visitors/ppx_deriving_visitors.cma
/usr/lib/ocaml/visitors/ppx_deriving_visitors.cmxa
/usr/lib/ocaml/visitors/ppx_deriving_visitors.cmxs
/usr/share/doc/libppx-visitors-ocaml-dev/changelog.Debian.gz
/usr/share/doc/libppx-visitors-ocaml-dev/copyright
/var/lib/ocaml/lintian/libppx-visitors-ocaml-dev.info
/var/lib/ocaml/md5sums/libppx-visitors-ocaml-dev.md5sums

Changelog

2017-10-30 - Ralf Treinen <treinen@debian.org>
ocaml-visitors (20170725-2) unstable; urgency=medium
* Patch ocaml-4.05: migrate to ocaml 4.05, patch picked from upstream git
(closes: #880063)
* Standards-Version 4.1.1:
- replace Priority extra by optional. 
2017-07-28 - Ralf Treinen <treinen@debian.org>
ocaml-visitors (20170725-1) unstable; urgency=medium
* New upstream release. This release fixes compilation on bytecode
architectures (closes: #869207)
* Added build-dependency on ocamlbuild.
2017-07-06 - Ralf Treinen <treinen@debian.org>
ocaml-visitors (20170404-1) unstable; urgency=medium
* Initial upload (closes: #862775)

See Also

Package Description
libppx-visitors-ocaml-doc_20170725-2_all.deb Documentation of the visitors syntax extension for OCaml
libpqtypes-dev_1.5.1-2_i386.deb parameterized queries libpq extension - development
libpqtypes0_1.5.1-2_i386.deb parameterized queries libpq extension - shared library
libpqxx-4.0v5_4.0.1+dfsg3-8_i386.deb C++ library to connect to PostgreSQL
libpqxx-dev_4.0.1+dfsg3-8_i386.deb C++ library to connect to PostgreSQL (development files)
libpqxx-doc_4.0.1+dfsg3-8_all.deb C++ library to connect to PostgreSQL (documentation)
libpqxx3-dev_4.0.1+dfsg3-8_all.deb Transitional dummy package for libpqxx-dev
libpracticalxml-java_1.1.19-1_all.deb practical XML handling routines
libpragmatic-perl_1.7-2_all.deb Adds pragmata to Exporter
libpreferencepanes-dev_1.2.0-2build3_i386.deb GNUstep preferences library - development files
libpreferencepanes1_1.2.0-2build3_i386.deb GNUstep preferences library - runtime library
libprefork-perl_1.04-2_all.deb Module loading for forking or non-forking processes in Perl
libprelude-dev_4.1.0-4_i386.deb Security Information and Events Management system [ Development files ]
libprelude-doc_4.1.0-4_all.deb Security Information and Events Management system [ Documentation ]
libprelude-lua_4.1.0-4_i386.deb Security Information and Events Management system [ Lua bindings ]
Advertisement
Advertisement