libppx-deriving-ocaml_4.1-1.1_i386.deb


Advertisement

Description

libppx-deriving-ocaml - type-driven code generation for OCaml (runtime files)

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libppx-deriving-ocaml
Package version 4.1
Package release 1.1
Package architecture i386
Package type deb
Installed size 6.96 KB
Download size 1.65 MB
Official Mirror archive.ubuntu.com
Ppx_deriving provides common infrastructure for generating code based
on type definitions, and a set of useful plugins for common tasks.
This package contains runtime files.

Alternatives

Package Version Architecture Repository
libppx-deriving-ocaml_4.1-1.1_amd64.deb 4.1 amd64 Ubuntu Universe
libppx-deriving-ocaml - - -

Requires

Name Value
libc6 >= 2.17
libfindlib-ocaml-2vsn1 -
libresult-ocaml-ciso5 -
ocaml-base-nox-4.05.0 -

Provides

Name Value
libppx-deriving-ocaml-dxg83 -

Download

Type URL
Binary Package libppx-deriving-ocaml_4.1-1.1_i386.deb
Source Package ppx-deriving

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libppx-deriving-ocaml deb package:
    # sudo apt-get install libppx-deriving-ocaml

Files

Path
/usr/lib/ocaml/ppx_deriving/META
/usr/lib/ocaml/ppx_deriving/ppx_deriving
/usr/lib/ocaml/ppx_deriving/ppx_deriving.cma
/usr/lib/ocaml/ppx_deriving/ppx_deriving.cmxs
/usr/lib/ocaml/ppx_deriving/ppx_deriving_create.cma
/usr/lib/ocaml/ppx_deriving/ppx_deriving_create.cmxs
/usr/lib/ocaml/ppx_deriving/ppx_deriving_enum.cma
/usr/lib/ocaml/ppx_deriving/ppx_deriving_enum.cmxs
/usr/lib/ocaml/ppx_deriving/ppx_deriving_eq.cma
/usr/lib/ocaml/ppx_deriving/ppx_deriving_eq.cmxs
/usr/lib/ocaml/ppx_deriving/ppx_deriving_fold.cma
/usr/lib/ocaml/ppx_deriving/ppx_deriving_fold.cmxs
/usr/lib/ocaml/ppx_deriving/ppx_deriving_iter.cma
/usr/lib/ocaml/ppx_deriving/ppx_deriving_iter.cmxs
/usr/lib/ocaml/ppx_deriving/ppx_deriving_main.cma
/usr/lib/ocaml/ppx_deriving/ppx_deriving_main.cmxs
/usr/lib/ocaml/ppx_deriving/ppx_deriving_make.cma
/usr/lib/ocaml/ppx_deriving/ppx_deriving_make.cmxs
/usr/lib/ocaml/ppx_deriving/ppx_deriving_map.cma
/usr/lib/ocaml/ppx_deriving/ppx_deriving_map.cmxs
/usr/lib/ocaml/ppx_deriving/ppx_deriving_ord.cma
/usr/lib/ocaml/ppx_deriving/ppx_deriving_ord.cmxs
/usr/lib/ocaml/ppx_deriving/ppx_deriving_runtime.cma
/usr/lib/ocaml/ppx_deriving/ppx_deriving_runtime.cmxs
/usr/lib/ocaml/ppx_deriving/ppx_deriving_show.cma
/usr/lib/ocaml/ppx_deriving/ppx_deriving_show.cmxs
/usr/share/doc/libppx-deriving-ocaml/changelog.Debian.gz
/usr/share/doc/libppx-deriving-ocaml/copyright

Changelog

2017-10-28 - Gianfranco Costamagna <locutusofborg@debian.org>
ppx-deriving (4.1-1.1) unstable; urgency=medium
* Non-maintainer upload
* debian/patches/b6b02c2ba051bde67c2b454724ff0bf36bc11060.patch:
- upstream fix for ocaml build failure (Closes: #876725)
2017-07-21 - Stéphane Glondu <glondu@debian.org>
ppx-deriving (4.1-1) unstable; urgency=medium
* New upstream release
* Add ocamlbuild to Build-Depends
2016-08-05 - Stéphane Glondu <glondu@debian.org>
ppx-deriving (4.0-1) unstable; urgency=medium
* New upstream release
2016-08-04 - Stéphane Glondu <glondu@debian.org>
ppx-deriving (3.3-2) unstable; urgency=medium
* Fix FTBFS on bytecode architectures
* Add versioned dependency for ppx-tools
* Fix debian/watch
2016-07-29 - Stéphane Glondu <glondu@debian.org>
ppx-deriving (3.3-1) unstable; urgency=low
* Initial release (Closes: #832881)

See Also

Package Description
libppx-tools-ocaml-dev_5.0+4.05.0-1_i386.deb tools for authors of OCaml syntactic tools
libppx-visitors-ocaml-dev_20170725-2_i386.deb OCaml syntax extension for object-oriented visitors
libppx-visitors-ocaml-doc_20170725-2_all.deb Documentation of the visitors syntax extension for OCaml
libpqtypes-dev_1.5.1-2_i386.deb parameterized queries libpq extension - development
libpqtypes0_1.5.1-2_i386.deb parameterized queries libpq extension - shared library
libpqxx-4.0v5_4.0.1+dfsg3-8_i386.deb C++ library to connect to PostgreSQL
libpqxx-dev_4.0.1+dfsg3-8_i386.deb C++ library to connect to PostgreSQL (development files)
libpqxx-doc_4.0.1+dfsg3-8_all.deb C++ library to connect to PostgreSQL (documentation)
libpqxx3-dev_4.0.1+dfsg3-8_all.deb Transitional dummy package for libpqxx-dev
libpracticalxml-java_1.1.19-1_all.deb practical XML handling routines
libpragmatic-perl_1.7-2_all.deb Adds pragmata to Exporter
libpreferencepanes-dev_1.2.0-2build3_i386.deb GNUstep preferences library - development files
libpreferencepanes1_1.2.0-2build3_i386.deb GNUstep preferences library - runtime library
libprefork-perl_1.04-2_all.deb Module loading for forking or non-forking processes in Perl
libprelude-dev_4.1.0-4_i386.deb Security Information and Events Management system [ Development files ]
Advertisement
Advertisement