libpostscript-file-perl_2.23+dfsg-1_all.deb


Advertisement

Description

libpostscript-file-perl - module for creating Adobe PostScript files

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libpostscript-file-perl
Package version 2.23+dfsg
Package release 1
Package architecture all
Package type deb
Installed size 317 B
Download size 85.01 KB
Official Mirror archive.ubuntu.com
PostScript::File is a Perl module capable of producing the outline for an
Adobe PostScript file. It provides convenient routines for writing PostScript
directly, and also includes error reporting and debugging facilities. Though
it is designed to be used independently, the functions provided are suitable
for use in other modules.

Alternatives

Package Version Architecture Repository
libpostscript-file-perl_2.23+dfsg-1_all.deb 2.23+dfsg all Ubuntu Universe
libpostscript-file-perl - - -

Requires

Name Value
perl -

Download

Type URL
Binary Package libpostscript-file-perl_2.23+dfsg-1_all.deb
Source Package libpostscript-file-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpostscript-file-perl deb package:
    # sudo apt-get install libpostscript-file-perl

Files

Path
/usr/share/doc/libpostscript-file-perl/changelog.Debian.gz
/usr/share/doc/libpostscript-file-perl/copyright
/usr/share/doc/libpostscript-file-perl/examples/cp1252.pl
/usr/share/doc/libpostscript-file-perl/examples/generate_metrics.pl
/usr/share/doc/libpostscript-file-perl/examples/hello_world.pl
/usr/share/doc/libpostscript-file-perl/examples/iso-8859-1.pl
/usr/share/doc/libpostscript-file-perl/examples/minimal.pl
/usr/share/doc/libpostscript-file-perl/examples/symbol.pl
/usr/share/lintian/overrides/libpostscript-file-perl
/usr/share/man/man3/PostScript::File.3pm.gz
/usr/share/man/man3/PostScript::File::Functions.3pm.gz
/usr/share/man/man3/PostScript::File::Metrics.3pm.gz
/usr/share/man/man3/PostScript::File::Metrics::Loader.3pm.gz
/usr/share/perl5/PostScript/File.pm
/usr/share/perl5/PostScript/File/Functions.pm
/usr/share/perl5/PostScript/File/Metrics.pm
/usr/share/perl5/PostScript/File/Metrics/Loader.pm
/usr/share/perl5/PostScript/File/Metrics/cp1252/Courier.pm
/usr/share/perl5/PostScript/File/Metrics/cp1252/Helvetica.pm
/usr/share/perl5/PostScript/File/Metrics/cp1252/Courier/Bold.pm
/usr/share/perl5/PostScript/File/Metrics/cp1252/Courier/BoldOblique.pm
/usr/share/perl5/PostScript/File/Metrics/cp1252/Courier/Oblique.pm
/usr/share/perl5/PostScript/File/Metrics/cp1252/Helvetica/Bold.pm
/usr/share/perl5/PostScript/File/Metrics/cp1252/Helvetica/BoldOblique.pm
/usr/share/perl5/PostScript/File/Metrics/cp1252/Helvetica/Oblique.pm
/usr/share/perl5/PostScript/File/Metrics/cp1252/Times/Bold.pm
/usr/share/perl5/PostScript/File/Metrics/cp1252/Times/BoldItalic.pm
/usr/share/perl5/PostScript/File/Metrics/cp1252/Times/Italic.pm
/usr/share/perl5/PostScript/File/Metrics/cp1252/Times/Roman.pm
/usr/share/perl5/PostScript/File/Metrics/iso_8859_1/Courier.pm
/usr/share/perl5/PostScript/File/Metrics/iso_8859_1/Helvetica.pm
/usr/share/perl5/PostScript/File/Metrics/iso_8859_1/Courier/Bold.pm
/usr/share/perl5/PostScript/File/Metrics/iso_8859_1/Courier/BoldOblique.pm
/usr/share/perl5/PostScript/File/Metrics/iso_8859_1/Courier/Oblique.pm
/usr/share/perl5/PostScript/File/Metrics/iso_8859_1/Helvetica/Bold.pm
/usr/share/perl5/PostScript/File/Metrics/iso_8859_1/Helvetica/BoldOblique.pm
/usr/share/perl5/PostScript/File/Metrics/iso_8859_1/Helvetica/Oblique.pm
/usr/share/perl5/PostScript/File/Metrics/iso_8859_1/Times/Bold.pm
/usr/share/perl5/PostScript/File/Metrics/iso_8859_1/Times/BoldItalic.pm
/usr/share/perl5/PostScript/File/Metrics/iso_8859_1/Times/Italic.pm
/usr/share/perl5/PostScript/File/Metrics/iso_8859_1/Times/Roman.pm
/usr/share/perl5/PostScript/File/Metrics/std/Courier.pm
/usr/share/perl5/PostScript/File/Metrics/std/Helvetica.pm
/usr/share/perl5/PostScript/File/Metrics/std/Courier/Bold.pm
/usr/share/perl5/PostScript/File/Metrics/std/Courier/BoldOblique.pm
/usr/share/perl5/PostScript/File/Metrics/std/Courier/Oblique.pm
/usr/share/perl5/PostScript/File/Metrics/std/Helvetica/Bold.pm
/usr/share/perl5/PostScript/File/Metrics/std/Helvetica/BoldOblique.pm
/usr/share/perl5/PostScript/File/Metrics/std/Helvetica/Oblique.pm
/usr/share/perl5/PostScript/File/Metrics/std/Times/Bold.pm
/usr/share/perl5/PostScript/File/Metrics/std/Times/BoldItalic.pm
/usr/share/perl5/PostScript/File/Metrics/std/Times/Italic.pm
/usr/share/perl5/PostScript/File/Metrics/std/Times/Roman.pm
/usr/share/perl5/PostScript/File/Metrics/sym/Symbol.pm

Changelog

2018-01-01 - Damyan Ivanov <dmn@debian.org>
libpostscript-file-perl (2.23+dfsg-1) unstable; urgency=medium
[ Florian Schlichting ]
* Import upstream version 2.23+dfsg
* Drop fix-pod-spelling.patch, applied upstream
[ Salvatore Bonaccorso ]
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
[ gregor herrmann ]
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
* debian/upstream/metadata: use HTTPS for GitHub URLs.
[ intrigeri ]
* Switch repackaging framework to Files-Excluded method.
[ gregor herrmann ]
* Remove Chris Butler from Uploaders. Thanks for your work!
* Remove Jonathan Yu from Uploaders. Thanks for your work!
[ Damyan Ivanov ]
* fix options quoting in d/watch that made lintian miss the version mangling
* add pod-spelling.patch fixing another batch of spelling mistakes
* declare conformance with Policy 4.1.3 (no changes needed)
2015-10-09 - Florian Schlichting <fsfs@debian.org>
libpostscript-file-perl (2.22+dfsg-1) unstable; urgency=low
* Team upload
[ gregor herrmann ]
* debian/control: update {versioned,alternative} (build) dependencies.
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ gregor herrmann ]
* Update debian/repack.stub.
[ Axel Beckert ]
* debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg-
copyright"
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ Florian Schlichting ]
* Add upstream metadata
* Import new upstream version 2.22+dfsg
* Bump years of upstream copyright
* Forward fix-pod-spelling.patch
* Bump dh compat to level 9
* Declare compliance with Debian Policy 3.9.6
* Mark package autopkgtest-able
* Do not separate files with comma in d/copyright
2012-02-12 - gregor herrmann <gregoa@debian.org>
libpostscript-file-perl (2.20+dfsg-1) unstable; urgency=low
* New upstream release.
* Refresh fix-pod-spelling.patch.
* Update years of upstream and packaging copyright.
* Add libfont-afm-perl to Suggests.
2011-10-16 - gregor herrmann <gregoa@debian.org>
libpostscript-file-perl (2.11+dfsg-1) unstable; urgency=low
[ Salvatore Bonaccorso ]
* debian/copyright: Replace DEP5 Format-Specification URL from
svn.debian.org to anonscm.debian.org URL.
[ gregor herrmann ]
* New upstream release.
* Bump debhelper compatibility level to 8.
* debian/copyright: update debian/* section.
2011-07-29 - Chris Butler <chrisb@debian.org>
libpostscript-file-perl (2.10+dfsg-1) unstable; urgency=low
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Chris Butler ]
* New upstream release
* Refreshed fix-pod-spelling.patch
* Updated years of upstream copyright
* Add myself to Uploaders
* Updated to Standards-Version 3.9.2 (no changes required)
2010-12-27 - Jonathan Yu <jawnsy@cpan.org>
libpostscript-file-perl (2.02+dfsg-1) unstable; urgency=low
[ Jonathan Yu ]
* New upstream release 2.00, 2.02
* Standards-Version 3.9.1 (no changes)
* Use new 3.0 (quilt) source format
* No longer run author RELEASE_TESTING tests
* Add patch to fix POD spelling errors
* Add lintian override to supress errors about re-encode being
misspelled without the hyphen (it is a function name)
* Refresh copyright information
* Add repacking script to remove non-free fonts and corresponding
example file
[ gregor herrmann ]
* New upstream release 2.01.
* debian/copyright: update upstream copyright info.
* Add /me to Uploaders.
2009-10-29 - Jonathan Yu <jawnsy@cpan.org>
libpostscript-file-perl (1.05-1) unstable; urgency=low
[ Jonathan Yu ]
* New upstream release
* Install examples now provided from upstream
[ gregor herrmann ]
* debian/copyright: add info about examples.

See Also

Package Description
libpostscript-perl_0.06-2_all.deb Perl module to generate PostScript code
libpostscript-simple-perl_0.09-1_all.deb Perl library for generating postscript files
libpostscriptbarcode_20140312-2_all.deb Barcode Writer in Pure PostScript
libpotemkin-clojure_0.4.3-2_all.deb collection of facades and workarounds for Clojure
libpowercap-dev_0.1.1-1_i386.deb Development files for libpowercap
libpowercap0_0.1.1-1_i386.deb Shared library for accessing the powercap Linux kernel feature
libpowerdevilcore2_5.12.4-0ubuntu1_i386.deb Global power saver settings ui library
libpowerdevilui5_5.12.4-0ubuntu1_i386.deb Global power saver settings ui library
libpowerman0-dev_2.3.5-1build1_i386.deb Development files for Powerman - Centralized PDU management
libpowerman0_2.3.5-1build1_i386.deb Client library for Powerman - Centralized PDU management
libpowermock-java_1.6.6-1_all.deb PowerMock testing framework for Java
libppd-dev_0.10-7.3_i386.deb postscript PPD file library, development kit
libppd0_0.10-7.3_i386.deb postscript PPD file library
libppi-html-perl_1.08-1_all.deb module to highlight Perl code using PPI
libppi-perl_1.236-1_all.deb module to parse, analyze and manipulate Perl code
Advertisement
Advertisement