libpoe-test-loops-perl_1.360-1ubuntu2_all.deb


Advertisement

Description

libpoe-test-loops-perl - test framework for POE event loops

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libpoe-test-loops-perl
Package version 1.360
Package release 1ubuntu2
Package architecture all
Package type deb
Installed size 278 B
Download size 57.70 KB
Official Mirror archive.ubuntu.com
POE::Test::Loops is a Perl helper module that provides a framework for testing
the functionality of POE event loops. It contains a single function that sets
up all the loop tests for one or more POE::Loop subclasses. It is most useful
during development and building of POE event loops.

Alternatives

Package Version Architecture Repository
libpoe-test-loops-perl_1.360-1ubuntu2_all.deb 1.360 all Ubuntu Universe
libpoe-test-loops-perl - - -

Requires

Name Value
perl -

Download

Type URL
Binary Package libpoe-test-loops-perl_1.360-1ubuntu2_all.deb
Source Package libpoe-test-loops-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpoe-test-loops-perl deb package:
    # sudo apt-get install libpoe-test-loops-perl

Files

Path
/usr/bin/poe-gen-tests
/usr/share/doc/libpoe-test-loops-perl/changelog.Debian.gz
/usr/share/doc/libpoe-test-loops-perl/copyright
/usr/share/man/man1/poe-gen-tests.1p.gz
/usr/share/man/man3/POE::Test::Loops.3pm.gz
/usr/share/perl5/POE/Test/DondeEstan.pm
/usr/share/perl5/POE/Test/Loops.pm
/usr/share/perl5/POE/Test/Loops/00_info.pm
/usr/share/perl5/POE/Test/Loops/all_errors.pm
/usr/share/perl5/POE/Test/Loops/comp_tcp.pm
/usr/share/perl5/POE/Test/Loops/comp_tcp_concurrent.pm
/usr/share/perl5/POE/Test/Loops/connect_errors.pm
/usr/share/perl5/POE/Test/Loops/k_alarms.pm
/usr/share/perl5/POE/Test/Loops/k_aliases.pm
/usr/share/perl5/POE/Test/Loops/k_detach.pm
/usr/share/perl5/POE/Test/Loops/k_run_returns.pm
/usr/share/perl5/POE/Test/Loops/k_selects.pm
/usr/share/perl5/POE/Test/Loops/k_sig_child.pm
/usr/share/perl5/POE/Test/Loops/k_signals.pm
/usr/share/perl5/POE/Test/Loops/k_signals_rerun.pm
/usr/share/perl5/POE/Test/Loops/sbk_signal_init.pm
/usr/share/perl5/POE/Test/Loops/ses_nfa.pm
/usr/share/perl5/POE/Test/Loops/ses_session.pm
/usr/share/perl5/POE/Test/Loops/wheel_accept.pm
/usr/share/perl5/POE/Test/Loops/wheel_curses.pm
/usr/share/perl5/POE/Test/Loops/wheel_readline.pm
/usr/share/perl5/POE/Test/Loops/wheel_readwrite.pm
/usr/share/perl5/POE/Test/Loops/wheel_run.pm
/usr/share/perl5/POE/Test/Loops/wheel_run_size.pm
/usr/share/perl5/POE/Test/Loops/wheel_sf_ipv6.pm
/usr/share/perl5/POE/Test/Loops/wheel_sf_tcp.pm
/usr/share/perl5/POE/Test/Loops/wheel_sf_udp.pm
/usr/share/perl5/POE/Test/Loops/wheel_sf_unix.pm
/usr/share/perl5/POE/Test/Loops/wheel_tail.pm
/usr/share/perl5/POE/Test/Loops/z_kogman_sig_order.pm
/usr/share/perl5/POE/Test/Loops/z_leolo_wheel_run.pm
/usr/share/perl5/POE/Test/Loops/z_merijn_sigchld_system.pm
/usr/share/perl5/POE/Test/Loops/z_rt39872_sigchld.pm
/usr/share/perl5/POE/Test/Loops/z_rt39872_sigchld_stop.pm
/usr/share/perl5/POE/Test/Loops/z_rt53302_fh_watchers.pm
/usr/share/perl5/POE/Test/Loops/z_rt54319_bazerka_followtail.pm
/usr/share/perl5/POE/Test/Loops/z_steinert_signal_integrity.pm

Changelog

2015-12-28 - Colin Watson <cjwatson@ubuntu.com>
libpoe-test-loops-perl (1.360-1ubuntu2) xenial; urgency=medium
* Remove stray copied-and-pasted libdbi-perl from debian/tests/control.
2015-12-28 - Colin Watson <cjwatson@ubuntu.com>
libpoe-test-loops-perl (1.360-1ubuntu1) xenial; urgency=medium
* Depend on libpoe-perl for runtime-deps-and-recommends autopkgtest; this
is also covered by needs-recommends, but an explicit dependency forces
autopkgtest not to drop it during Perl transitions due to pinning only
necessary packages from -proposed.
2015-05-16 - gregor herrmann <gregoa@debian.org>
libpoe-test-loops-perl (1.360-1) unstable; urgency=medium
* Import upstream version 1.360
* Update years of packaging copyright.
* Update Test::More build dependency.
2014-10-14 - gregor herrmann <gregoa@debian.org>
libpoe-test-loops-perl (1.359-1) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ gregor herrmann ]
* Add debian/upstream/metadata
* Import upstream version 1.359
* Mark package as autopkgtest-able.
* Declare compliance with Debian Policy 3.9.6.
2014-07-19 - gregor herrmann <gregoa@debian.org>
libpoe-test-loops-perl (1.358-1) unstable; urgency=medium
* New upstream release.
2014-07-12 - gregor herrmann <gregoa@debian.org>
libpoe-test-loops-perl (1.357-1) unstable; urgency=medium
* New upstream release.
* Update years of packaging copyright.
2014-07-10 - Florian Schlichting <fsfs@debian.org>
libpoe-test-loops-perl (1.355-1) unstable; urgency=low
[ gregor herrmann ]
* debian/control: remove Nicholas Bamber from Uploaders on request of
the MIA team.
* Strip trailing slash from metacpan URLs.
[ Florian Schlichting ]
* Import Upstream version 1.354, 1.355
* Bump copyright years
* Declare compliance with Debian Policy 3.9.5
2013-10-01 - Florian Schlichting <fsfs@debian.org>
libpoe-test-loops-perl (1.353-1) unstable; urgency=low
[ gregor herrmann ]
* debian/control: update {versioned,alternative} (build) dependencies.
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Florian Schlichting ]
* Import Upstream version 1.353
* Update years of upstream copyright
* Declare compliance with Debian Policy 3.9.4
* Add myself to uploaders and copyright
2012-03-19 - gregor herrmann <gregoa@debian.org>
libpoe-test-loops-perl (1.351-1) unstable; urgency=low
* New upstream release.
* Update years of upstream and packaging copyright.
* debian/copyright: update to Copyright-Format 1.0.
* Bump Standards-Version to 3.9.3 (no changes).
2011-12-17 - Alessandro Ghedini <al3xbio@gmail.com>
libpoe-test-loops-perl (1.350-1) unstable; urgency=low
* Team upload
* New upstream release

See Also

Package Description
libpoet-perl_0.16-1_all.deb modern Perl web framework for Mason developers
libpolkit-qt-1-1_0.112.0-5_i386.deb PolicyKit-qt-1 library
libpolkit-qt-1-dev_0.112.0-5_i386.deb PolicyKit-qt-1 development files
libpolkit-qt5-1-1_0.112.0-5_i386.deb PolicyKit-qt5-1 library
libpolkit-qt5-1-dev_0.112.0-5_i386.deb PolicyKit-qt5-1 development files
libpolled-camera-dev_1.11.11-3_i386.deb Robot OS polled_camera package - development
libpolled-camera0d_1.11.11-3_i386.deb Robot OS polled_camera package
libpolyclipping-dev_6.4.2-3_i386.deb polygon clipping, polygon offsetting and polyline offsetting library
libpolyclipping22_6.4.2-3_i386.deb polygon clipping, polygon offsetting and polyline offsetting library
libpolyglot-maven-java-doc_0.8~tobrien+git20120905-9_all.deb modules to enable Maven usage in others JVM languages - docs
libpolyglot-maven-java_0.8~tobrien+git20120905-9_all.deb modules to enable Maven usage in others JVM languages
libpolylib64-8_5.22.5-4+dfsg_i386.deb Polyhedral library - long int version
libpolylib64-dev_5.22.5-4+dfsg_i386.deb Development files for the long int version of PolyLib
libpolymake-dev-common_3.2r2-3_all.deb Tool for algorithmic discrete geometry -- common dev package
libpolymake-dev_3.2r2-3_i386.deb Tool for algorithmic discrete geometry -- development package
Advertisement
Advertisement