libpoe-filter-ssl-perl_0.41-1_i386.deb


Advertisement

Description

libpoe-filter-ssl-perl - module to make SSL in POE easy and flexible

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libpoe-filter-ssl-perl
Package version 0.41
Package release 1
Package architecture i386
Package type deb
Installed size 98 B
Download size 29.36 KB
Official Mirror archive.ubuntu.com
POE::Filter::SSL allows one to secure connections of POE::Wheel::ReadWrite
with OpenSSL by a POE::Filter object, and behaves (beside of SSLing) as
POE::Filter::Stream.
POE::Filter::SSL can be added, switched and removed during runtime, for
example if you want to initiate SSL (see the SSL on an established
connection example in SYNOPSIS) on an already established connection. You
are able to combine POE::Filter::SSL with other filters, for example have
a HTTPS server together with POE::Filter::HTTPD.
POE::Filter::SSL is based on Net::SSLeay, but got two XS functions which
Net::SSLeay is missing.

Alternatives

Package Version Architecture Repository
libpoe-filter-ssl-perl_0.41-1_amd64.deb 0.41 amd64 Ubuntu Universe
libpoe-filter-ssl-perl - - -

Requires

Name Value
libc6 >= 2.4
libhttp-message-perl -
libnet-ssleay-perl >= 1.65
libpoe-perl -
libssl1.1 >= 1.1.0
perl >= 5.26.1-4build1
perlapi-5.26.1 -

Download

Type URL
Binary Package libpoe-filter-ssl-perl_0.41-1_i386.deb
Source Package libpoe-filter-ssl-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpoe-filter-ssl-perl deb package:
    # sudo apt-get install libpoe-filter-ssl-perl

Files

Path
/usr/lib/i386-linux-gnu/perl5/5.26/POE/Filter/SSL.pm
/usr/lib/i386-linux-gnu/perl5/5.26/POE/Filter/SSL/PreFilter.pm
/usr/lib/i386-linux-gnu/perl5/5.26/auto/POE/Filter/SSL/SSL.so
/usr/share/doc/libpoe-filter-ssl-perl/changelog.Debian.gz
/usr/share/doc/libpoe-filter-ssl-perl/copyright
/usr/share/man/man3/POE::Filter::SSL.3pm.gz
/usr/share/man/man3/POE::Filter::SSL::PreFilter.3pm.gz

Changelog

2018-02-19 - gregor herrmann <gregoa@debian.org>
libpoe-filter-ssl-perl (0.41-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* Add patches to fix spelling and POD errors.
2018-01-13 - gregor herrmann <gregoa@debian.org>
libpoe-filter-ssl-perl (0.39-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* Drop 0001-fixing-typos-in-manpage.patch, applied upstream.
2017-12-30 - gregor herrmann <gregoa@debian.org>
libpoe-filter-ssl-perl (0.38-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* Refresh 0001-fixing-typos-in-manpage.patch (offset).
* Declare compliance with Debian Policy 4.1.3.
* Bump debhelper compatibility level to 10.
2017-11-20 - gregor herrmann <gregoa@debian.org>
libpoe-filter-ssl-perl (0.37-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* Update 0001-fixing-typos-in-manpage.patch.
* Update years of upstream copyright.
* Make (build) dependency on libnet-ssleay-perl versioned.
* Declare compliance with Debian Policy 4.1.1.
* Removing trailing whitespace in debian/control.
Thanks to pedantic lintian.
2017-06-30 - gregor herrmann <gregoa@debian.org>
libpoe-filter-ssl-perl (0.31-1) unstable; urgency=medium
* Team upload.
* Import upstream version 0.31.
* Drop add-openssl-1.1.0-support.patch, applied upstream.
* Declare compliance with Debian Policy 4.0.0.
2016-12-14 - gregor herrmann <gregoa@debian.org>
libpoe-filter-ssl-perl (0.30-3) unstable; urgency=medium
* Team upload.
* Update previous changelog entry: #828408 was not closed by this upload.
* Add patch to add support for OpenSSL 1.1.0.
Thanks to Sebastian Andrzej Siewior for the patch. (Closes: #828408)
* debian/control: build-depend on libssl-dev instead of the
1.0 variants.
2016-11-12 - gregor herrmann <gregoa@debian.org>
libpoe-filter-ssl-perl (0.30-2) unstable; urgency=medium
* Team upload.
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
* Use OpenSSL 1.0.2 for the time being. (cf. #828408)
* Add one more fix to 0001-fixing-typos-in-manpage.patch.
2016-04-10 - Lucas Kanashiro <kanashiro.duarte@gmail.com>
libpoe-filter-ssl-perl (0.30-1) unstable; urgency=medium
* Import upstream version 0.30
* Drop patch fixing typos in manpage, already applied by upstream
* Update upstream copyright
* Update years of Debian packaging copyright
* Declare compliance with Debian policy 3.9.8
* debian/control: add Vcs-{Browser,Git}
* debian/rules: export DEB_BUILD_MAINT_OPTIONS = hardening=+bindnow
* Create patch to fix typos in manpage
2015-08-28 - Lucas Kanashiro <kanashiro.duarte@gmail.com>
libpoe-filter-ssl-perl (0.28-1) unstable; urgency=medium
* Imported Upstream version 0.28
* Remove fix-pod.patch. Already applied by upstream.
* Refresh fix-spelling-errors.patch
* Update year of upstream copyright
2015-08-18 - Lucas Kanashiro <kanashiro.duarte@gmail.com>
libpoe-filter-ssl-perl (0.27-1) unstable; urgency=low
* Initial Release. (Closes: #795951)

See Also

Package Description
libpoe-filter-stomp-perl_0.04-2_all.deb Perl extension for the POE Environment to provide a Stomp filter
libpoe-filter-xml-perl_1.140700-1_all.deb POE Filter for parsing XML
libpoe-loop-event-perl_1.305-1_all.deb POE event loop implementation using Event
libpoe-loop-tk-perl_1.305-1_all.deb POE event loop implementation using Tk
libpoe-perl_1.3670-2_all.deb event-driven component architecture for Perl
libpoe-test-loops-perl_1.360-1ubuntu2_all.deb test framework for POE event loops
libpoet-perl_0.16-1_all.deb modern Perl web framework for Mason developers
libpolkit-qt-1-1_0.112.0-5_i386.deb PolicyKit-qt-1 library
libpolkit-qt-1-dev_0.112.0-5_i386.deb PolicyKit-qt-1 development files
libpolkit-qt5-1-1_0.112.0-5_i386.deb PolicyKit-qt5-1 library
libpolkit-qt5-1-dev_0.112.0-5_i386.deb PolicyKit-qt5-1 development files
libpolled-camera-dev_1.11.11-3_i386.deb Robot OS polled_camera package - development
libpolled-camera0d_1.11.11-3_i386.deb Robot OS polled_camera package
libpolyclipping-dev_6.4.2-3_i386.deb polygon clipping, polygon offsetting and polyline offsetting library
libpolyclipping22_6.4.2-3_i386.deb polygon clipping, polygon offsetting and polyline offsetting library
Advertisement
Advertisement