libpod-strip-perl_1.02-2_all.deb


Advertisement

Description

libpod-strip-perl - remove POD documentation from Perl code

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libpod-strip-perl
Package version 1.02
Package release 2
Package architecture all
Package type deb
Installed size 47 B
Download size 6.10 KB
Official Mirror archive.ubuntu.com
Pod::Strip is a subclass of Pod::Simple that removes the POD (plain old
documentation) from Perl code. The POD may optionally be replaced with
comments so that line numbers of the code stay the same.
Pod::Strip is useful in Perl code parsers that don't want to bother about POD.

Alternatives

Package Version Architecture Repository
libpod-strip-perl_1.02-2_all.deb 1.02 all Ubuntu Universe
libpod-strip-perl - - -

Requires

Name Value
perl -

Download

Type URL
Binary Package libpod-strip-perl_1.02-2_all.deb
Source Package libpod-strip-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpod-strip-perl deb package:
    # sudo apt-get install libpod-strip-perl

Files

Path
/usr/share/doc/libpod-strip-perl/changelog.Debian.gz
/usr/share/doc/libpod-strip-perl/copyright
/usr/share/man/man3/Pod::Strip.3pm.gz
/usr/share/perl5/Pod/Strip.pm

Changelog

2015-06-08 - Damyan Ivanov <dmn@debian.org>
libpod-strip-perl (1.02-2) unstable; urgency=low
[ gregor herrmann ]
* debian/control: Changed: Switched Vcs-Browser field to ViewSVN
(source stanza).
[ Nathan Handler ]
* debian/watch: Update to ignore development releases.
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ gregor herrmann ]
* debian/control: update {versioned,alternative} (build) dependencies.
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Axel Beckert ]
* debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg-
copyright"
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ Damyan Ivanov ]
* Mark package as autopkgtest-able
* Declare compliance with Debian Policy 3.9.6
* Switch to source format "3.0 (quilt)"
* Add explicit build dependency on libmodule-build-perl
* bump debhelper compatibility level to 8
* remove perl from B-D-I as it is already in B-D
* add lib/Pod/Strip.pm to the list of files needed for autopkgtest
* copyright: point to GPL-1 for "GPL version 1 or later"
* rules: adopt 3-line dh style
* copyright: move license application text to X-Note
2008-08-14 - Damyan Ivanov <dmn@debian.org>
libpod-strip-perl (1.02-1) unstable; urgency=low
* Initial Release. Closes: #495020 -- ITP

See Also

Package Description
libpod-tests-perl_1.19-4_all.deb Perl extension for excts embedded tests and code examples from POD
libpod-tree-perl_1.25-1_all.deb module for creating a static syntax tree for a POD
libpod-weaver-perl_4.015-1_all.deb Perl module to weave together a Pod document from an outline
libpod-weaver-plugin-ensureuniquesections-perl_0.163250-1_all.deb Pod::Weaver plugin to check for duplicate Pod section headers
libpod-weaver-section-contributors-perl_0.009-1_all.deb Pod::Weaver plugin for a section listing contributors
libpod-weaver-section-generatesection-perl_1.06-1_all.deb Pod::Weaver plugin to add Pod sections from a template text
libpod-weaver-section-legal-complicated-perl_1.22-1_all.deb Pod::Weaver plugin for per module authors, copyright holders, and license
libpod-weaver-section-support-perl_1.008-1_all.deb Dist::Zilla plugin to add a SUPPORT section to your POD
libpod-webserver-perl_3.11-1_all.deb miniature web server for reading Pod in web browsers
libpod-wordlist-hanekomu-perl_1.132680-2_all.deb collection of stop words to spell check POD documents
libpod-wsdl-perl_0.063-1_all.deb creator of WSDL documents from (extended) POD
libpod-xhtml-perl_1.61-2_all.deb module for translating POD to XHTML
libpod2-base-perl_0.043-1_all.deb module for translations of Perl documentation
libpodofo-dev_0.9.5-9_i386.deb PoDoFo development files
libpodofo-utils_0.9.5-9_i386.deb PoDoFo utilities
Advertisement
Advertisement