libpmi2-pmix_2.1.1~rc1-1_i386.deb


Advertisement

Description

libpmi2-pmix - OpenMPI implementation of the PMI v2 library

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libpmi2-pmix
Package version 2.1.1~rc1
Package release 1
Package architecture i386
Package type deb
Installed size 741 B
Download size 229.99 KB
Official Mirror archive.ubuntu.com
This is the OpenMPI implementation of the Process Management Interface (PMI)
API, v2.

Alternatives

Package Version Architecture Repository
libpmi2-pmix_2.1.1~rc1-1_amd64.deb 2.1.1~rc1 amd64 Ubuntu Universe
libpmi2-pmix - - -

Requires

Name Value
libc6 >= 2.15
libevent-2.1-6 >= 2.1.8-stable
libevent-pthreads-2.1-6 >= 2.1.8-stable
libhwloc-plugins -
zlib1g >= 1:1.2.0

Replaces

Name Value
libpmix2 << 2.1.0~rc1-2

Download

Type URL
Binary Package libpmi2-pmix_2.1.1~rc1-1_i386.deb
Source Package pmix

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpmi2-pmix deb package:
    # sudo apt-get install libpmi2-pmix

Files

Path
/usr/lib/i386-linux-gnu/libpmi2.so.1
/usr/lib/i386-linux-gnu/libpmi2.so.1.0.0
/usr/lib/i386-linux-gnu/pmix/lib/libpmi2.so.1
/usr/lib/i386-linux-gnu/pmix/lib/libpmi2.so.1.0.0
/usr/share/doc/libpmi2-pmix/changelog.Debian.gz
/usr/share/doc/libpmi2-pmix/copyright

Changelog

2018-02-24 - Alastair McKinstry <mckinstry@debian.org>
pmix (2.1.1~rc1-1) unstable; urgency=medium
* New upstream release
2018-02-03 - Alastair McKinstry <mckinstry@debian.org>
pmix (2.1.0-2) unstable; urgency=medium
* Build static libs -fPIC. Needed for openmpi
2018-02-03 - Alastair McKinstry <mckinstry@debian.org>
pmix (2.1.0-1) unstable; urgency=medium
* New upstream release
* Point VCS -Git, browser in d/control to salsa.debian.org
* Correct copy-paste error in description. Closes: #882846
* Build static libs -fPIC
2018-01-04 - Alastair McKinstry <mckinstry@debian.org>
pmix (2.1.0~rc1-3) unstable; urgency=medium
* Standards-Version: 4.1.3. No changes required
* Now use debhelper 11
* Set Vcs-Git in debian/control
* Put components in /usr/lib/$(triplet)/pmix where they will be found,
not a subdir. See pmix issue 628
* flex now needed to build
2017-11-25 - Alastair McKinstry <mckinstry@debian.org>
pmix (2.1.0~rc1-2) unstable; urgency=medium
* Move pmix to /usr/lib/$multiarch/pmix/{lib,include} and split libpmi{1,2}
libraries to co-exist with SLURM, MPICH implementations.
Closes: # 882033
* FTBFS on Hurd: add patch for MAXPATHLEN. Closes: #881952
2017-11-17 - Alastair McKinstry <mckinstry@debian.org>
pmix (2.1.0~rc1-1) unstable; urgency=medium
* New upstream release
* Standards-Version: 4.1.1
* Set libpmix-dev as Multi-Arch: same
* Add patch for FTBFS on Hurd: #811952
* Add watch file
2017-09-18 - Alastair McKinstry <mckinstry@debian.org>
pmix (2.0.1-1) unstable; urgency=medium
* Initial release. (Closes: #809345)

See Also

Package Description
libpmix-dev_2.1.1~rc1-1_i386.deb Development files for the PMI Exascale library
libpmix2_2.1.1~rc1-1_i386.deb Process Management Interface (Exascale) library
libpmount-dev_0.0.17-3_i386.deb portable mount library - development files
libpmount0_0.0.17-3_i386.deb portable mount library - shared library
libpng++-dev_0.2.9-1_all.deb C++ interface to the PNG (Portable Network Graphics) library
libpng-sixlegs-java-doc_2.0-1_all.deb Documentation for Sixlegs Java PNG Decoder
libpng-sixlegs-java_2.0-1_all.deb Sixlegs Java PNG Decoder
libpnglite-dev_0.1.17-2_i386.deb lightweight C library for loading and writing PNG images
libpnglite0_0.1.17-2_i386.deb lightweight C library for loading and writing PNG images
libpocketsphinx-dev_0.8.0+real5prealpha-1ubuntu2_i386.deb Speech recognition tool - front-end library development files
libpocketsphinx3_0.8.0+real5prealpha-1ubuntu2_i386.deb Speech recognition tool - front-end library
libpocl-dev_1.1-5_i386.deb development files for the pocl library
libpocl2-common_1.1-5_all.deb common files for the pocl library
libpocl2_1.1-5_i386.deb Portable Computing Language library
libpoco-dev_1.8.0.1-1ubuntu4_i386.deb C++ Portable Components (POCO) Development files
Advertisement
Advertisement