libpll-dev_0.3.1-1_i386.deb


Advertisement

Description

libpll-dev - Phylogenetic Likelihood Library (development)

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libpll-dev
Package version 0.3.1
Package release 1
Package architecture i386
Package type deb
Installed size 620 B
Download size 173.59 KB
Official Mirror archive.ubuntu.com
PLL is a highly optimized, parallelized software library to ease the
development of new software tools dealing with phylogenetic inference.
Among the functions included in PLL are parsing multiple sequence
alignments (MSA) from PHYLIP and FASTA files, reading Newick trees,
performing topological moves such as SPR and NNI, model optimization,
likelihood evaluation and partitioned analysis by assigning different
substitution models to each partition of the MSA. PLL fully implements
the GTR nucleotide substitution model for DNA data and a number of
models for aminoacid data.
This package contains the static library and the header file.

Alternatives

Package Version Architecture Repository
libpll-dev_0.3.1-1_amd64.deb 0.3.1 amd64 Ubuntu Universe
libpll-dev - - -

Requires

Name Value
libpll0 = 0.3.1-1

Download

Type URL
Binary Package libpll-dev_0.3.1-1_i386.deb
Source Package libpll

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpll-dev deb package:
    # sudo apt-get install libpll-dev

Files

Path
/usr/include/libpll/pll.h
/usr/lib/i386-linux-gnu/libpll.a
/usr/lib/i386-linux-gnu/libpll.so
/usr/share/doc/libpll-dev/changelog.Debian.gz
/usr/share/doc/libpll-dev/copyright

Changelog

2017-05-17 - Andreas Tille <tille@debian.org>
libpll (0.3.1-1) unstable; urgency=medium
* new upstream version incorporating all patches
* remove unneeded debian/get-orig-source
2017-05-16 - Andreas Tille <tille@debian.org>
libpll (0.3.0-3) unstable; urgency=medium
* add overrides to d-shlibmove
2017-05-16 - Andreas Tille <tille@debian.org>
libpll (0.3.0-2) unstable; urgency=medium
[ James Cowgill ]
* only tries to detect x86 features on x86
* detects altivec properly
* uses GCC's __builtin_cpu_supports which is nicer than cpuid
* compiles with --disable-* on all arches except x86
* enables arch specific code on x86 (there is proper runtime detection now)
* uses debhelper 10 to avoid manual autogen
* includes architecture.mk which is required before using DEB_HOST_*
2017-05-15 - Andreas Tille <tille@debian.org>
libpll (0.3.0-1) unstable; urgency=medium
* Check for HAVE_X86INTRIN_H
Closes: #861754
* New upstream version uses runtime detection and thus does not use AVX and
SSE on i386 and other architectures
Closes: #861755
2017-05-03 - Andreas Tille <tille@debian.org>
libpll (0.0+20160909+ds1-1) unstable; urgency=medium
* Remove m4/ files which can be found in package autoconf-archive
2017-04-30 - Andreas Tille <tille@debian.org>
libpll (0.0+20160909-1) unstable; urgency=low
* Initial release (Closes: #861529)

See Also

Package Description
libpll0_0.3.1-1_i386.deb Phylogenetic Likelihood Library
libploop-dev_1.15-5_i386.deb ploop API development library
libploop1_1.15-5_i386.deb ploop API library
libplot-dev_2.6-9_i386.deb GNU plotutils libraries (development files)
libplot2c2_2.6-9_i386.deb GNU plotutils libraries
libploticus0-dev_2.42-4_i386.deb Development files for the ploticus library
libploticus0_2.42-4_i386.deb script driven business graphics library
libplplot-ada-dev_5.13.0+dfsg-6ubuntu2_i386.deb Ada support for PLplot, a plotting library (development files)
libplplot-dev_5.13.0+dfsg-6ubuntu2_i386.deb Scientific plotting library (development files)
libplplot-java_5.13.0+dfsg-6ubuntu2_i386.deb Scientific plotting library (Java bindings)
libplplot-lua_5.13.0+dfsg-6ubuntu2_i386.deb Scientific plotting library (Lua bindings)
libplplot-ocaml-dev_5.13.0+dfsg-6ubuntu2_i386.deb OCaml support for the PLplot plotting library (development files)
libplplot-ocaml_5.13.0+dfsg-6ubuntu2_i386.deb OCaml bindings for the scientific plotting library
libplplot15_5.13.0+dfsg-6ubuntu2_i386.deb Scientific plotting library
libplplotada2_5.13.0+dfsg-6ubuntu2_i386.deb Ada support for PLplot, a plotting library
Advertisement
Advertisement