libplexus-cipher-java_1.7-3_all.deb


Advertisement

Description

libplexus-cipher-java - Plexus Cipher Component used by Maven

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libplexus-cipher-java
Package version 1.7
Package release 3
Package architecture all
Package type deb
Installed size 38 B
Download size 14.70 KB
Official Mirror archive.ubuntu.com
The Plexus project provides a full software stack for creating and
executing software projects. Based on the Plexus container, the applications
can utilise component-oriented programming to build modular, reusable
components that can easily be assembled and reused.
This package provides a cipher component for Plexus.

Alternatives

Package Version Architecture Repository
libplexus-cipher-java_1.7-3_all.deb 1.7 all Ubuntu Universe
libplexus-cipher-java - - -

Download

Type URL
Binary Package libplexus-cipher-java_1.7-3_all.deb
Source Package plexus-cipher

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libplexus-cipher-java deb package:
    # sudo apt-get install libplexus-cipher-java

Files

Path
/usr/share/doc/libplexus-cipher-java/changelog.Debian.gz
/usr/share/doc/libplexus-cipher-java/copyright
/usr/share/java/plexus-cipher-1.7.jar
/usr/share/java/plexus-cipher.jar
/usr/share/maven-repo/org/sonatype/plexus/plexus-cipher/1.7/plexus-cipher-1.7.jar
/usr/share/maven-repo/org/sonatype/plexus/plexus-cipher/1.7/plexus-cipher-1.7.pom
/usr/share/maven-repo/org/sonatype/plexus/plexus-cipher/debian/plexus-cipher-debian.jar
/usr/share/maven-repo/org/sonatype/plexus/plexus-cipher/debian/plexus-cipher-debian.pom

Changelog

2017-08-03 - Emmanuel Bourg <ebourg@apache.org>
plexus-cipher (1.7-3) unstable; urgency=medium
* Team upload.
* Depend on libplexus-container-default1.5-java
instead of libplexus-container-default-java
* Removed the unused build dependency on libplexus-maven-plugin-java
* Removed the unused build dependency on junit
2017-07-24 - Emmanuel Bourg <ebourg@apache.org>
plexus-cipher (1.7-2) unstable; urgency=medium
* Team upload.
* Fixed the scope of the junit dependency in the pom
* Build with the DH sequencer instead of CDBS
* Standards-Version updated to 4.0.0
* Switch to debhelper level 10
* Use secure Vcs-* URLs
2015-07-09 - Emmanuel Bourg <ebourg@apache.org>
plexus-cipher (1.7-1) unstable; urgency=low
* Team upload.
* New upstream release
- Refreshed the patch
- Added a build dependency on libsisu-maven-plugin-java
* debian/control:
- Use canonical URLs for the Vcs-* fields
- Standard-Version updated to 3.9.6 (no changes)
* debian/watch: Updated the watched URL
* Moved the package to Git
* Switch to debhelper level 9
2013-01-12 - tony mancill <tmancill@debian.org>
plexus-cipher (1.5-4) unstable; urgency=low
* Team upload.
* Add patch for test case that fails on fast systems.
- Thanks to Sjoerd Simons. (Closes: #697919)
* Remove Michael Koch from Uploaders. (Closes: #654125)
* Bump Standard-Version to 3.9.4 (no changes).
2012-09-13 - Miguel Landaeta <miguel@miguel.cc>
plexus-cipher (1.5-3) unstable; urgency=low
[ Miguel Landaeta ]
* Team upload.
* Install jars in /usr/share/java. (Closes: #687541).
[ tony mancill ]
* Bump Standard-Version to 3.9.3 (no changes).
* Update d/copyright.
2011-08-25 - Torsten Werner <twerner@debian.org>
plexus-cipher (1.5-2) unstable; urgency=low
* Team upload.
* Update debian/watch.
* Update Homepage.
* Update Standards-Version: 3.9.1.
* Switch to source format 3.0.
* Use Maven to build package.
* Add a documentation package.
2009-10-25 - Michael Koch <konqueror@gmx.de>
plexus-cipher (1.5-1) unstable; urgency=low
* New upstream release.
* Updated debhelper to >= 7.
* Added myself to Uploaders.
* Updated Standards-Version to 3.8.3.
2009-08-14 - Ludovic Claude <ludovic.claude@laposte.net>
plexus-cipher (1.4-2) unstable; urgency=low
* Update copyright notice after reading NOTICE.txt
* Change Build-Depends to default-jdk as gcj is not used
* debian/rules: compile against plexus-container-default-alpha
2009-05-02 - Ludovic Claude <ludovic.claude@laposte.net>
plexus-cipher (1.4-1) unstable; urgency=low
* Initial release. (Closes: #526588)

See Also

Package Description
libplexus-classworlds-java-doc_2.5.2-2_all.deb Class loading utilities for the Plexus framework - documentation
libplexus-classworlds-java_2.5.2-2_all.deb Class loading utilities for the Plexus framework
libplexus-classworlds2-java_2.5.2-2_all.deb Class loading utilities for the Plexus framework (transitional package)
libplexus-cli-java-doc_1.2-7_all.deb Documentation for Plexus CLI
libplexus-cli-java_1.2-7_all.deb Easily create CLIs with Plexus components
libplexus-compiler-java-doc_2.8.3-1_all.deb Documentation for The API for the Plexus compiler system
libplexus-compiler-java_2.8.3-1_all.deb Plexus compiler system
libplexus-component-annotations-java_1.7.1-7_all.deb Plexus Component Annotations
libplexus-component-metadata-java_1.7.1-7_all.deb Component Metadata Maven plugin for Plexus
libplexus-container-default-java_1.7.1-7_all.deb Plexus Inversion-of-control Container
libplexus-container-default1.5-java_1.7.1-7_all.deb Plexus Inversion-of-control Container (transitional package)
libplexus-digest-java-doc_1.1-5_all.deb Documentation for Digest utilities for the Plexus system
libplexus-digest-java_1.1-5_all.deb Digest utilities for the Plexus system
libplexus-i18n-java-doc_1.0-beta-10-4_all.deb API Documentation for plexus-i18n
libplexus-i18n-java_1.0-beta-10-4_all.deb a component to support internationalization of applications using Plexus
Advertisement
Advertisement