libpjsua2_2.7.2~dfsg-1_i386.deb


Advertisement

Description

libpjsua2 - PJ Project - Basic VoIP client library

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libpjsua2
Package version 2.7.2~dfsg
Package release 1
Package architecture i386
Package type deb
Installed size 354 B
Download size 126.67 KB
Official Mirror archive.ubuntu.com
PJSIP (a.k.a PJProject) is a multimedia communication library written
in C language implementing standard based protocols such as SIP, SDP,
RTP, STUN, TURN, and ICE. It combines signaling protocol (SIP) with rich
multimedia framework and NAT traversal functionality into high level API
that is portable and suitable for almost any type of systems ranging
from desktops, embedded systems, to mobile handsets.
This package includes a framework for a VoIP client (pjsua)

Alternatives

Package Version Architecture Repository
libpjsua2_2.7.2~dfsg-1_amd64.deb 2.7.2~dfsg amd64 Ubuntu Universe
libpjsua2 - - -

Requires

Name Value
libc6 >= 2.4
libpj2 >= 2.5.5~dfsg
libpjlib-util2 >= 2.5.5~dfsg
libpjmedia-audiodev2 >= 2.5.5~dfsg
libpjmedia-codec2 >= 2.5.5~dfsg
libpjmedia-videodev2 >= 2.5.5~dfsg
libpjmedia2 >= 2.6~dfsg
libpjnath2 >= 2.5.5~dfsg
libpjsip-simple2 >= 2.5.5~dfsg
libpjsip-ua2 >= 2.5.5~dfsg
libpjsip2 >= 2.7~dfsg

Download

Type URL
Binary Package libpjsua2_2.7.2~dfsg-1_i386.deb
Source Package pjproject

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpjsua2 deb package:
    # sudo apt-get install libpjsua2

Files

Path
/usr/lib/i386-linux-gnu/libpjsua.so.2
/usr/share/doc/libpjsua2/changelog.Debian.gz
/usr/share/doc/libpjsua2/copyright

Changelog

2018-02-24 - Bernhard Schmidt <berni@debian.org>
pjproject (2.7.2~dfsg-1) unstable; urgency=medium
* New upstream version, fixing two remote crashes
- Crash when receiving SDP with invalid fmtp attribute
- Crash when parsing SDP with an invalid media format description
* Mark binary packages linux-any, FTBFSing on hurd/kfreebsd
* Drop duplicate filter line in d/gbp.conf
* Switch Vcs-* to salsa
2017-11-09 - Bernhard Schmidt <berni@debian.org>
pjproject (2.7.1~dfsg-1) unstable; urgency=medium
* New upstream release
+ Adjust symbols
2017-10-05 - Bernhard Schmidt <berni@debian.org>
pjproject (2.7~dfsg-1) unstable; urgency=medium
[ Bernhard Schmidt ]
* New upstream release
+ Repack with Jonas' updated copyright information (Closes: #877365)
+ Drop security patches applied upstream
+ Update symbols
* Switch to libsrtp2
+ add Breaks against Asterisk built with libsrtp0
* Change section of libraries to "libs", silencing lintian
* Declare Standards-Version 4.1.1, no changes necessary
* Enable all hardening
[ Jonas Smedegaard ]
* Update copyright info:
+ Use (derived form of) SPDX license shortname Rdisc.
+ Use https protocol in format URL.
+ Normalize http URLs.
+ Use License-Grant and License-Reference fields.
+ Fix list pjlib/src/pj/compat/longjmp_i386.S as licensed LGPL-2+
(not LGPL-2.1+).
+ Fix cover files licensed FSFUL NTP Ms-PL Expat.
+ Fix cover file licensed BSD-4-clause and GPL-2+ (not only GPL-2+).
+ Fix remove files listed as stripped from source repackaging but
not existing in upstream source:
- third_party/yuv
- third_party/webrtc.
+ Rewrite notes on files stripped from repackaged source.
+ Fix strip more files when repackaging source:
- Non-DFSG-free ApiLock.*.
- Copyright-protected graphics ICC profiles without DFSG-free
license.
- Binary Java files potentially with non-free parts.
+ Rewrite maintainer script copyright-check.
2017-08-17 - Bernhard Schmidt <berni@debian.org>
pjproject (2.6~dfsg-2) unstable; urgency=medium
* Add libavdevice-dev to libpjproject-dev Depends
* Reinclude libssl-dev dependency that was dropped during migration
* Drop useless-autoreconf-build-depends
2017-08-15 - Bernhard Schmidt <berni@debian.org>
pjproject (2.6~dfsg-1) unstable; urgency=medium
* Release to unstable
* change Standards-Version to 4.0.1, no changes necessary
* add debian/gbp.conf for pristine-tar
2017-08-06 - Bernhard Schmidt <berni@debian.org>
pjproject (2.6~dfsg-0+exp2) experimental; urgency=medium
* Build with -Wl,--as-needed
- disable unnecessary 0006-Reduce-linkage-of-unused-libraries.patch
- also disable 0001-Remove-pointless-linking-with-libasound.patch
breaking compilation
* drop symbols for (largely unused) C++ library
2017-06-24 - Bernhard Schmidt <berni@debian.org>
pjproject (2.6~dfsg-0+exp1) experimental; urgency=medium
* New upstream version 2.6
- dfsg: Exclude third_party/webrtc, not sure if distributable
- Drop patches applied upstream
- refresh remaining patches
- update symbols
* Disable webrtc build
* Switch to OpenSSL 1.1.0 (Closes: #854583)
2017-06-02 - Bernhard Schmidt <berni@debian.org>
pjproject (2.5.5~dfsg-6) unstable; urgency=high
[ Tzafrir Cohen ]
* add security patches published by the Asterisk project
- AST-2017-002: Buffer Overrun in PJSIP transaction layer
(Closes: #863901)
- AST-2017-003: Crash in PJSIP multi-part body parser
(Closes: #863902)
2016-12-18 - Bernhard Schmidt <berni@debian.org>
pjproject (2.5.5~dfsg-5) unstable; urgency=medium
[ Bernhard Schmidt ]
* run dh_clean in clean target
* Disable debug assertions as recommended for production builds

See Also

Package Description
libpkgconfig-perl_0.19026-1_all.deb Pure-Perl Core-Only replacement for pkg-config
libplacebo-dev_0.4.0-2_i386.deb GPU-accelerated video/image rendering primitives (development files)
libplacebo4_0.4.0-2_i386.deb GPU-accelerated video/image rendering primitives (shared library)
libplack-app-proxy-perl_0.29-1_all.deb Plack::App::Proxy - middleware-aware proxy application for Plack
libplack-builder-conditionals-perl_0.05-1_all.deb Plack::Builder extension for Conditionals
libplack-handler-anyevent-fcgi-perl_0.01-1_all.deb asynchronous FCGI handler for PSGI using AnyEvent::FCGI
libplack-middleware-cache-perl_0.14-1_all.deb Plack middleware for caching responses of certain URLs
libplack-middleware-crossorigin-perl_0.012-1_all.deb Plack middleware adding headers to allow CORS
libplack-middleware-csrfblock-perl_0.10-2_all.deb Plack middleware to block CSRF (cross-site request forgery)
libplack-middleware-deflater-perl_0.12-1ubuntu1_all.deb middleware to compress response body with gzip or deflate
libplack-middleware-expires-perl_0.06-1_all.deb mod_expires for plack
libplack-middleware-file-sass-perl_0.03-4_all.deb Sass and SCSS support for all Plack-based PSGI frameworks
libplack-middleware-fixmissingbodyinredirect-perl_0.11-1_all.deb Plack::Middleware which ensures redirect response have a body
libplack-middleware-header-perl_0.04-1_all.deb Plack middleware to modify HTTP response headers
libplack-middleware-logany-perl_0.001-1_all.deb use Log::Any to handle logging from your Plack app
Advertisement
Advertisement