libpion-dev_5.0.7+dfsg-4_i386.deb


Advertisement

Description

libpion-dev - lightweight HTTP interface library - development files

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libpion-dev
Package version 5.0.7+dfsg
Package release 4
Package architecture i386
Package type deb
Installed size 648 B
Download size 114.63 KB
Official Mirror archive.ubuntu.com
pion is not intended to implement yet another web server, but to
provide HTTP(S) functionality to new or existing C++ applications. If
you're looking for a full-featured server application, check out Apache
or lighttpd. If you're working on a Boost C++ application and would just
like to use HTTP to provide a simple user interface or interact with
run-time data, then pion is a clean and simple solution.
Pion Network Library uses the Boost and asio libraries for multi-threading
and asynchronous I/O. This allows servers implemented using pion to
handle many thousands of connections simultaneously with a single physical
server.
pion also supports server-side SSL & TLS encryption when built with
the OpenSSL library (which the Debian package is).
This package includes the pion development files.

Alternatives

Package Version Architecture Repository
libpion-dev_5.0.7+dfsg-4_amd64.deb 5.0.7+dfsg amd64 Ubuntu Universe
libpion-dev - - -

Requires

Name Value
libboost-filesystem1.62.0 -
libboost-system1.62.0 -
libboost-thread1.62.0 -
libc6 >= 2.8
libgcc1 >= 1:3.0
liblog4cpp5-dev -
liblog4cpp5v5 -
libpion-5.0 = 5.0.7+dfsg-4
libpion-plugins = 5.0.7+dfsg-4
libssl-dev -
libssl1.0.0 >= 1.0.2~beta3
libstdc++6 >= 5.2

Conflicts

Name Value
libpion-net-dev -

Download

Type URL
Binary Package libpion-dev_5.0.7+dfsg-4_i386.deb
Source Package pion

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpion-dev deb package:
    # sudo apt-get install libpion-dev

Files

Path
/usr/bin/helloserver
/usr/bin/piond
/usr/include/pion/admin_rights.hpp
/usr/include/pion/algorithm.hpp
/usr/include/pion/config.hpp
/usr/include/pion/error.hpp
/usr/include/pion/hash_map.hpp
/usr/include/pion/logger.hpp
/usr/include/pion/plugin.hpp
/usr/include/pion/plugin_manager.hpp
/usr/include/pion/process.hpp
/usr/include/pion/scheduler.hpp
/usr/include/pion/user.hpp
/usr/include/pion/http/auth.hpp
/usr/include/pion/http/basic_auth.hpp
/usr/include/pion/http/cookie_auth.hpp
/usr/include/pion/http/message.hpp
/usr/include/pion/http/parser.hpp
/usr/include/pion/http/plugin_server.hpp
/usr/include/pion/http/plugin_service.hpp
/usr/include/pion/http/reader.hpp
/usr/include/pion/http/request.hpp
/usr/include/pion/http/request_reader.hpp
/usr/include/pion/http/request_writer.hpp
/usr/include/pion/http/response.hpp
/usr/include/pion/http/response_reader.hpp
/usr/include/pion/http/response_writer.hpp
/usr/include/pion/http/server.hpp
/usr/include/pion/http/types.hpp
/usr/include/pion/http/writer.hpp
/usr/include/pion/plugins/AllowNothingService.hpp
/usr/include/pion/plugins/CookieService.hpp
/usr/include/pion/plugins/EchoService.hpp
/usr/include/pion/plugins/FileService.hpp
/usr/include/pion/plugins/HelloService.hpp
/usr/include/pion/plugins/LogService.hpp
/usr/include/pion/spdy/decompressor.hpp
/usr/include/pion/spdy/parser.hpp
/usr/include/pion/spdy/types.hpp
/usr/include/pion/tcp/connection.hpp
/usr/include/pion/tcp/server.hpp
/usr/include/pion/tcp/stream.hpp
/usr/include/pion/tcp/timer.hpp
/usr/include/pion/test/unit_test.hpp
/usr/lib/i386-linux-gnu/libpion.so
/usr/lib/i386-linux-gnu/pkgconfig/pion.pc
/usr/share/doc/libpion-dev/NEWS.gz
/usr/share/doc/libpion-dev/README.md
/usr/share/doc/libpion-dev/TODO
/usr/share/doc/libpion-dev/changelog.Debian.gz
/usr/share/doc/libpion-dev/copyright
/usr/share/lintian/overrides/libpion-dev

Changelog

2016-12-23 - Roberto C. Sanchez <roberto@connexer.com>
pion (5.0.7+dfsg-4) unstable; urgency=medium
* Fix FTBFS, do not let arch-dependent actions leak to arch-independent
installation target, patch from Santiago Vila (Closes: #848860)
2016-12-09 - Roberto C. Sanchez <roberto@connexer.com>
pion (5.0.7+dfsg-3) unstable; urgency=medium
* Fix FTBFS, build unit tests unoptimized on arm64 to work around a
spurious null pointer dereference (Closes: #847133)
2016-12-04 - Roberto C. Sanchez <roberto@connexer.com>
pion (5.0.7+dfsg-2) unstable; urgency=medium
* Fix FTBFS with gcc6 (narrowing conversion), thanks to Graham Inggs
for the patch (Closes: #846573)
2016-12-01 - Roberto C. Sanchez <roberto@connexer.com>
pion (5.0.7+dfsg-1) unstable; urgency=medium
* New upstream release (Closes: #825099, #828504)
* Update to Standards-Version 3.9.8 (no changes)
* Fix FTBFS with gcc6, thanks to Graham Inggs for the patch
(Closes: #811849)
* Update to debhelper compatibility level 9 (rework debian/rules)
* Switch to generated -dbg package
2015-07-06 - Roberto C. Sanchez <roberto@connexer.com>
pion (5.0.6+dfsg-1) unstable; urgency=low
* New upstream release
* Update to Standards-Version 3.9.6 (no changes)
* Strip -D_FORTIFY_SOURCE=2 from CPPFLAGS to prevent spurious inclusion
in pion.pc
2014-03-11 - Roberto C. Sanchez <roberto@connexer.com>
pion (5.0.5+dfsg-1) unstable; urgency=low
* New upstream release
2013-11-02 - Roberto C. Sanchez <roberto@connexer.com>
pion (5.0.4+dfsg-2) unstable; urgency=low
* Fix FTBFS on big endian architectures, thanks to Aurelien Jarno
for the patch (Closes: #728320)
* Update to Standards-Version 3.9.5 (no changes)
2013-09-23 - Roberto C. Sanchez <roberto@connexer.com>
pion (5.0.4+dfsg-1) unstable; urgency=low
* New upstream release
* Make libpion-dev, libpion-plugins, and libpion-plugins-dev conflict
with their counterparts from the old package (Closes: #719771, #719772)
* Add get-orig-source target to debian/rules
2013-08-03 - Roberto C. Sanchez <roberto@connexer.com>
pion (5.0.3+dfsg-1) unstable; urgency=low
* New upstream release
2013-07-06 - Roberto C. Sanchez <roberto@connexer.com>
pion (5.0.1+dfsg-1) unstable; urgency=low
* Acknowledge NMU, thanks to Matthias Klose
* New upstream release (Closes: #701336, #708802)
* Source package renamed as a result of upstream changes: pion-net -> pion
* Binary packages renamed:
+ libpion-net-4.0 and libpion-common-4.0 -> libpion-5.0
+ libpion-net-dev and libpion-common-dev -> libpion-dev
* Update watch file
* Update copyright information
* Update to Standards-Version 3.9.4 (no changes)
* Enable compilation with hardening flags
* Add dependencies:
+ liblog4cpp5-dev for libpion-dev (Closes: #678433) (LP: #881632)
+ libssl-dev for libpion-dev (Closes: #678435)
* Ship headers for the plugins (LP: #1012022)

See Also

Package Description
libpion-doc_5.0.7+dfsg-4_all.deb lightweight HTTP interface library - documentation
libpion-plugins_5.0.7+dfsg-4_i386.deb lightweight HTTP interface library - plugins
libpipebang-camlp4-dev_113.00.00-2build1_i386.deb OCaml Syntax extension to transform pipe expressions
libpirl-java-doc_2.3.8-2_all.deb PIRL Java Packages Documentation
libpirl-java_2.3.8-2_all.deb PIRL Java Packages
libpisock-dev_0.12.5-dfsg-2build2_i386.deb development files for communicating with a PalmOS PDA
libpisock9_0.12.5-dfsg-2build2_i386.deb library for communicating with a PalmOS PDA
libpisync1_0.12.5-dfsg-2build2_i386.deb synchronization library for PalmOS devices
libpithub-perl_0.01033-1_all.deb Github v3 API
libpixelif-common_0.8.4-2_all.deb Provides localization and font data for libpixelif
libpixelif-dev_0.8.4-2_i386.deb Interface translating fizmo output into pixel data
libpixelmed-codec-java_20170512-1_all.deb some imaging codecs for pixelmed DICOM image and ECG viewer
libpixelmed-java-doc_20150917-2_all.deb DICOM implementation containing Image Viewer and a ECG Viewer - doc
libpixelmed-java_20150917-2_all.deb DICOM implementation containing Image Viewer and a ECG Viewer
libpixels-java_2.1.3+svn.42-2_all.deb manipulation and filtering of images in Java
Advertisement
Advertisement