libpimcommon4_4.14.10-7_i386.deb


Advertisement

Description

libpimcommon4 - library for common bits of KDEPIM

Property Value
Distribution Ubuntu 18.04 LTS (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libpimcommon4
Package version 4.14.10
Package release 7
Package architecture i386
Package type deb
Installed size 1.84 KB
Download size 491.68 KB
Official Mirror archive.ubuntu.com
This internal library is for sharing some common bits between
the applications in KDEPIM

Alternatives

Package Version Architecture Repository
libpimcommon4_4.14.10-7_amd64.deb 4.14.10 amd64 Ubuntu Universe
libpimcommon4 - - -

Requires

Name Value
libakonadi-contact4 >= 4:4.14.8~
libakonadi-kde4 >= 4:4.14.8~
libc6 >= 2.4
libgcc1 >= 1:3.0
libkabc4 >= 4:4.14.8~
libkdecore5 >= 4:4.14.0~
libkdepim4 = 4:4.14.10-7
libkdeui5 >= 4:4.14.0~
libkimap4 >= 4:4.14.8~
libkio5 >= 4:4.14.0~
libknewstuff3-4 >= 4:4.14.0~
libkpimtextedit4 >= 4:4.14.8~
libkpimutils4 >= 4:4.14.8~
libqjson0 >= 0.7.1
libqt4-dbus >= 4:4.5.3
libqt4-network >= 4:4.7.0~beta1
libqt4-xml >= 4:4.5.3
libqtcore4 >= 4:4.7.0~beta1
libqtgui4 >= 4:4.7.0~beta1
libqtwebkit4 -
libsolid4 >= 4:4.14.0~
libstdc++6 >= 5

Download

Type URL
Binary Package libpimcommon4_4.14.10-7_i386.deb
Source Package kdepim4

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpimcommon4 deb package:
    # sudo apt-get install libpimcommon4

Files

Path
/usr/lib/libpimcommon.so.4
/usr/lib/libpimcommon.so.4.14.16
/usr/share/doc/libpimcommon4/changelog.Debian.gz
/usr/share/doc/libpimcommon4/copyright
/usr/share/lintian/overrides/libpimcommon4

Changelog

2016-08-09 - Pino Toscano <pino@debian.org>
kdepim4 (4:4.14.10-7) unstable; urgency=medium
* Team upload.
* Remove the handling of kalarm icons, as kalarm is no more built by this
source.
* Disable the build of most of the unused applications and libraries:
- disable the build of mobile stuff (-DKDEPIM_BUILD_MOBILE=false to cmake)
- pass -DBUILD_<foo>=false to cmake to disable console, akonadiconsole,
akregator, blogilo, grantleeeditor, importwizard, kaddressbook, kalarm,
kjots, kleopatra, kmail, kmailcvt, knotes, kontact, korgac, korganizer,
ksendemail, ktnef, mboximporter, pimsettingexporter, sieveeditor, and
storageservicemanager
* Do not install the Qt Designer plugins and their icons, as there is no
development stuff.
* Do not install unused libraries.
- remove unused packages: libmailcommon4, libmailimporter4
* Update install files.
* The above install cleanups should fix the circular dependencies because of
libkdepim4. (Closes: #729363)
* Remove unused build dependencies: akonadi-server, libkactivities-dev,
libprison-dev, libqt4-opengl-dev, libsearchclient-dev, libsoprano-dev,
libxml2-dev, and sharutils.
* Update Vcs-* fields.
* Update the patches:
- debianize_akregator_default.diff: drop, no more needed
- kubuntu_debianize_akregator_default.diff: drop, no more needed
- kubuntu_install_headers.diff: drop, no more needed
- disable_has_focus_tests_failed_in_xvfb.patch: drop, tests are not run
- disable_test_verify: drop, stale file
- spambayes.patch: drop, stale file
* Install the knode and ktimetracker documentations in the application
packages; add proper breaks/replaces against old kdepim-doc versions.
* Update not-installed file.
* Fix typo in description of libkdgantt2-0.
* Update lintian overrides.
* Remove useless debian/docs file, not needed for knode.
* Bump Standards-Version to 3.9.8, no changes required.
* Add a simple description for libsendlater4. (Closes: #731301)
2016-07-13 - Maximiliano Curia <maxy@debian.org>
kdepim4 (4:4.14.10-6) unstable; urgency=medium
* Drop kgapi build dependency.
Thanks to Jeremy Bicha for the report (Closes: 830511)
2016-07-07 - Maximiliano Curia <maxy@debian.org>
kdepim4 (4:4.14.10-5) unstable; urgency=low
* Release to unstable.
2016-07-04 - Maximiliano Curia <maxy@debian.org>
kdepim4 (4:4.14.10-4) unstable; urgency=low
* Release to unstable.
2016-06-28 - Maximiliano Curia <maxy@debian.org>
kdepim4 (4:4.14.10-3) experimental; urgency=medium
* Rename source package to keep only knode and ktimetracker.
* Migrate to the automatic dbgsym packages
* Drop build depends indep
* Drop link-grammar build dependency
* Remove images installed by korganizer
2015-09-03 - Scott Kitterman <scott@kitterman.com>
kdepim (4:4.14.10-2) unstable; urgency=medium
* Team upload.
* Add kdepim-mobileui-data Breaks/Replaces libmessageviewer4 (Closes:
#788465)
2015-09-01 - Maximiliano Curia <maxy@debian.org>
kdepim (4:4.14.10-1) unstable; urgency=medium
* New upstream release (4.14.6).
* New upstream release (4.14.7).
* New upstream release (4.14.8).
* New upstream release (4.14.9).
* New upstream release (4.14.10).
* Refresh patches.
* Add libsoprano-dev build dep.
* Update install files.
* New patch: workaround_boost_moc_ftbfs
2015-03-13 - Scarlett Clark <sgclark@kubuntu.org>
kdepim (4:4.14.6-0ubuntu1) vivid; urgency=medium
* New upstream release
* Update watch file
2015-02-24 - Maximiliano Curia <maxy@debian.org>
kdepim (4:4.14.5-1) experimental; urgency=medium
* Prepare Debian release (upstream 4.14.5).
* Bump Standards-Version to 3.9.6, no changes needed.
* Remove upstream patch: upstream_delete_the_part_from_the_mainwindow
* Remove upstream patch: upstream_fix_crash_on_logout
* Refresh patches.

See Also

Package Description
libpion-5.0_5.0.7+dfsg-4_i386.deb lightweight HTTP interface library - runtime files
libpion-dev_5.0.7+dfsg-4_i386.deb lightweight HTTP interface library - development files
libpion-doc_5.0.7+dfsg-4_all.deb lightweight HTTP interface library - documentation
libpion-plugins_5.0.7+dfsg-4_i386.deb lightweight HTTP interface library - plugins
libpipebang-camlp4-dev_113.00.00-2build1_i386.deb OCaml Syntax extension to transform pipe expressions
libpirl-java-doc_2.3.8-2_all.deb PIRL Java Packages Documentation
libpirl-java_2.3.8-2_all.deb PIRL Java Packages
libpisock-dev_0.12.5-dfsg-2build2_i386.deb development files for communicating with a PalmOS PDA
libpisock9_0.12.5-dfsg-2build2_i386.deb library for communicating with a PalmOS PDA
libpisync1_0.12.5-dfsg-2build2_i386.deb synchronization library for PalmOS devices
libpithub-perl_0.01033-1_all.deb Github v3 API
libpixelif-common_0.8.4-2_all.deb Provides localization and font data for libpixelif
libpixelif-dev_0.8.4-2_i386.deb Interface translating fizmo output into pixel data
libpixelmed-codec-java_20170512-1_all.deb some imaging codecs for pixelmed DICOM image and ECG viewer
libpixelmed-java-doc_20150917-2_all.deb DICOM implementation containing Image Viewer and a ECG Viewer - doc
Advertisement
Advertisement