libpetsc-complex-3.7-dev_3.7.7+dfsg1-2build5_i386.deb


Advertisement

Description

libpetsc-complex-3.7-dev - Static libraries, shared links, header files for PETSc

Property Value
Distribution Ubuntu 18.04 (Bionic Beaver)
Repository Ubuntu Universe i386
Package name libpetsc-complex-3.7-dev
Package version 3.7.7+dfsg1
Package release 2build5
Package architecture i386
Package type deb
Installed size 31 B
Download size 3.98 KB
Official Mirror archive.ubuntu.com
PETSc is the "Portable Extensible Toolkit for Scientific Computation", a suite
of data structures and routines for the scalable (parallel) solution of
scientific applications modeled by partial differential equations.  It employs
the MPI standard for all message-passing communication.  Several sample
scientific applications, as well as various papers and talks, demonstrate the
features of the PETSc libraries.
This is a dummy package which depends on the latest version of PETSc 3.7
to provide the development files needed for building applications with support
for complex numbers.
The library soname is 3.7 (without specifying the patch version), so if you
want to build against PETSc 3.7 with support for complex numbers then you
probably want to use this package.

Alternatives

Package Version Architecture Repository
libpetsc-complex-3.7-dev_3.7.7+dfsg1-2build5_amd64.deb 3.7.7+dfsg1 amd64 Ubuntu Universe
libpetsc-complex-3.7-dev - - -

Requires

Name Value
libpetsc-complex-3.7.7-dev -

Provides

Name Value
petsc-complex-3.7-dev -

Download

Type URL
Binary Package libpetsc-complex-3.7-dev_3.7.7+dfsg1-2build5_i386.deb
Source Package petsc

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libpetsc-complex-3.7-dev deb package:
    # sudo apt-get install libpetsc-complex-3.7-dev

Files

Path
/usr/share/doc/libpetsc-complex-3.7-dev/changelog.Debian.gz
/usr/share/doc/libpetsc-complex-3.7-dev/copyright

Changelog

2018-02-05 - Dimitri John Ledkov <xnox@ubuntu.com>
petsc (3.7.7+dfsg1-2build5) bionic; urgency=high
* No change rebuild against openssl1.1.
2017-12-20 - Gianfranco Costamagna <locutusofborg@debian.org>
petsc (3.7.7+dfsg1-2build4) bionic; urgency=medium
* Rebuild against new libmumps-5.1.2.
2017-12-12 - Gianfranco Costamagna <locutusofborg@debian.org>
petsc (3.7.7+dfsg1-2build3) bionic; urgency=medium
* Rebuild against new hypre 2.13.
2017-11-29 - Steve Langasek <steve.langasek@ubuntu.com>
petsc (3.7.7+dfsg1-2build2) bionic; urgency=medium
* No-change rebuild against libscalapack-openmpi2.0
2017-11-22 - Steve Langasek <steve.langasek@ubuntu.com>
petsc (3.7.7+dfsg1-2build1) bionic; urgency=medium
* No-change rebuild against libptscotch-6.0
2017-10-19 - Drew Parsons <dparsons@debian.org>
petsc (3.7.7+dfsg1-2) unstable; urgency=medium
* Team upload.
* Standards-Version: 4.1.1
* debian/control Priority: optional (Priority: extra is deprecated)
2017-09-29 - Drew Parsons <dparsons@debian.org>
petsc (3.7.7+dfsg1-1) experimental; urgency=medium
* Team upload.
* New upstream version. Last release before PETSc 3.8.
* Standards-Version: 4.1.0
2017-07-27 - Drew Parsons <dparsons@debian.org>
petsc (3.7.6+dfsg1-3) unstable; urgency=medium
* create mpi-version-test.patch to relax MPI version test to match
minor, not patch (release) version in include/petscsys.h. Should
simplify future openmpi upgrades, see debian/extract_MPI_dependency.
Taken from upstream git (commits ca70f86, 41f4af4). Closes: #865526.
* remove dependencies on libblacs-mpi-dev (explicit blacs support
has not been a PETSc configuration option since 3.4)
* drop Build-Depends: autotools-dev (autoreconf is now automatic in
debhelper compat 10)
2017-07-15 - Drew Parsons <dparsons@debian.org>
petsc (3.7.6+dfsg1-2) unstable; urgency=medium
* Team upload.
* Standards-Version: 4.0.0
* debhelper compatibility level 10
* debian/rules: build using make -j 1 
(petsc uses MAKE_NP to handle parallel builds, 
see lib/petsc/conf/rules)
2017-05-30 - Drew Parsons <dparsons@debian.org>
petsc (3.7.6+dfsg1-1exp1) experimental; urgency=medium
* New upstream version.
* libpetsc-3.7.6-dev, libpetsc-complex-3.7.6-dev Suggests: 
relax to unversioned dependency on petsc-dev, petsc3.7.6-doc

See Also

Package Description
libpetsc-complex-3.7.7-dev_3.7.7+dfsg1-2build5_i386.deb Static libraries, shared links, header files for PETSc
libpetsc-complex-3.7.7_3.7.7+dfsg1-2build5_i386.deb Shared libraries for version 3.7 of PETSc with Complex Numbers
libpetsc3.7-dev_3.7.7+dfsg1-2build5_i386.deb Static libraries, shared links, header files for PETSc
libpetsc3.7.7-dev_3.7.7+dfsg1-2build5_i386.deb Static libraries, shared links, header files for PETSc
libpetsc3.7.7_3.7.7+dfsg1-2build5_i386.deb Shared libraries for version 3.7 of PETSc
libpff-dev_20120802-5.1_i386.deb library to access various ms outlook files formats (development)
libpff1_20120802-5.1_i386.deb library to access various ms outlook files formats
libpfqueue-dev_0.5.6-9build2_i386.deb interactive console-based tool to control MTA queues (development)
libpfqueue0_0.5.6-9build2_i386.deb interactive console-based tool to control MTA queues (library)
libpfs-dev_2.1.0-3_i386.deb C++ library to read and write pfs files (development files)
libpfs2_2.1.0-3_i386.deb C++ library to read and write pfs files
libpg-hstore-perl_1.06-1build2_i386.deb Perl module for working with PostgreSQLs HSTORE data type
libpg-perl_2.1.1-5build4_i386.deb Perl modules for PostgreSQL
libpgf-dev_6.14.12-3.2_i386.deb Progressive Graphics File (PGF) library - development files
libpgf6_6.14.12-3.2_i386.deb Progressive Graphics File (PGF) library - runtime files
Advertisement
Advertisement